Installation fails; cannot create install.log
This article provides a fix for a failed installation due to the Setup Wizard not creating the install.log
during the installation.
Issue
Running Adobe Commerce processes at the same time might result in problems creating the installation log. (For example, two different installations in separate tab pages.)
Cause
Installation-fails-cannot-create-install.log
Review your setting for open_basedir
in php.ini
. The Setup Wizard uses the sys_get_temp_dir ( void ) PHP call to get the value of the temporary directory. If open_basedir is set to refuse connections to a directory specified by sys_get_temp_dir
, the installation fails.
Review your setting for open_basedir
in php.ini
. The Setup Wizard uses the sys_get_temp_dir ( void ) PHP call to get the value of the temporary directory. If open_basedir is set to refuse connections to a directory specified by sys_get_temp_dir
, the installation fails.
Solution
To resolve the issue, change the value of open_basedir
and restart the webserver.
If you’re not sure how to change this value, use the following steps:
- If you haven’t already done so, create phpinfo.php.
- Enter the following URL in your browser’s address or location field:
https://<your web server IP or hostname>/<path to docroot>/phpinfo.php
- Look for the location of
php.ini
.php.ini
is typically specified as Loaded Configuration File in the displayed results. - As a user with root privileges, open
php.ini
in a text editor. - Locate the value of
open_basedir
and change it. - Save your changes to
php.ini
. - Restart the webserver.