Installation fails; cannot create install.log

This article provides a fix for a failed installation due to the Setup Wizard not creating the install.log during the installation.

Issue

Running Adobe Commerce processes at the same time might result in problems creating the installation log. (For example, two different installations in separate tab pages.)

Cause

Installation-fails-cannot-create-install.log
Review your setting for open_basedir in php.ini. The Setup Wizard uses the sys_get_temp_dir ( void ) PHP call to get the value of the temporary directory. If open_basedir is set to refuse connections to a directory specified by sys_get_temp_dir, the installation fails.
Review your setting for open_basedir in php.ini. The Setup Wizard uses the sys_get_temp_dir ( void ) PHP call to get the value of the temporary directory. If open_basedir is set to refuse connections to a directory specified by sys_get_temp_dir, the installation fails.

Solution

To resolve the issue, change the value of open_basedir and restart the webserver.

If you’re not sure how to change this value, use the following steps:

  1. If you haven’t already done so, create phpinfo.php.
  2. Enter the following URL in your browser’s address or location field: https://<your web server IP or hostname>/<path to docroot>/phpinfo.php
  3. Look for the location of php.ini. php.ini is typically specified as Loaded Configuration File in the displayed results.
  4. As a user with root privileges, open php.ini in a text editor.
  5. Locate the value of open_basedir and change it.
  6. Save your changes to php.ini.
  7. Restart the webserver.
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