New customers not displayed in Customer grid after CSV import
This article provides a fix for the issue when you cannot see new customers under Customers > All customers after an import from a .csv
file. The solution is to set the customer_grid
indexer to “Update on Save” mode and manually reindex the customer grid.
Affected versions
- Adobe Commerce on-premises 2.2.0 and later
- Adobe Commerce on cloud infrastructure 2.2.0 and later
Issue
After importing new customers from a .csv
file using the native Adobe Commerce import functionality, you might not be able to see the new customer records under Customers > All customers in the Admin until you manually reindex the customer_grid
indexer.
Cause
The “Update on Schedule” indexing mode in Adobe Commerce 2.2.0 and later does not support the customer_grid
indexer due to performance issues.
Solution
Configure the customer_grid
indexer to be reindexed using the “Update on Save” mode. To do this, take the following steps:
- Log in to the Commerce Admin.
- Click System > Tools > Index Management.
- Select the checkbox next to Customer Grid indexer.
- In the Actions drop-down list, select Update on Save.
- Click Submit.
We also recommend manually reindexing the customer_grid
indexer after configuring the indexing mode to ensure that the index is up to date and can work with cron. To manually reindex, use the following command:
bin/magento indexer:reindex customer_grid
More information
Links to related topics in our developer documentation: