Enable cache to avoid performance degradation

This article explains how to solve a slow site issue caused by certain Adobe Commerce cache types being disabled.

Affected products and versions

  • Adobe Commerce on cloud infrastructure 2.2.x, 2.3.x
  • Adobe Commerce on-premises 2.2.x, 2.3.x

Issue

You notice performance degradation. For example, the Checkout page is loading slowly, or the Apdex value decrease in New Relic.

Cause

One reason for performance degradation might be certain Adobe Commerce cache types being disabled.

Solution

  1. First, check the status of your Adobe Commerce cache, to see if this is the issue. For this, SSH to your environment and run the following command:

    code language-bash
    php bin/magento cache:status
    

    This would display the status of each cache type (“0” for disabled, “1” for enabled). Or you can get this information in the app/etc/env.php file.

  2. Investigate the disabled cache types. All Adobe Commerce cache types should be enabled, unless you received alternative guidance from Adobe. Third party extensions must not require disabling Adobe Commerce cache.

  3. If the investigation confirms that some cache types are disabled by mistake, enable them by running the following command for each cache type: php bin/magento cache:enable <your_disabled_cache_type>

If there are concerns and/or questions whether a certain Adobe Commerce cache type can or should be disabled, contact Adobe Commerce support asking for recommendations.

Adobe Commerce cache documentation in our developer documentation:

Other possible reasons for performance issues and solutions for them:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a