Magento Order Management System (OMS) for Adobe Commerce times out

This article provides a solution for the issue where the Magento Order Management System (OMS) for Adobe Commerce cannot register the locally installed micro-service with MOM using ngrok, because MOM times out when trying to callback.

Affected products and versions

  • Adobe Commerce 2.3.1
  • OMS
  • ngrok
WARNING
Disclaimer: Adobe Commerce does not recommend or endorse any particular tool for establishing tunnels. The preceding are suggestions only. For more information, consult the ngrok documentation.

Issue

Steps to reproduce

  1. Install Adobe Commerce on your local environment.
  2. Set up ngrok to create a tunnel to expose your local server.
  3. Try connecting to OMS.

Expected result

Connection established successfully.

Actual result

MCOM seems to timeout when trying to callback to the ngrok URL.

Cause

One of the possible reasons for the timeout is that servers are located geographically too far away, and connection takes too much time.

Solution

Add a parameter specifying your region when starting ngrok. Like the following:

./ngrok http 80 -region eu

The default region is US. See all possible values.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a