Limpieza de direcciones de vértice: no se permiten direcciones diferentes

Este artículo habla sobre la solución del problema en el cual cuando el usuario intenta ingresar una dirección de facturación y envío diferente, con la validación de direcciones de Vértice habilitada, la tienda no permitirá que el usuario la ingrese.

Productos y versiones afectados

  • Adobe Commerce local y Adobe Commerce en la infraestructura en la nube 2.3.5-p1

Problema

Pasos a seguir:

  1. Vaya a Administración > Tiendas > Configuración > Ventas > Limpieza de direcciones.
  2. Seleccione Habilitado de la lista desplegable Usar limpieza de direcciones de vértice y Guardar configuración.
  3. Vaya al front-end como invitado y añada un producto al carro de compras.
  4. Haga clic en el icono Carro de compras y Continuar con la compra.
  5. Rellene los campos de dirección.
  6. Seleccione el método de envío deseado y haga clic en Siguiente.
  7. Vuelve a hacer clic en el botón Siguiente.
  8. Anule la selección de Mis direcciones de facturación y envío son iguales e introduzca una nueva dirección de facturación (diferente a Dirección).
  9. Haga clic en el botón Actualizar y luego haga clic en Actualizar dirección.

Resultados esperados:

El usuario ve diferentes direcciones de facturación y envío.

Resultados reales:

Cuando el usuario pulsa Actualizar, las direcciones de facturación y envío vuelven a ser las mismas.

Causa

Error de verificación de dirección de vértice.

Solución

Deshabilite la verificación de direcciones de Vértice o actualice a 2.4.0.

Lectura relacionada

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a