Hinzufügen digitaler Assets zu Adobe Experience Manager as a Cloud Service Assets

Adobe Experience Manager Assets akzeptiert viele Arten von digitalen Assets aus vielen Quellen. Es speichert die Binärdateien und die erstellten Ausgabedarstellungen, kann die Asset-Verarbeitung mithilfe einer Vielzahl von Workflows durchführen und die Adobe Sensei-Services ermöglichen die Verteilung über viele Kanäle in vielen Oberflächen.

Adobe Experience Manager In wird der binäre Inhalt der hochgeladenen digitalen Dateien mit Rich-Metadaten, Smart-Tags, Ausgabedarstellungen und anderen DAM (Digital Asset Management)-Services erweitert. Sie können verschiedene Arten von Dateien (z. B. Bilder, Dokumente und Raw-Dateien) von Ihrem lokalen Ordner oder Netzlaufwerk in Experience Manager Assets hochladen.

Neben dem am häufigsten verwendeten Browser-Upload gibt es noch weitere Methoden zum Hinzufügen von Assets zum Experience Manager-Repository, einschließlich Desktop-Clients wie Adobe Asset Link oder Experience Manager-Desktop-Programm, Upload- und Aufnahmeskripte, die Kunden erstellen, und automatisierte Aufnahmeintegrationen, die als Experience Manager-Erweiterungen hinzugefügt werden.

Sie können zwar jede beliebige Binärdatei in Experience Manager hochladen und verwalten, aber die am häufigsten verwendeten Dateiformate bieten Unterstützung für zusätzliche Services, wie z. B. die Extraktion von Metadaten oder die Vorschau-/Ausgabedarstellungsgenerierung. Weitere Informationen finden Sie unter Unterstützte Dateiformate.

Sie können sich auch dafür entscheiden, die hochgeladenen Assets zusätzlich zu bearbeiten. Für den Ordner, in den die Assets hochgeladen werden, kann eine Reihe von Asset-Verarbeitungsprofilen konfiguriert werden, um spezifische Metadaten, Ausgabedarstellungen oder Bildbearbeitungs-Service hinzuzufügen. Weitere Informationen finden Sie unter Verarbeiten von Assets beim Hochladen.

Assets stellt die folgenden Upload-Methoden bereit. Adobe empfiehlt, dass Sie Ihren Anwendungsfall und die Anwendbarkeit einer Upload-Option verstehen, bevor Sie sie verwenden.

Upload-Methode Anwendungsfall Primärpersonen
Benutzeroberfläche der Assets-Konsole Gelegentliches Hochladen, einfaches Drücken und Ziehen, Finder-Upload. Verwenden Sie diese Option nicht, um eine große Anzahl von Assets hochzuladen. Alle Benutzer
Upload-API Für dynamische Entscheidungen beim Hochladen. Entwickler
Experience Manager -Desktop-Programm Asset-Aufnahme mit niedrigem Volumen, jedoch nicht zur Migration. Administrator, Marketingexperte
Adobe Asset Link Nützlich, wenn Kreative und Marketingexperten mit Assets aus den unterstützten Creative Cloud-Desktop-Programmen arbeiten. Kreative, Marketingexperte
Tool zur Asset-Massenaufnahme Empfohlen für umfangreiche Migrationen und gelegentliche Massenaufnahmen. Nur für unterstützte Datenspeicher. Administrator, Entwickler

Hochladen von Assets

Um eine Datei (oder mehrere Dateien) hochzuladen, können Sie diese auf Ihrem Desktop auswählen und in der Benutzeroberfläche (Webbrowser) in den Zielordner ziehen. Sie können den Upload auch über die Benutzeroberfläche starten.

  1. Navigieren Sie in der Assets-Benutzeroberfläche zu dem Speicherort, an dem Sie digitale Assets hinzufügen möchten.

  2. Führen Sie einen der folgenden Schritte aus, um die Assets hochzuladen:

    • Klicken Sie in der Symbolleiste auf Erstellen > Dateien. Sie können die Datei im angezeigten Dialogfeld bei Bedarf umbenennen.
    • Ziehen Sie die Assets in einem Browser, der HTML5 unterstützt, direkt auf die Assets-Benutzeroberfläche. Das Dialogfeld zum Umbenennen der Datei wird nicht angezeigt.

    create_menu

    Wenn Sie die Assets im Dialogfeld für die Dateiauswahl bei gedrückter Ctrl- oder Command-Taste markieren, können Sie mehrere Dateien auswählen. Bei Verwendung eines iPads können Sie jeweils nur eine Datei auswählen.

  3. Um einen laufenden Upload abzubrechen, klicken Sie auf „Schließen“ (X) neben der Fortschrittsleiste. Wenn Sie den Upload abbrechen, löscht Assets den teilweise hochgeladenen Teil des Assets.
    Wenn Sie das Hochladen abbrechen, bevor die Dateien hochgeladen sind, unterbricht Assets den Upload der aktuellen Datei und aktualisiert den Inhalt. Dateien, die bereits hochgeladen wurden, werden jedoch nicht gelöscht.

  4. Das Dialogfeld für den Upload-Fortschritt in Assets zeigt die Anzahl der erfolgreich hochgeladenen Dateien und die der Dateien an, die nicht hochgeladen werden konnten.
    Darüber hinaus zeigt die Assets-Benutzeroberfläche das zuletzt hochgeladene Asset oder den Ordner an, den Sie zuerst erstellt haben.

HINWEIS

Informationen zum Hochladen verschachtelter Ordnerhierarchien finden Sie unter Massen-Upload von Assets.

Handhabung von Uploads, wenn das Asset bereits vorhanden ist

Sie können ein Asset mit demselben Pfad (demselben Namen und demselben Speicherort) hochladen wie ein vorhandenes Asset. Es wird jedoch ein Warndialogfeld mit den folgenden Optionen angezeigt:

  • Vorhandenes Asset ersetzen: Wenn Sie ein vorhandenes Asset ersetzen, werden die Metadaten für das Asset und sämtliche vorherigen Änderungen daran (z. B. Anmerkungen, Zuschnitte usw.) gelöscht.

    HINWEIS

    Die Option zum Ersetzen von Assets ist nicht verfügbar, wenn das Asset gesperrt oder ausgecheckt ist.

  • Eine andere Version erstellen: Eine neue Version des vorhandenen Assets wird im Repository erstellt. Sie können die beiden Versionen in der Zeitleiste anzeigen und bei Bedarf zur bereits vorhandenen Version zurückkehren.

  • Beides beibehalten: Wenn Sie beide Assets beibehalten, wird das neue Asset umbenannt.

Um das doppelte Asset in Assets beizubehalten, klicken Sie auf Behalten. Tippen oder klicken Sie auf Löschen, um das doppelte Asset zu löschen, das Sie gerade hochgeladen haben.

Behandlung von Dateinamen und unzulässige Zeichen

Experience Manager Assets versucht zu verhindern, dass Sie Assets hochladen, deren Dateinamen unzulässige Zeichen enthalten. Wenn Sie versuchen, ein Asset mit einem Dateinamen mit einem oder mehreren nicht zulässigen Zeichen hochzuladen, zeigt Assets eine Warnmeldung an und stoppt den Upload, bis Sie diese Zeichen entfernen oder mit einem zulässigen Namen hochladen.

Um bestimmte Dateibenennungskonventionen für Ihre Organisation einzuhalten, können Sie im Dialogfeld Assets hochladen lange Namen für die Dateien angeben, die Sie hochladen möchten. Die folgenden Zeichen (in der Liste durch Leerzeichen getrennt) werden nicht unterstützt:

  • Ungültige Zeichen für den Asset-Dateinamen * / : [ \\ ] | # % { } ? &
  • Ungültige Zeichen für den Asset-Ordnernamen * / : [ \\ ] | # % { } ? \" . ^ ; + & \t

Massen-Upload von Assets

Das Tool zur Asset-Massenaufnahme kann eine sehr große Anzahl von Assets effizient verarbeiten. Eine Aufnahme in großem Umfang ist jedoch nicht nur ein großer Datei-Dump oder eine gelegentliche Migration. Damit eine umfangreiche Aufnahme ein aussagekräftiges Projekt ist, das Ihrem Geschäftszweck dient und effizient ist, müssen Sie die Migration planen und die Organisation der Assets kuratieren. Alle Aufnahmen sind unterschiedlich. Berücksichtigen Sie daher anstelle einer Verallgemeinerung die differenzierte Zusammensetzung des Repositorys und die Geschäftsanforderungen. Im Folgenden finden Sie einige übergreifende Vorschläge zum Planen und Ausführen einer Massenaufnahme:

  • Assets kuratieren: Entfernen Sie Assets, die im DAM nicht benötigt werden. Sie sollten nicht verwendete, veraltete oder doppelte Assets entfernen. Dadurch werden die übertragenen Daten und die aufgenommenen Assets reduziert, was zu schnelleren Aufnahmen führt.
  • Assets organisieren: Sie sollten den Inhalt in einer logischen Reihenfolge organisieren, z. B. nach Dateigröße, Dateiformat, Anwendungsfall oder Priorität. Im Allgemeinen erfordern große, komplexe Dateien mehr Verarbeitung. Sie können auch in Betracht ziehen, große Dateien mithilfe der Dateigrößenfilteroption (siehe unten) separat aufzunehmen.
  • Aufnahmen staffeln: Erwägen Sie, Ihre Aufnahme in mehrere Massenaufnahmen zu unterteilen. Auf diese Weise können Sie Inhalte früher anzeigen und Ihre Aufnahme bei Bedarf aktualisieren. Beispielsweise können Sie verarbeitungsintensive Assets außerhalb der Spitzenzeiten oder schrittweise in mehreren Blöcken aufnehmen. Sie können aber auch kleinere und einfachere Assets, die nicht viel Verarbeitung erfordern, in einem Schritt aufnehmen.

Verwenden Sie einen der folgenden Ansätze, um eine größere Anzahl von Dateien hochzuladen. Weitere Informationen finden Sie unter Anwendungsfälle und Methoden.

  • Asset-Upload-APIs: Verwenden Sie ein benutzerdefiniertes Upload-Skript oder -Tool, das APIs nutzt, um bei Bedarf zusätzliche Verarbeitungsschritte für Assets hinzuzufügen (z. B. Metadaten übersetzen oder Dateien umbenennen).
  • Experience Manager -Desktop-Programm: Nützlich für Kreativprofis und Marketing-Experten, die Assets aus ihrem lokalen Dateisystem hochladen. Verwenden Sie diese Option, um lokal verfügbare verschachtelte Ordner hochzuladen.
  • Tool zur Massenaufnahme: Wird zum gelegentlichen oder anfänglichen Aufnehmen großer Mengen von Assets bei der Bereitstellung von Experience Manager verwendet.

Asset-Massenimport-Tool

Das Tool wird nur der Administratorgruppe zur Verfügung gestellt, um Assets in großem Umfang aus Azure- oder S3-Datenspeichern aufzunehmen. Sehen Sie sich eine Video-Anleitung zur Konfiguration und Aufnahme an.

Die folgende Abbildung zeigt die verschiedenen Phasen der Aufnahme von Assets in Experience Manager aus einem Datenspeicher:

Massenaufnahme-Tool

Voraussetzungen

Sie müssen über die Speicherdetails des Quell-Blob-Speichers verfügen, um Ihre Experience Manager-Instanz mit einem Datenspeicher zu verbinden.

Konfigurieren des Tools für den Massenimport

Gehen Sie wie folgt vor, um das Tool für den Massenimport zu konfigurieren:

  1. Navigieren Sie zu Tools > Assets > Massenimport. Wählen Sie die Option Erstellen aus.

  2. Geben Sie einen Titel für die Konfiguration des Massenimports in der Titel -Feld.

  3. Wählen Sie den Datenquellentyp aus der Importquelle Dropdown-Liste.

  4. Geben Sie die Werte an, um eine Verbindung mit der Datenquelle herzustellen. Wenn Sie beispielsweise Azure Blob Storage Geben Sie als Datenquelle die Werte für das Azure-Speicherkonto, den Azure-Blob-Container und den Azure-Zugriffsschlüssel an.

  5. Geben Sie den Namen des Stammordners an, der Assets in der Datenquelle im Quellordner -Feld.

  6. (Optional) Geben Sie die Mindestdateigröße von Assets in MB an, um sie in den Aufnahmeprozess in die Nach Mindestgröße filtern -Feld.

  7. (Optional) Geben Sie die maximale Dateigröße der Assets in MB an, um sie in den Aufnahmeprozess in die Nach Maximalgröße filtern -Feld.

  8. (Optional) Geben Sie eine kommagetrennte Liste von MIME-Typen an, die von der Aufnahme ausgeschlossen werden sollen. MIME-Typen ausschließen -Feld. Beispiel: image/jpeg, image/.*, video/mp4. Siehe alle unterstützten Dateiformate.

  9. Geben Sie eine kommagetrennte Liste der MIME-Typen an, die von der Aufnahme in die MIME-Typen einschließen -Feld. Siehe alle unterstützten Dateiformate.

  10. Wählen Sie die Quelldatei nach Import löschen Option zum Löschen der Originaldateien aus dem Quelldatenspeicher nach dem Import der Dateien in Experience Manager.

  11. Wählen Sie die Importmodus. Auswählen Überspringen, Ersetzen oder Version erstellen. Der Modus „Überspringen“ ist der Standardmodus. In diesem Modus überspringt das Aufnahme-Tool den Import eines Assets, wenn es bereits vorhanden ist. Siehe die Bedeutung der Optionen zum Ersetzen und Erstellen von Versionen.

  12. Geben Sie einen Pfad an, um einen Speicherort in DAM zu definieren, an dem Assets mit dem Asset-Zielordner -Feld. Beispiel: /content/dam/imported_assets.

  13. (Optional) Geben Sie die zu importierende Metadatendatei im CSV-Format im Metadatendatei -Feld. Geben Sie die CSV-Datei im Quellblob-Speicherort an und verweisen Sie beim Konfigurieren des Tools für den Massenimport auf den Pfad. Das in diesem Feld referenzierte CSV-Dateiformat entspricht dem CSV-Dateiformat, wenn Sie Importieren und Exportieren von Asset-Metadaten in großen Mengen. Wenn Sie die Quelldatei nach Import löschen Option zum Filtern von CSV-Dateien mithilfe der Ausschließen oder MIME-Typ einschließen oder Nach Pfad/Datei filtern -Felder. Sie können einen regulären Ausdruck verwenden, um CSV-Dateien in diesen Feldern zu filtern.

  14. Klicken Sie auf Speichern, um die Konfiguration zu speichern.

Konfiguration des Tools für den Massenimport verwalten

Nach der Erstellung der Tool-Konfiguration für den Massenimport können Sie Aufgaben ausführen, um die Konfiguration vor der Massenaufnahme von Assets in Ihre Experience Manager-Instanz zu bewerten. Wählen Sie die unter verfügbare Konfiguration aus. Instrumente > Assets > Massenimport , um die verfügbaren Optionen zur Verwaltung der Konfiguration des Tools für den Massenimport anzuzeigen.

Bearbeiten Sie die Konfiguration

Wählen Sie die Konfiguration aus und klicken Sie auf Bearbeiten , um die Konfigurationsdetails zu ändern. Sie können den Titel der Konfiguration und die Importdatenquelle beim Ausführen des Bearbeitungsvorgangs nicht bearbeiten.

Konfiguration löschen

Wählen Sie die Konfiguration aus und klicken Sie auf Löschen , um die Konfiguration Massenimport zu löschen.

Verbindung zur Datenquelle überprüfen

Wählen Sie die Konfiguration aus und klicken Sie auf check , um die Verbindung zur Datenquelle zu überprüfen. Im Falle einer erfolgreichen Verbindung zeigt Experience Manager die folgende Meldung an:

Erfolgsmeldung zum Massenimport

Aufrufen eines Testlaufs für den Massenimportauftrag

Wählen Sie die Konfiguration aus und klicken Sie auf Trockenlauf , um einen Testlauf für den Massenimportauftrag aufzurufen. Experience Manager zeigt die folgenden Details zum Massenimportauftrag an:

Probelaufergebnis

Einmaligen oder wiederkehrenden Massenimport planen

Führen Sie die folgenden Schritte aus, um einen einmaligen oder wiederkehrenden Massenimport zu planen:

  1. Erstellen Sie eine Konfiguration für den Massenimport.

  2. Wählen Sie die Konfiguration aus und wählen Sie Zeitplan aus der Symbolleiste aus.

  3. Legen Sie eine einmalige Aufnahme fest oder erstellen Sie einen stündlichen, täglichen oder wöchentlichen Zeitplan. Klicken Sie auf Senden.

    Massenaufnahme-Vorgang planen

Anzeigen des Assets-Zielordners

Wählen Sie die Konfiguration aus und klicken Sie auf Anzeigen von Assets , um den Zielspeicherort für Assets anzuzeigen, in den die Assets importiert werden, nachdem der Massenimportauftrag ausgeführt wurde.

Ausführen des Tools für den Massenimport

Nachher Konfigurieren des Tools für den Massenimport und optional Verwalten der Konfiguration des Tools für den Massenimportkönnen Sie den Konfigurationsauftrag ausführen, um die Massenaufnahme von Assets zu starten.

Navigieren Sie zu Instrumente > Assets > Massenimport, wählen Sie die Massenimportkonfiguration und klicken Sie auf Ausführen , um den Massenimport-Prozess zu starten. Klicken Ausführen erneut zu bestätigen.

Experience Manager aktualisiert den Status des Auftrags auf Verarbeitung und Erfolgreich nach erfolgreichem Abschluss des Auftrags. Klicken Anzeigen von Assets , um die importierten Assets in Experience Manager anzuzeigen.

Wenn der Auftrag ausgeführt wird, können Sie auch die Konfiguration auswählen und auf Anhalten , um die Massenaufnahme zu stoppen. Klicken Ausführen erneut, um den Prozess fortzusetzen. Sie können auch auf Trockenlauf , um die Details der Assets zu erfahren, die noch nicht importiert wurden.

Verwalten von Aufträgen nach Ausführung

Mit Experience Manager können Sie den Verlauf der Massenimportiervorgänge anzeigen. Der Auftragsverlauf umfasst den Status des Auftrags, des Auftragserstellers, der Protokolle sowie weitere Details wie Startdatum und -zeit, Datum und Uhrzeit sowie Enddatum und -zeit.

Um auf den Auftragsverlauf für eine Konfiguration zuzugreifen, wählen Sie die Konfiguration aus und klicken Sie auf Auftragsverlauf. Wählen Sie einen Auftrag aus und klicken Sie auf Öffnen.

Massenaufnahme-Vorgang planen

Experience Manager zeigt den Auftragsverlauf an. Auf der Seite mit dem Massenimport-Auftragsverlauf können Sie auch auf Löschen , um diesen Auftrag für die Massenimportkonfiguration zu löschen.

Hochladen von Assets mit Desktop-Clients

Zusätzlich zur Webbrowser-Benutzeroberfläche unterstützt Experience Manager auch andere Clients auf dem Desktop. Sie bieten außerdem ein Upload-Erlebnis, ohne dass der Browser aufgerufen werden muss.

  • Adobe Asset Link bietet den Zugriff auf Assets aus Experience Manager in Adobe Photoshop-, Adobe Illustrator- und Adobe InDesign-Desktop-Programmen. Sie können das aktuell geöffnete Dokument direkt über die Adobe Asset Link-Benutzeroberfläche in diesen Desktop-Programme in Experience Manager hochladen.
  • Das Experience Manager -Desktop-Programm vereinfacht die Arbeit mit Assets auf dem Desktop, unabhängig vom Dateityp oder dem nativen Programm, das diese verarbeitet. Es ist besonders nützlich, um Dateien in verschachtelten Ordnerhierarchien aus Ihrem lokalen Dateisystem hochzuladen, da der Browser-Upload nur das Hochladen flacher Dateilisten unterstützt.

Verarbeiten von Assets beim Hochladen

Um zusätzliche Verarbeitungsschritte für die hochgeladenen Assets durchzuführen, können Sie Verarbeitungsprofile auf die Upload-Ordner anwenden. Die Profile sind auf der Seite Eigenschaften eines Ordners in Assets verfügbar. Ein digitales Asset ohne Erweiterung oder mit einer falschen Erweiterung wird nicht wie gewünscht verarbeitet. Beim Hochladen solcher Assets passiert beispielsweise nichts oder es kann ein falsches Profil für die Verarbeitung auf das Asset angewendet werden. Benutzer können die Binärdateien weiterhin im DAM speichern.

Eigenschaften eines Asset-Ordners mit Optionen zum Hinzufügen eines Verarbeitungsprofils

Die folgenden Registerkarten sind verfügbar:

  • Mit Metadatenprofilen können Sie Standardeigenschaften für Metadaten auf Assets anwenden, die in diesen Ordner hochgeladen wurden.
  • Mit Verarbeitungsprofilen können Sie mehr Ausgabedarstellungen generieren, als standardmäßig möglich sind.

Wenn Dynamic Media in Ihrer Bereitstellung aktiviert ist, stehen außerdem die folgenden Registerkarten zur Verfügung:

  • Mit Dynamic Media Bildprofilen können Sie bestimmte Zuschneidefunktionen (Smarter Zuschnitt und Pixelzuschnitt) und Scharfzeichnungskonfigurationen auf die hochgeladenen Assets anwenden.
  • Mit Dynamic Media Videoprofilen können Sie bestimmte Videokodierungsprofile (Auflösung, Format, Parameter) anwenden.
HINWEIS

Dynamic Media-Zuschnitt und andere Vorgänge für Assets sind zerstörungsfrei. Die Vorgänge ändern das hochgeladene Original nicht. Stattdessen werden Parameter zum Zuschneiden oder Transformieren bei der Übergabe der Assets bereitgestellt.

Für Ordner mit zugewiesenem Verarbeitungsprofil wird der Profilname in der Miniatur der Kartenansicht angezeigt. In der Listenansicht wird der Profilname in der Spalte Verarbeitungsprofil angezeigt.

Hochladen oder Aufnehmen von Assets mit APIs

Technische Details zu den Upload-APIs und dem Protokoll sowie Links zu Open-Source-SDK und Beispiel-Clients finden Sie im Abschnitt zum Asset-Upload in der Entwicklerreferenz.

Tipps, Best Practices und Einschränkungen

  • Der direkte binäre Upload ist eine neue Methode zum Hochladen von Assets. Sie wird standardmäßig von den Produktfunktionen und Clients wie der Experience Manager-Benutzeroberfläche, Adobe Asset Link und dem Experience Manager-Desktop-Programm unterstützt. Jeder benutzerdefinierte Code, der von den technischen Teams des Kunden angepasst oder erweitert wird, muss die neuen Kunde-APIs und Protokolle verwenden.

  • Adobe empfiehlt, in jedem Ordner unter Experience Manager Assets maximal 1.000 Assets hinzuzufügen. Sie können zwar mehr Assets zu einem Ordner hinzufügen, dann können jedoch Leistungsprobleme auftreten, z. B. eine langsamere Navigation zu diesen Ordnern.

  • Wenn Sie die Option Ersetzen im Dialogfeld Namenskonflikt auswählen, wird die Asset-ID für das neue Asset neu generiert. Diese ID unterscheidet sich von der ID des vorherigen Assets. Wenn Asset Insights zur Verfolgung von Impressionen oder Klicks mit Adobe Analytics aktiviert ist, werden die für das Asset in Analytics erfassten Daten durch die erneut generierte Asset-ID ungültig.

  • Einige Upload-Methoden verhindern nicht, Assets mit unzulässigen Zeichen in den Dateinamen hochzuladen. Die Zeichen werden durch das Symbol - ersetzt.

  • Das Hochladen von Assets mit dem Browser unterstützt nur flache Dateilisten und keine verschachtelten Ordnerhierarchien. Wenn Sie alle Assets in verschachtelten Ordnern hochladen möchten, sollten Sie das Desktop-Programm verwenden.

  • Die Massenimportmethode importiert die gesamte Ordnerstruktur so, wie sie in der Datenquelle vorhanden ist. Es werden jedoch nur die nicht leeren Ordner in Experience Manager.

Auf dieser Seite