[AEM Assets]{class="badge positive" title="Gilt für AEM Assets)."}
Asset-Microservices und Verarbeitungsprofile verwenden get-started-using-asset-microservices
Asset-Microservices bieten skalierbare und zuverlässige Asset Verarbeitung über Cloud-native Anwendungen, auch Sekundäre genannt, unabhängig skalierbare Verarbeitungseinheiten, die in der Cloud ausgeführt werden, um Assets bei Bedarf zu verarbeiten. Da diese Mitarbeiter elastisch skalieren, wird die Verarbeitungskapazität bei der Aufnahme großer Mengen automatisch erhöht und bei Inaktivität verringert, was sowohl den Durchsatz als auch die Zuverlässigkeit im Vergleich zur Verarbeitung mit fester Kapazität verbessert.
Adobe verwaltet diese Services direkt und gewährleistet so eine optimale Handhabung verschiedener Asset-Typen und Verarbeitungsoptionen. Dieser verwaltete Ansatz bedeutet, dass Administratoren die zugrunde liegende Verarbeitungsinfrastruktur nicht bereitstellen, optimieren oder warten müssen, sodass sich Teams auf die Asset-Konfiguration statt auf den betrieblichen Overhead konzentrieren können.
Unterstützte Dateitypen und Formate
Asset-Microservices verarbeiten eine breite Palette von Dateitypen die mehr Formate standardmäßig abdecken als frühere Versionen vonExperience Manager. Diese erweiterte native Unterstützung beseitigt die Abhängigkeit von externen Tools für viele gängige Workflows.
Beispielsweise wird jetzt Miniaturansicht-Extraktion von PSD (Photoshop Document) und PSB (Photoshop Big) nativ unterstützt. In früheren Versionen waren hierfür Lösungen von Drittanbietern wie ImageMagick erforderlich. Die direkte Handhabung dieser Formate innerhalb der Plattform vereinfacht Pipelines, reduziert die Integrationskomplexität und eliminiert den Wartungsaufwand durch externe Abhängigkeiten.
Konfiguration von Verarbeitungsprofilen
Die Asset-Verarbeitung wird durch die unter „Verarbeitungsprofile definierte Konfiguration. Experience Manager wird mit einer grundlegenden Standardeinrichtung ausgeliefert und ermöglicht es Administratoren, eine spezifischere Asset-Verarbeitungskonfiguration hinzuzufügen, um ihre Anforderungen zu erfüllen.
Administratoren sind für die folgenden Konfigurationsaufgaben verantwortlich:
- Erstellen neue Workflow-Konfigurationen für die Nachbearbeitung für bestimmte Asset-Verarbeitungsanforderungen.
- Bestehende beibehalten, um das Verarbeitungsverhalten an die Unternehmensstandards anzupassen.
- Ändern von Konfigurationen, einschließlich optionaler Anpassung von Nachbearbeitungs-Workflows.
Entwickler können das Standardangebot erweitern, indem sie diese Workflows anpassen. Da der Nachbearbeitungs-Workflow konfigurierbar ist, fügen Entwicklerinnen und Entwickler Verarbeitungsschritte hinzu, die über die Standardfunktionen hinausgehen, und passen die Pipeline an spezielle Anwendungsfälle an.
Beziehung zum alten Workflow DAM-Update-Asset .
DAM Update Asset-Workflow-Modell, das in früheren Versionen von Experience Manager verwendet wurde. Die Verarbeitung von Asset-Microservices ersetzt die meisten Schritte zur Generierung von Standardausgabedarstellungen und zum Erstellen von Metadaten. Die Konfiguration des Nachbearbeitungs-Workflows kann ggf. die verbleibenden Schritte ersetzen, sodass die gesamte Verarbeitungs-Pipeline über das neue Modell verarbeitet wird.Optionen zur Asset-Verarbeitung verstehen get-started
Experience Manager (AEM) unterstützt drei progressive Ebenen der Asset-Verarbeitung: Standardkonfiguration, Benutzerdefinierte und Benutzerdefiniertes Profil. Diese Optionen bilden ein mehrstufiges Eskalationsmodell, das mit einsatzbereiten Standardeinstellungen beginnt, sich auf vom Administrator definierte Anpassungen erstreckt und zu einer vollständig programmierbaren, Cloud-nativen Verarbeitung für erweiterte Anforderungen führt. Die Auswahl der richtigen Ebene hängt davon ab, wie viel Kontrolle Ihr Unternehmen über Ausgabedarstellungsformate, Auflösungen und die Verarbeitung von Dateitypen benötigt.
- Standardmäßige Miniaturen, die von der Assets-Benutzeroberfläche verwendet werden (48, 140 und 319 Pixel)
- Große Vorschau (Web-Ausgabedarstellung - 1280 Pixel)
- Metadaten- und Textextraktion.
- FPO-Ausgabedarstellung (nur für Platzierung.
- Dateiformat und Auflösung von Bildern ändern.
- Bedingte Anwendung der Verarbeitung auf konfigurierte Dateitypen.
Unterstützte Dateiformate supported-file-formats
Asset-Microservices bieten Unterstützung für eine Vielzahl von Bild-, Dokument-, Video- und Audiodateiformaten. Asset-Microservices für diese unterstützten Formate bieten drei Kernfunktionen:
- Prozessdateien - Aufnehmen und Transformieren von Assets, damit sie für die nachgelagerte Verwendung im Workflow für die Verwaltung digitaler Assets bereit sind.
- Ausgabedarstellungen generieren - Erstellen alternativer Versionen eines Assets, z. B. Miniaturansichten in der Größe, Vorschauen oder formatkonvertierte Kopien. Ausgabedarstellungen stellen sicher, dass ein einzelnes Quell-Asset in der Größe, Auflösung oder dem Format bereitgestellt werden kann, die jeder Kanal erfordert.
- Metadaten extrahieren - Lesen eingebetteter und technischer Metadaten (z. B. Dimensionen, Farbprofile oder Authoring-Details) direkt aus jeder Datei. Dadurch können Assets durchsucht, gefunden und konsistent katalogisiert werden.
Welche spezifischen Funktionen verfügbar sind, hängt vom Dateityp ab. Jedes unterstützte Format wird durch seinen MIME-Typ (Multipurpose Internet Mail Extensions), die standardisierte Kennung, die dem System mitteilt, wie eine Datei interpretiert werden soll und welche Verarbeitungsvorgänge dafür gelten.
Eine vollständige Liste der unterstützten MIME-Typen und der für jeden Typ verfügbaren Funktionen finden Sie unter Unterstützte Dateiformate.
Standardkonfiguration default-config
Experience Manager enthält vorkonfigurierte Standardeinstellungen, die die von der Plattform benötigten Standard Ausgabedarstellungen sofort verfügbar machen. Ausgabedarstellungen sind die alternativen Versionen eines Assets - z. B. Vorschauen, Miniaturen und Web-optimierte Ableitungen -, die Experience Manager aus einem ursprünglichen Upload generiert. Die Standardkonfiguration garantiert auch, dass Kernvorgänge automatisch ausgeführt werden, sodass:
- Metadatenextraktion erfasst beschreibende Informationen, die in jedes hochgeladene Asset eingebettet sind.
- Textextraktion ruft lesbaren Textinhalt aus unterstützten Dateitypen ab.
- Standardausgabedarstellungen werden erstellt, damit Assets Experience Manager verwendet werden können.
Daher können Benutzer sofort mit dem Hochladen oder Aktualisieren von Assets beginnen, und die grundlegende Verarbeitung ist standardmäßig ohne zusätzliche Einrichtung verfügbar.
Das standardmäßige Verarbeitungsprofil
Bei der Standardkonfiguration wendet Experience Manager nur das einfachste Verarbeitungsprofil an. Ein Verarbeitungsprofil definiert die Gruppe von Vorgängen - Ausgabedarstellungen, Metadatenverarbeitung und Textextraktion -, die Experience Manager mit erfassten Assets durchführen. Dieses standardmäßige Verarbeitungsprofil ist in der Benutzeroberfläche nicht sichtbar und kann nicht geändert werden.
Dieses standardmäßige Verarbeitungsprofil wird immer ausgeführt, um hochgeladene Assets zu verarbeiten und sicherzustellen, dass die für Experience Manager erforderliche grundlegende Verarbeitung für jedes Asset abgeschlossen ist. Da es bedingungslos ausgeführt wird, tritt kein Asset in das System ein, ohne die wesentlichen Ausgabedarstellungen und Extraktionsvorgänge zu erhalten, Experience Manager für die Suche, Vorschau und Bereitstellung von abhängt.
Standardkonfiguration standard-config
Experience Manager bietet Funktionen zum Generieren spezifischerer Ausgabedarstellungen für gängige Formate gemäß den Anforderungen der Benutzenden. Ein Administrator kann zusätzliche Verarbeitungsprofile anlegen, um die Erstellung solcher Ausgabedarstellungen zu erleichtern. Benutzer können dann eines oder mehrere der verfügbaren Profile bestimmten Ordnern zuweisen, um die zusätzliche Verarbeitung zu erhalten. Beispielsweise kann die zusätzliche Verarbeitung Ausgabedarstellungen für Web, Mobile und Tablet generieren, um sicherzustellen, dass jedes Asset in einer für das Zielgerät und den Kanal optimierten Größe bereitgestellt wird. In diesem Video erfahren Sie, wie Sie Verarbeitungsprofile“ erstellen und anwenden auf die erstellten Ausgabedarstellungen zugreifen.
-
Breite und Höhe der Ausgabedarstellung: Die Angabe der Breite und Höhe der Ausgabedarstellung definiert die maximalen Größen des generierten Ausgabebilds. Asset-Microservices erzeugen die größtmögliche Ausgabedarstellung, deren Breite und Höhe die angegebenen Werte nicht überschreiten. Das Seitenverhältnis wird beibehalten, sodass es dem Original entspricht, sodass die generierte Ausgabedarstellung nicht gegenüber dem Quell-Asset verzerrt oder gestreckt wird. Ein leerer Wert bedeutet, dass bei der Asset-Verarbeitung die Pixelabmessungen des Originals berücksichtigt werden.
-
Einschlussregeln für MIME-Typen: Der MIME-Typ (Multipurpose Internet Mail Extensions) bestimmt, ob für ein bestimmtes Asset eine Ausgabedarstellung erzeugt wird. Wenn ein Asset mit einem bestimmten MIME-Typ verarbeitet wird, wird der MIME-Typ zunächst mit dem Wert der ausgeschlossenen MIME-Typen für die Ausgabespezifikation verglichen. Wenn er mit dieser Liste übereinstimmt, wird diese spezifische Ausgabedarstellung nicht für das Asset generiert (Blockierungsliste). Andernfalls wird der MIME-Typ mit dem eingeschlossenen MIME-Typ verglichen. Wenn er mit der Liste übereinstimmt, wird die Ausgabedarstellung generiert (Zulassungsliste).
-
Spezielle FPO-Ausgabedarstellung (nur für Platzierung: Beim Platzieren großer Assets aus Experience Manager in Adobe InDesign-Dokumente wartet ein Kreativprofi eine ganze Weile, nachdem er ein Asset platziert. In der Zwischenzeit kann der Kreativprofi keine InDesign verwenden. Dies unterbricht den kreativen Fluss und wirkt sich negativ auf das Benutzererlebnis aus. Um diesem Problem zu begegnen, ermöglicht Adobe die zeitweilige Platzierung kleinformatiger Ausgabedarstellungen in InDesign-Dokumenten. Dadurch kann der Kreativprofi die Arbeit sofort wieder aufnehmen. Diese Platzhalter können später bei Bedarf durch Assets in voller Auflösung ersetzt werden. Experience Manager bietet Ausgabedarstellungen, die nur für die Platzierung verwendet werden. Diese FPO-Ausgabedarstellungen (For Placement Only) haben eine kleine Dateigröße, behalten jedoch das gleiche Seitenverhältnis wie das Original bei, sodass die für sie erstellten Layouts auch dann noch korrekt sind, wenn die Assets in voller Auflösung eingetauscht werden.
Das Verarbeitungsprofil kann eine FPO-Wiedergabe (nur für Platzierung) enthalten. In der Adobe Asset Link-Dokumentation erfahren Sie, ob Sie es für Ihr Verarbeitungsprofil aktivieren müssen. Weitere Informationen finden Sie in der vollständigen Dokumentation von Adobe Asset Link.
Erstellen eines Standardprofils create-standard-profile
-
Administratoren greifen auf Tools > Assets > Verarbeitungsprofile zu. Klicken Sie auf Erstellen.
-
Geben Sie einen beschreibenden Namen an, mit dem Admins das Profil eindeutig identifizieren können, wenn sie es auf einen Ordner anwenden, da der Profilname bestimmt, wie das Profil bei der Ordnerzuweisung ausgewählt wird.
-
Um FPO-Ausgabedarstellungen (nur für Platzierungen) zu erzeugen - Platzhalterversionen mit niedriger Auflösung eines Bildes, die für Layout, Vorschauen und Verweise verwendet werden, bevor endgültige hochauflösende Assets verfügbar sind -, öffnen Sie die Registerkarte Bild und aktivieren Sie FPO-Ausgabedarstellung erstellen. Geben Sie einen Quality-Wert zwischen 1 und 100 ein, wobei ein höherer Wert eine FPO-Ausgabedarstellung mit höherer Qualität erzeugt.
-
Um zusätzliche Ausgabedarstellungen (alternative Versionen des Originalbilds, die in unterschiedlichen Größen, Formaten oder Qualitätsstufen erstellt wurden) zu generieren, klicken Sie auf Neu hinzufügen und geben Sie die folgenden Informationen ein:
- Dateiname jeder Ausgabedarstellung, der zur Identifizierung der generierten Ausgabe verwendet wird.
- Dateiformat jedes Ausgabeformats, ausgewählt aus PNG, JPEG, GIF oder WebP.
- Breite und Höhe in Pixel jeder Ausgabedarstellung. Wenn die Werte für Breite und Höhe nicht angegeben sind, wird die volle Pixelgröße des Originalbilds verwendet, um sicherzustellen, dass die Ausgabedarstellung die nativen Abmessungen des Quellbilds beibehält.
- Qualität in Prozent für jede JPEG- und WebP-Ausgabedarstellung, wobei der Komprimierungsgrad und die resultierende Dateigröße für diese Formate gesteuert werden.
- Eingeschlossene und ausgeschlossene MIME-Typen (Multipurpose Internet Mail Extensions), die Anwendbarkeit eines Profils definieren, indem sie angeben, für welche Asset-Typen die Ausgabedarstellungsregeln gelten und welche weggelassen werden.
-
Klicken Sie Speichern, um das Profil zu speichern und es für die Zuweisung zu Ordnern verfügbar zu machen.
Benutzerdefiniertes Profil und Anwendungsfälle custom-config
Der Asset Compute Service unterstützt eine Vielzahl von Anwendungsfällen, einschließlich Standardverarbeitung und Verarbeitung von Adobe-spezifischen Formaten wie Photoshop. Der Service ermöglicht auch die Implementierung benutzerdefinierter oder unternehmensspezifischer Verarbeitungsformate, die auf individuelle Anforderungen zugeschnitten sind. Anpassungen, für die zuvor der Workflow DAM-Update-Asset für Digital Asset Management (DAM) erforderlich war, werden jetzt entweder automatisch oder über die Konfiguration Verarbeitungsprofile verarbeitet. Wenn diese Verarbeitungsoptionen nicht den spezifischen Geschäftsanforderungen entsprechen, empfiehlt Adobe, die Asset Compute Service zu entwickeln und bereitzustellen, um die Standardfunktionen zu erweitern. Einen Überblick finden Sie unter Erweiterbarkeit und Verwendungszeitpunkt.
Der Asset Compute Service transformiert Bild-, Video-, Dokument- und andere Dateiformate in mehrere Ausgabedarstellungen, einschließlich Miniaturansichten, extrahiertem Text und Metadaten sowie Archiven. Auf diese Weise können Unternehmen automatisch die abgeleiteten Assets generieren, die für die Bereitstellung, Suche und nachgelagerte Workflows erforderlich sind.
Entwickler können den Asset Compute Service verwenden, um benutzerdefinierte Programme für die unterstützten Anwendungsfälle zu erstellen. Experience Manager ruft diese benutzerdefinierten Programme direkt über die Benutzeroberfläche mithilfe von benutzerdefinierten Profilen“ auf die Administratoren konfigurieren. Dadurch wird die benutzerdefinierte Verarbeitung für Endbenutzer ohne manuelles Eingreifen verfügbar. Der Asset Compute Service unterstützt die folgenden Anwendungsfälle für das Aufrufen externer Services:
- Verwenden Sie die ImageCutout-API von Adobe Photoshop, um Hintergründe zu entfernen oder Betreffe zu isolieren und das Ergebnis zur Wiederverwendung als Ausgabedarstellung zu speichern.
- Rufen Sie Drittanbietersysteme auf, um Änderungen vorzunehmen, z. B. ein Product Information Management (PIM)-System, damit die Asset-Verarbeitung mit externen Geschäftsdaten synchronisiert bleibt.
- Verwenden Sie die Photoshop-, um basierend auf einer Photoshop eine Vielzahl von Ausgabedarstellungen zu generieren und so eine konsistente, markenorientierte Ausgabe im benötigten Umfang sicherzustellen.
- Verwenden Sie die Adobe Lightroom-API um die erfassten Assets zu optimieren und als Ausgabedarstellungen zu speichern, wodurch die visuelle Qualität während der Aufnahme automatisch verbessert wird.
Benutzerdefiniertes Profil erstellen create-custom-profile
Mit einem benutzerdefinierten Verarbeitungsprofil in Adobe Experience Manager können Admins Assets an eine Headless-App Builder- weiterleiten, die eine oder mehrere benutzerdefinierte Ausgabedarstellungen). Gehen Sie wie folgt vor, um einen zu erstellen:
-
Admins greifen auf Tools > Assets > Verarbeitungsprofile > Erstellen zu.
-
Klicken Sie auf der Seite „Verarbeitungsprofil“ auf die Registerkarte Benutzerdefiniert und dann auf Neu hinzufügen.
-
Geben Sie im Textfeld „Name“ den gewünschten Dateinamen der Ausgabedarstellung ein und geben Sie dann die folgenden Informationen ein.
- Dateiname der jeweiligen Ausgabedarstellung und eine unterstützte Dateierweiterung.
- Endpunkt-URL (Uniform Resource Locator) einer benutzerdefinierten App Builder-App. Die App muss aus derselben Organisation wie das Experience Manager-Konto.
- Fügen Sie Dienstparameter hinzu, um zusätzliche Informationen oder Parameter an das benutzerdefinierte Programm zu .
- Eingeschlossene und ausgeschlossene MIME (Multipurpose Internet Mail Extensions) die Verarbeitung auf wenige bestimmte Dateiformate zu beschränken.
-
Klicken Sie oben rechts auf der Seite auf Speichern.
Bei den benutzerdefinierten Programmen handelt es Headless Project App Builder-Apps, d. h. sie werden ohne Benutzeroberfläche ausgeführt und automatisch als Teil der Asset-Verarbeitungs-Pipeline ausgeführt. Eine benutzerdefinierte Anwendung erhält alle Dateien, die ihr bereitgestellt werden, wenn die Anwendung mit einem Verarbeitungsprofil verknüpft ist. Die Anwendung muss die Dateien filtern, da sie jedes Asset verarbeitet, das ihr übergeben wird. Durch Filtern wird sichergestellt, dass nur die beabsichtigten, relevanten Dateiformate transformiert werden und dass nicht unterstützte oder unerwünschte Eingaben ignoriert werden.
Beispiel für ein benutzerdefiniertes Profil custom-profile-example
Ein benutzerdefiniertes Verarbeitungsprofil wendet benutzerdefinierten Text mithilfe der Adobe Photoshop-API auf Kampagnenbilder an um diese Bilder automatisch zu bearbeiten. Dieses Beispiel veranschaulicht einen gängigen Anwendungsfall: Hinzufügen von markenspezifischen oder kampagnenspezifischen Textüberlagerungen zu Assets, während sie in Experience Manager aufgenommen werden.
Übergeben von Parametern durch das benutzerdefinierte Profil an die Photoshop-API
Die Asset Compute Service Integration ermöglicht es Experience Manager, diese Parameter über das Feld Dienstparameter“ an benutzerdefinierte Programm zu übergeben. Das benutzerdefinierte Programm ruft dann die Photoshop-API und übergibt diese Werte an die API. Dadurch wird sichergestellt, dass die Imaging-Logik jedes Mal konsistent ausgeführt wird, wenn ein Asset verarbeitet wird, anstatt dass eine manuelle Bearbeitung erforderlich ist.
Über das Feld Dienstparameter können Sie die folgenden Parameter übergeben, um Kampagnenbildern benutzerdefinierten Text hinzuzufügen:
- Schriftartname - Gibt die Schriftart an, die auf den überlagerten Text angewendet wird.
- Textfarbe - Definiert die Farbe des angewendeten Textes.
- Textstärke - Legt die Stärke des Textes fest.
- Textgröße - Bestimmt die Abmessungen des gerenderten Textes.
Abbildung: Verwenden Sie das Feld Dienstparameter, um zusätzliche Informationen an vordefinierte Parameter zu übergeben, die in das benutzerdefinierte Programm integriert sind. Da in diesem Beispiel das Profil bei der Aufnahme angewendet wird, wird beim Hochladen eines Kampagnenbilds die Aktualisierung automatisch Trigger und die Bilder werden mit Jumanji Text in der Arial-BoldMT gerendert.
Verarbeitungsprofile zur Verarbeitung von Assets verwenden use-profiles
Erstellen Sie zusätzliche benutzerdefinierte Verarbeitungsprofile und wenden Sie sie auf bestimmte Ordner an. Dieser Workflow ermöglicht es Experience Manager, Assets zu verarbeiten, die in diese Ordner hochgeladen oder in ihnen aktualisiert werden. Das standardmäßige integrierte Verarbeitungsprofil wird immer ausgeführt, ist jedoch in der Benutzeroberfläche nicht sichtbar. Wenn Sie ein benutzerdefiniertes Profil hinzufügen, verarbeitet Experience Manager die hochgeladenen Assets mit beiden Profilen. Dadurch wird sichergestellt, dass die standardmäßige Verarbeitung immer angewendet wird, während Ihre benutzerdefinierten Ausgabedarstellungen oben hinzugefügt werden.
Methoden zum Anwenden von Verarbeitungsprofilen auf Ordner
Anwenden von Verarbeitungsprofilen auf Ordner mithilfe einer der folgenden drei Methoden:
-
Admins können unter Tools > Assets > Verarbeitungsprofile eine Verarbeitungsprofildefinition auswählen und die Aktion Profil auf Ordner anwenden nutzen. Dadurch wird ein Inhalts-Browser geöffnet, mit dem Sie zu bestimmten Ordnern navigieren, diese auswählen und die Anwendung des Profils bestätigen können.
-
Benutzer können einen Ordner in der Assets Benutzeroberfläche auswählen und die Aktion Eigenschaften verwenden, um den Bildschirm mit den Ordnereigenschaften zu öffnen. Auf der Registerkarte Asset Verarbeitung) können Benutzende das entsprechende Verarbeitungsprofil für diesen Ordner aus der Liste Verarbeitungsprofil auswählen. Klicken Sie auf Speichern und schließen, um die Änderungen zu speichern.
-
Benutzer können Ordner oder bestimmte Assets in Assets Benutzeroberfläche auswählen, um ein Verarbeitungsprofil anzuwenden, und dann die Option
Assets erneut verarbeiten aus den oben verfügbaren Optionen auswählen.
Nachdem ein Verarbeitungsprofil auf einen Ordner angewendet wurde, werden alle neuen Assets, die in diesen Ordner oder einen seiner Unterordner hochgeladen (oder aktualisiert) werden, automatisch mit dem zusätzlichen konfigurierten Verarbeitungsprofil verarbeitet. Daher wird die Verarbeitung auf Ordnerebene über die gesamte Ordnerstruktur nach unten propagiert. Diese Verarbeitung erfolgt zusätzlich zum Standardprofil.
Um sicherzustellen, dass Assets verarbeitet werden, müssen Sie die erzeugten Ausgabedarstellungen in der Ansicht Ausgabedarstellungen in der linken Leiste als Vorschau anzeigen. Öffnen Sie die Asset-Vorschau und dann die linke Leiste, um auf die Ansicht Ausgabedarstellungen zuzugreifen. Die spezifischen Ausgabedarstellungen im Verarbeitungsprofil, für die der Typ des jeweiligen Assets mit den Einschlussregeln des MIME-Typs übereinstimmt, sind sichtbar und zugänglich.
Abbildung: Beispiel zweier zusätzlicher Ausgabedarstellungen, die von einem Verarbeitungsprofil generiert wurden, das auf den übergeordneten Ordner angewendet wurde.
Nachbearbeitungs-Workflows post-processing-workflows
Nachbearbeitungs-Workflows fügen zusätzlich zur konfigurierbaren Verarbeitung durch Asset-Microservices eine vollständig angepasste Asset-Verarbeitung hinzu. Sie können sie immer dann verwenden, wenn eine zusätzliche Verarbeitung von Assets erforderlich ist die allein mit Verarbeitungsprofilen erreicht werden kann. Durch das Hinzufügen dieser Workflows zur Konfiguration erweitern Admins Experience Manager über die standardmäßigen Verarbeitungsfunktionen hinaus, um spezielle Anforderungen zu erfüllen.
Nachdem die Verarbeitung der Microservices abgeschlossen istExperience Manager führt automatisch Nachbearbeitungs-Workflows aus oder startet Workflows automatisch aus falls konfiguriert. Da Experience Manager Trigger diese Workflows nach Abschluss der Verarbeitung der Microservices automatisch ausführen, müssen Workflow-Starter nicht manuell hinzugefügt werden. Häufige Beispiele sind:
- Benutzerdefinierte Workflow-) zur Verarbeitung von Assets.
- Integrationen die Assets von externen Systemen Metadaten oder Eigenschaften hinzufügen, z. B. Produkt- oder Prozessinformationen.
- Zusätzliche Verarbeitung durchgeführt von externen Services.
Gehen Sie wie folgt vor, um Experience Manager eine Workflow-Konfiguration für die Nachbearbeitung hinzuzufügen:
- Erstellen Sie ein oder mehrere Workflow-Modelle. Diese benutzerdefinierten Modelle werden in dieser Dokumentation als Nachbearbeitungs-Workflow-Modelle bezeichnet. Es handelt sich um normale Experience Manager-Workflow-Modelle.
- Fügen Sie diesen Modellen die erforderlichen Workflow-Schritte hinzu. Überprüfen Sie die Schritte aus dem Standard-Workflow und fügen Sie dem benutzerdefinierten Workflow alle erforderlichen Standardschritte hinzu. Experience Manager führt diese Schritte für die Assets basierend auf der Konfiguration des Workflow-Modells aus. Damit Smart-Tagging beispielsweise automatisch beim Hochladen von Assets erfolgt, fügen Sie den Smart-Tagging-Schritt zu Ihrem benutzerdefinierten Workflow-Modell für die Nachbearbeitung hinzu.
- Fügen Sie am Ende den Schritt Abgeschlossener Prozess zum DAMWorkflow eines Asset-Updates“ hinzu. Dieser Schritt ist wichtig: Er signalisiert Experience Manager, wenn die Verarbeitung abgeschlossen ist, damit das Asset als verarbeitet markiert werden kann, d. h. Neu auf dem Asset angezeigt wird. Ohne diesen letzten Schritt können Experience Manager nicht zuverlässig feststellen, dass die Verarbeitung abgeschlossen ist.
- Erstellen Sie eine Konfiguration für den Custom Workflow Runner-Service. Mit dieser Konfiguration können Admins die Ausführung eines Nachbearbeitungs-Workflow-Modells entweder anhand eines Pfads (Ordnerspeicherort) oder anhand eines regulären Ausdrucks definieren.
Weitere Informationen dazu, welcher standardmäßige Workflow-Schritt im Nachbearbeitungs-Workflow verwendet werden kann, finden Sie unter Workflow-Schritte im Nachbearbeitungs-Workflow in der Entwicklerreferenz.
Erstellen von Nachbearbeitungs-Workflow-Modellen in Adobe Experience Manager create-post-processing-workflow-models
Nachbearbeitungs-Workflow-Modelle sind standardmäßige Adobe Experience Manager (AEM-Workflow-Modelle, die zur Verarbeitung digitaler Assets innerhalb des Digital Asset Management (DAM)- verwendet werden. Erstellen Sie separate Modelle, wenn für verschiedene Repository-Speicherorte oder Asset-Typen eine unterschiedliche Verarbeitung erforderlich ist, da durch die Anpassung eines Modells an jedes Szenario sichergestellt wird, dass Assets entsprechend ihren spezifischen Anforderungen verarbeitet werden.
Workflow erstellen: Stellen Sie jeden Nachbearbeitungs-Workflow aus den Ihren Anforderungen entsprechenden Verarbeitungsschritten zusammen. Sie können Folgendes kombinieren:
- Unterstützte (vordefinierte) Schritte die im Lieferumfang von Experience Manager enthalten sind
- Benutzerdefinierte Workflow-Schritte speziell für spezielle Verarbeitungsanforderungen entwickelt
Wichtige Anforderung - letzter Schritt: Der letzte Schritt jedes Nachbearbeitungs-Workflows muss DAM Update Asset Workflow Completed Process sein. Dieser Schritt signalisiert Abschluss an Experience Manager. Daher erkennt Experience Manager, wann die Asset-Verarbeitung abgeschlossen ist, und kann das Asset aus seinem Status „In Bearbeitung“ überführen. Wenn dieser letzte Schritt ausgelassen wird, kann die Plattform den Abschluss der Verarbeitung nicht erkennen, wodurch Assets in einem nicht aufgelösten Workflow-Status stecken bleiben können.
Konfigurieren der Ausführung von Nachbearbeitungs-Workflows configure-post-processing-workflow-execution
Nachdem die Asset-Microservices die Verarbeitung der hochgeladenen Assets abgeschlossen haben, können Sie einen Nachbearbeitungs-Workflow definieren, um zusätzliche Transformationen, Anreicherungen oder benutzerdefinierte Vorgänge auf die Assets anzuwenden. Verwenden Sie eine der folgenden Methoden, um die Nachbearbeitung mithilfe von Workflow-Modellen zu konfigurieren:
Anwenden eines Workflow-Modells auf einen Ordner apply-workflow-model-to-folder
Wenden Sie für typische Anwendungsfälle nach der Verarbeitung einen Workflow direkt auf einen Ordner an. Dies ist der einfachste und gängigste Ansatz. Gehen Sie wie folgt vor, um ein WorkflowModell im Ordner Eigenschaften“ anzuwenden:
-
Erstellen Sie ein Workflow-Modell.
-
Wählen Sie einen Ordner aus und klicken Sie in der Symbolleiste auf Eigenschaften und dann auf die Registerkarte Asset-Verarbeitung.
-
Wählen Sie unter Workflow automatisch starten den gewünschten Workflow aus, geben Sie einen Titel für den Workflow ein und speichern Sie dann die Änderungen.
Konfigurieren des Custom Workflow Runner-Services configure-custom-workflow-runner-service
Konfigurieren Sie den Custom Workflow Runner-Service für erweiterte Konfigurationen, die nicht ohne weiteres erfüllt werden können, indem Sie einen Workflow auf einen Ordner anwenden. Beispiel: ein Workflow, der einen regulären Ausdruck verwendet, um bestimmte Asset-Pfade selektiv auszuwählen. Dieser Service ist nützlich, da er es Ihnen ermöglicht, verschiedene Workflow-Modelle unterschiedlichen Repository-Speicherorten oder Benennungsmustern zuzuordnen, was mit einer Konfiguration auf Ordnerebene allein nicht erreicht werden kann. Der Adobe CQ Digital Asset Management (DAM) Custom Workflow Runner (com.adobe.cq.dam.processor.nui.impl.workflow.CustomDamWorkflowRunnerImpl) ist ein OSGi-Service (Open Service Gateway Initiative). Er bietet die beiden folgenden Konfigurationsoptionen:
- Nachbearbeitungs-Workflows nach Pfad (
postProcWorkflowsByPath): Es können mehrere Workflow-Modelle basierend auf verschiedenen Repository-Pfaden aufgeführt werden. Trennen Sie Pfade und Modelle mithilfe eines Doppelpunkts. Einfache Repository-Pfade werden unterstützt. Ordnen Sie diese einem Workflow-Modell im Pfad/varzu. Beispiel:/content/dam/my-brand:/var/workflow/models/my-workflow. - Nachbearbeitungs-Workflows nach Ausdruck (
postProcWorkflowsByExpression): Es können mehrere Workflow-Modelle basierend auf unterschiedlichen regulären Ausdrücken aufgelistet werden. Trennen Sie Pfade und Modelle mithilfe eines Doppelpunkts. Lassen Sie den regulären Ausdruck direkt auf den Asset-Knoten verweisen und nicht auf eine der Ausgabedarstellungen oder Dateien. Beispiel:/content/dam(/.*/)(marketing/seasonal)(/.*):/var/workflow/models/my-workflow.
Informationen zum Bereitstellen einer OSGi-Konfiguration finden Sie unter Bereitstellen für Experience Manager.
Deaktivieren der Ausführung von Nachbearbeitungs-Workflows
Wenn keine Nachbearbeitung erforderlich ist, deaktivieren Sie die Ausführung, indem Sie ein „leeres“ Workflow-Modell in der Auswahl Workflow automatisch starten erstellen und anwenden. Dies verhindert eine unnötige Workflow-Verarbeitung für Ordner, für die sie nicht erforderlich ist.
Erstellen des deaktivierten Modells „Workflow automatisch starten“
-
Gehen Sie zu Tools > Workflow > Modelle.
-
Klicken Sie Erstellen > Modell erstellen in der oberen Aktionsleiste.
-
Geben Sie einen Titel und einen Namen für das neue Workflow-Modell an, Beispiel:
- Titel: Deaktivieren des automatisch gestarteten Workflows
- Name: disable-auto-start-workflow
-
Klicken Sie auf Fertig, um das Workflow-Modell zu erstellen.
-
Wählen Sie das erstellte Workflow-Modell aus und bearbeiten Sie es.
-
Wählen Sie im Workflow-Modell-Editor die Option Schritt 1 aus der Modelldefinition aus und löschen Sie sie.
-
Klicken Sie im seitlichen Bedienfeld auf Schritte.
-
Ziehen Sie den Schritt Workflow „DAM Update Asset“ abgeschlossen in die Modelldefinition.
-
Klicken Sie auf die Schaltfläche Seiteninformationen (neben dem Umschalter für das seitliche Bedienfeld) aus und dann auf Eigenschaften öffnen.
-
Klicken Sie unter der Registerkarte „Allgemein“ auf die Option Übergangs-Workflow. Ein Übergangs-Workflow behält seinen Ausführungsverlauf nicht im Repository bei, wodurch der Overhead reduziert und die Verarbeitungsleistung verbessert wird.
-
Klicken Sie in der oberen Aktionsleiste auf Speichern und schließen.
-
Klicken Sie in der oberen Aktionsleiste auf Synchronisieren.
-
Schließen Sie den Workflow-Modell-Editor.
Anwenden des Modells „Workflow für automatischen Start deaktivieren“
Befolgen Sie die Schritte unter Anwenden eines Workflow-Modells auf einen Ordner und legen Sie Workflow für automatischen Start deaktivieren für Workflow automatisch starten für Ordner fest, bei denen keine Nachbearbeitung von Assets erforderlich ist.
Best Practices und Einschränkungen best-practices-limitations-tips
Best Practices
- Berücksichtigen Sie beim Entwickeln von Workflows Ihre Anforderungen für alle Arten von Ausgabedarstellungen. Wenn Sie der Meinung sind, dass eine Ausgabedarstellung in Zukunft nicht erforderlich sein wird, entfernen Sie den Erstellungsschritt aus dem Workflow. Ausgabedarstellungen können danach nicht mehr stapelweise gelöscht werden. Da nicht verwendete Ausgabedarstellungen nicht gemeinsam entfernt werden können, können sich unerwünschte Ausgabedarstellungen ansammeln und nach längerer Nutzung von Adobe Experience Manager (AEM) viel Speicherplatz belegen. Bei einzelnen Assets können Sie Ausgabedarstellungen manuell aus der Benutzeroberfläche entfernen. Bei mehreren Assets können Sie Experience Manager so anpassen, dass entweder bestimmte Ausgabedarstellungen gelöscht oder die Assets gelöscht und dann die gelöschten Assets erneut hochgeladen werden.
Aktuelle Einschränkungen
- Derzeit ist die Unterstützung auf das Erzeugen von Ausgabedarstellungen beschränkt. Das Generieren neuer Assets wird nicht unterstützt.
- Die Dateigrößenbeschränkung für die Extraktion von Metadaten beträgt 15 GB. Beim Hochladen sehr großer Assets kann der Metadatenextraktionsvorgang für Dateien, die diesen Schwellenwert überschreiten, fehlschlagen.
- Es wird empfohlen, die Anzahl der auf ein Asset angewendeten Ausgabedarstellungen auf weniger als 40 % beschränken, da eine Überschreitung dieser Beschränkung dazu führt, dass -Anfragen abgeschnitten werden.
Siehe auch
- Übersetzen Assets
- Assets-HTTP-API
- Von AEM Assets unterstützte Dateiformate
- Suchen von Assets
- Connected Assets
- Asset-Berichte
- Metadatenschemata
- Herunterladen von Assets
- Verwalten von Metadaten
- Verwalten von Dynamic Media-Vorlagen
- Berichte in der Assets verwalten
- Suchfacetten
- Verwalten von Sammlungen
- Massenimport von Metadaten
- In Assets und Dynamic Media veröffentlichen