Nettoyage des adresses de sommet : adresses différentes non autorisées
Cet article décrit la solution du problème où, lorsque l’utilisateur tente de saisir une adresse de facturation et d’expédition différente, avec la validation de l’adresse de sommet activée, le storefront ne permet pas à l’utilisateur de la saisir.
Produits et versions concernés
- Adobe Commerce sur site et Adobe Commerce sur l’infrastructure cloud 2.3.5-p1
Problème
Étapes à reproduire :
- Accédez à Admin > Magasins > Configuration > Ventes > Nettoyage des adresses.
- Sélectionnez Activé dans la liste déroulante Utiliser le nettoyage des adresses de sommet et Enregistrer la configuration.
- Positionnez-vous sur le front-end en tant qu'invité et ajoutez un produit au panier.
- Cliquez sur l’icône Panier et Passez à la caisse.
- Renseignez les champs de l'adresse.
- Sélectionnez la méthode d’expédition souhaitée et cliquez sur Suivant.
- Cliquez de nouveau sur le bouton Suivant .
- Décochez la case Mon adresse de facturation et de livraison et saisissez une nouvelle adresse de facturation (différente de l’adresse).
- Cliquez sur le bouton Mettre à jour, puis sur Mettre à jour l'adresse.
Résultats attendus :
L’utilisateur voit différentes adresses de facturation et de livraison.
Résultats réels :
Lorsque l’utilisateur accède à la mise à jour, les adresses de facturation et de livraison redeviennent identiques.
Cause
La vérification de l’adresse du sommet a échoué.
Solution
Désactivez la vérification des adresses de sommet ou la mise à niveau vers la version 2.4.0.
Lecture connexe
- Problème connu d’Adobe Commerce 2.4.0 : message d’erreur lors de la sélection du mode de paiement local affiché pour certains pays lors du passage en caisse
- Problème connu d’Adobe Commerce 2.4.0 : erreur 404 lors de la suppression des points de récompense lors du passage en caisse multi-expédition
- Problème connu d’Adobe Commerce 2.4.0 : erreur d’affichage des commandes
- L’administrateur d’Adobe Commerce 2.4.0 B2B ne peut pas ajouter de produit configurable pour le devis
- Problème connu d’Adobe Commerce 2.4.0 : les méthodes de paiement du Braintree ne s’affichent pas dans le passage en caisse de plusieurs adresses
- Problème connu d’Adobe Commerce 2.4.0 : l’actualisation des activités du client ne fonctionne pas
- Problème connu d’Adobe Commerce 2.4.0 - Les taux de taxe d’exportation ne fonctionnent pas
- Problème connu d’Adobe Commerce 2.4.0 : le bouton "Ajouter des sélections à mon panier" ne fonctionne pas
- Problème connu d’Adobe Commerce 2.4.0 : affichage des données de message brutes sur le storefront
- Problème connu d'Adobe Commerce 2.4.0 : absence de l'étiquette "Remboursement" en larna
- Problème connu d’Adobe Commerce 2.4.0 : absence de deux boutons sur la page Créer une commande dans Admin
- Problème connu d’Adobe Commerce 2.4.0 : lorsque Braintree est activé, problème de facture partielle de Venmo
- Problème connu d’Adobe Commerce 2.4.0 : message d’erreur lors de la sélection du mode de paiement local affiché pour certains pays lors du passage en caisse
- Problème connu d’Adobe Commerce 2.4.0 : paiement Amazon activé, méthodes de paiement manquantes lors du retour au paiement standard utilisé
- Problème connu d’Adobe Commerce 2.4.0 : l’installation 2.4.0 échoue avec le cache de magasins obsolète
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a