[PaaS uniquement]{class="badge informative" title="S’applique uniquement aux projets Adobe Commerce on Cloud (infrastructure PaaS gérée par Adobe) et aux projets On-premise."}

Nettoyage des adresses de sommet : adresses différentes non autorisées

Cet article présente la solution au problème suivant : lorsque l’utilisateur tente de saisir une adresse de facturation et d’expédition différente avec la validation d’adresse Vertex activée, le storefront ne le laisse pas la saisir.

Produits et versions concernés

  • Adobe Commerce on-premise et Adobe Commerce sur l’infrastructure cloud 2.3.5-p1

Problème

Procédure à suivre :

  1. Accédez à Admin > Magasins > Configuration > Ventes > Nettoyage des adresses.
  2. Sélectionnez Activé dans la liste déroulante Utiliser le nettoyage des adresses de sommet et Enregistrer la configuration.
  3. Accédez au serveur frontal en tant qu’invité et ajoutez un produit au panier.
  4. Cliquez sur l’icône Panier et Passer en caisse.
  5. Renseignez les champs d’adresse .
  6. Sélectionnez le Mode d'expédition souhaité, puis cliquez sur Suivant.
  7. Cliquez de nouveau sur le bouton Suivant.
  8. Décochez Mon adresse de facturation et d’expédition sont identiques, puis saisissez une nouvelle adresse de facturation (différente de l’adresse).
  9. Cliquez sur le bouton Mettre à jour, puis sur Mettre à jour l’adresse.

Résultats attendus :

L’utilisateur voit différentes adresses de facturation et d’expédition.

Résultats réels :

Lorsque l’utilisateur clique sur mettre à jour, les adresses de facturation et d’expédition redeviennent identiques.

Cause

Échec de la vérification de l'adresse du sommet.

Solution

Désactivez la vérification des adresses Vertex ou effectuez une mise à niveau vers la version 2.4.0.

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