Nettoyage des adresses de sommet : adresses différentes non autorisées

Cet article décrit la solution du problème où, lorsque l’utilisateur tente de saisir une adresse de facturation et d’expédition différente, avec la validation de l’adresse de sommet activée, le storefront ne permet pas à l’utilisateur de la saisir.

Produits et versions concernés

  • Adobe Commerce sur site et Adobe Commerce sur l’infrastructure cloud 2.3.5-p1

Problème

Étapes à reproduire :

  1. Accédez à Admin > Magasins > Configuration > Ventes > Nettoyage des adresses.
  2. Sélectionnez Activé dans la liste déroulante Utiliser le nettoyage des adresses de sommet et Enregistrer la configuration.
  3. Positionnez-vous sur le front-end en tant qu'invité et ajoutez un produit au panier.
  4. Cliquez sur l’icône Panier et Passez à la caisse.
  5. Renseignez les champs de l'adresse.
  6. Sélectionnez la méthode d’expédition souhaitée et cliquez sur Suivant.
  7. Cliquez de nouveau sur le bouton Suivant .
  8. Décochez la case Mon adresse de facturation et de livraison et saisissez une nouvelle adresse de facturation (différente de l’adresse).
  9. Cliquez sur le bouton Mettre à jour, puis sur Mettre à jour l'adresse.

Résultats attendus :

L’utilisateur voit différentes adresses de facturation et de livraison.

Résultats réels :

Lorsque l’utilisateur accède à la mise à jour, les adresses de facturation et de livraison redeviennent identiques.

Cause

La vérification de l’adresse du sommet a échoué.

Solution

Désactivez la vérification des adresses de sommet ou la mise à niveau vers la version 2.4.0.

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