Échec de l’installation d’Adobe Commerce 2.4.0 avec le cache de magasins obsolète

Cet article fournit une solution au problème d’échec de l’installation d’Adobe Commerce 2.4.0 avec le message d’erreur : Le site web par défaut n’est pas défini. Définissez le site web et réessayez. affiché dans la console.

Produits et versions concernés

  • Adobe Commerce sur l’infrastructure cloud 2.4.0
  • Adobe Commerce on-premise 2.4.0

Problème

Conditions préalables :
Une extension tierce avec des dépendances sur les API pour le module Store dans les commandes de l’interface de ligne de commande est configurée comme requis dans composer.json. L'installation d'Adobe Commerce 2.4.0 échoue alors avec un message d'erreur : Le site web par défaut n'est pas défini. Définissez le site web et réessayez. affiché dans la console.

Cause

Le problème s’affiche pour les extensions tierces qui dépendent des magasins dans leurs commandes d’interface de ligne de commande. L’un est les Sales Channel Amazon.

Solution

Avant l'installation d'Adobe Commerce 2.4.0, les commerçants doivent :

  1. Supprimez ces extensions tierces de composer.json.
  2. Installez Adobe Commerce sans extensions.
  3. Ajoutez les extensions après l’installation.

Le problème sera corrigé dans la portée de la version 2.4.1.

Lectures connexes dans notre base de connaissances de support :

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a