Adobe Experience Manager 6.5 Laatste Opmerkingen bij de release Service Pack aem-service-pack-release-notes

Gegevens vrijgeven release-information

Product
Adobe Experience Manager 6,5
Versie
6.5.19,0
Type
Service Pack-release
Datum
Donderdag 7 december 2023
URL downloaden
Softwaredistributie

Wat is inbegrepen in Experience Manager 6.5.19,0 what-is-included-in-aem-6519

Experience Manager 6.5.19.0 omvat nieuwe eigenschappen, zeer belangrijke klant-gevraagde verhogingen, insectenmoeilijke situaties, en prestaties, stabiliteit, en veiligheidsverbeteringen die sinds de aanvankelijke beschikbaarheid van 6.5 in April 2019 zijn vrijgegeven. Dit servicepack installeren op Experience Manager 6.5

Belangrijke functies en verbeteringen

Enkele belangrijke functies en verbeteringen in deze release zijn onder andere:

  • Gebruikers van de Pagina-editor/afbeeldingscomponent van Sites konden naar elementen van de Cloud Service voor externe middelen verwijzen. (SITES-13448, SITES-13433)
  • AEM ondersteunt nu sorteren op de server voor snellere projectnavigatie in de lijstweergave. Projectknooppunten worden gesorteerd op basis van de door de gebruiker geselecteerde kolom voordat ze in de interface worden weergegeven.

Forms

  • Nieuwe adaptieve Core-componenten van het formulier: De verticale tabbladen, Algemene voorwaarden en Selectievakje worden toegevoegd om de schaalbaarheid van formulieren te verbeteren.

    • Component CheckBox: Adaptieve Forms op basis van Core Components kan nu een component checkbox bevatten. Hiermee kunnen gebruikers binaire keuzes maken door een bepaalde optie te selecteren of te deselecteren. De optie wordt meestal weergegeven als een klein vak waarop u kunt klikken of tikken om te schakelen tussen twee statussen: ingeschakeld en uitgeschakeld. Het selectievakje is een veelgebruikt formulierelement voor een ja/nee- of waar/onwaar-keuze.

    • Component Voorwaarden en bepalingen: Adaptieve Forms op basis van kerncomponenten kan nu een component Voorwaarden en Voorwaarden bevatten. Hiermee kunnen Forms-auteurs een specifieke sectie in het formulier introduceren waarin gebruikers de voorwaarden, juridische overeenkomsten of het gebruik van een service, product of platform krijgen aangeboden. Deze component is bedoeld om gebruikers te informeren over de regels, regels en verplichtingen waarmee zij instemmen door het formulier in te dienen.

      Verticale tabbladen, Algemene voorwaarden en componenten Selectievakje

    • De component Verticale tabbladen: Adaptieve Forms op basis van Core Components kan nu formulierinhoud ordenen in een verticale lijst met tabbladen, zodat u over een gestructureerde en navigeerbare indeling beschikt. Het gebruik van verticale tabbladen in een formulier kan de algehele gebruikerservaring verbeteren door de navigatie te vereenvoudigen en de organisatie van formulierinhoud te verbeteren, met name in situaties waarin een formulier meerdere secties of complexe informatie bevat.

  • 64-bits versie van AEM Forms Designer: De 64-bits versie van AEM Forms Designer biedt verbeterde prestaties, schaalbaarheid en geheugenbeheer, zodat u meer mogelijkheden hebt om formulieren te maken. Met de 64-bits architectuur kunt u nog grotere en complexere projecten eenvoudig aanpakken, zodat u kunt zorgen voor naadloze ontwerpworkflows en geoptimaliseerde efficiëntie. Verhoog uw mogelijkheden voor formulierontwerp en omarm de toekomst van AEM Forms Designer met deze geavanceerde release.

  • Een adaptieve Forms verbinden met de Microsoft® SharePoint List: AEM Forms biedt een out-of-the-box integratie om formuliergegevens rechtstreeks naar de SharePoint List te verzenden, zodat u de mogelijkheden van SharePoint List kunt gebruiken. U kunt de Microsoft® SharePoint-lijst configureren als gegevensbron voor een formuliergegevensmodel en de verzendactie Verzenden met het formuliergegevensmodel gebruiken om een adaptief formulier te verbinden met de SharePoint-lijst.

  • Ondersteuning voor het configureren van Document of Record-eigenschappen voor adaptieve formulierfragmenten: U kunt de fragmenten van het adaptieve formulier en de bijbehorende velden nu gemakkelijk aanpassen in de Adaptieve formuliereditor.

  • 64-bits XMLFM: De 64-bits iteratie van XMLFM introduceert verhoogde prestaties, schaalbaarheid en verfijnd geheugenbeheer. Het is de eerste inheemse dienst met 64 bits die op server-kant wordt opgesteld. Met XMLFM 64-bits kan een naadloze afhandeling van grotere renderingwerklasten worden bewerkstelligd door gebruik te maken van de inherente mogelijkheid om toegang te krijgen tot grotere geheugenbronnen in vergelijking met de 32-bits tegenhanger. Deze mijlpaal betekent niet alleen een prestatiesprong, maar introduceert ook belangrijke verbeteringen aan het native servicekader binnen de AEM Forms Server. Deze update zorgt ervoor dat AEM Forms Server naadloos elke 64-bits native service ondersteunt.

Opgeloste problemen in Service Pack 19 fixed-issues

Sites sites-6519

Toegankelijkheid sites-accessibility-6519

  • Als u op een AEM Sites-pagina 200% inzoomt op de pagina, worden de koppelingen Language Copy en CSV Report in de References verdwijnen. (SITES-11011)

Gebruikersinterface Admin sites-adminui-6519

  • AEM Screens Channel Preview werkt niet en wordt niet weergegeven op het dashboard. (SITES-15730)
  • Tijdens het verplaatsen van een pagina worden de verwijzingen, als de gebruikersinterface de verwijzingen niet kan tonen maar verklaart dat deze automatisch opnieuw worden gepubliceerd, zij niet opnieuw gepubliceerd. (SITES-16435)
  • In AEM 6.5 met Service Pack 16 of 17, wanneer in de mening van de Lijst van plaatsen met de toegelaten kolom van het "Werkschema", kunt u niet de lijst sorteren die op de punten in die kolom wordt gebaseerd. Er vindt geen sortering plaats. (SITES-15385)
  • Voor een paginasjabloon voor omleiding is het veld voor omleiding verplicht gesteld. De validatie voor het vereiste veld wordt echter niet toegepast en werkt niet in deze twee scenario's: wanneer een pagina wordt gemaakt zonder verplichte omleidingswaarde; u kunt geen omleidingspagina maken. De validatie werkt niet wanneer u met sneltoetsen navigeert en wanneer het veld is gemarkeerd als ongeldig, wordt niet verder gegaan. (SITES-15903)
  • Sommige Binnenkomende koppelingen werden niet opgenomen in het weergegeven aantal in het dialoogvenster Verwijzingen deelvenster. Het deelvenster werd bijvoorbeeld weergegeven Binnenkomende koppelingen (6) maar er waren eigenlijk negen binnenkomende links . (SITES-14816)

Klassieke interface sites-classicui-6519

  • Nadat u hotfix hebt geïnstalleerd in SITES-15827, werden dialoogvenstertitels met witruimte tussen woorden vervangen door " ". Er werden ook regeleinden verwijderd. (SITES-16089)
  • Titels van gecodeerde dialoogvensters resulteren nu in een dubbele codering van de titel. (SITES-15841)
  • De update van AEM servers van de dienstpak 6.5.16 tot 6.5.17 resulteerde in een dubbele codering van Klassieke de dialoogvaktitels van de UI. (SITES-15634)

Content Fragments sites-contentfragments-6519

  • Er verschijnt een bericht Interne serverfout in de Inhoudsfragmenteditor. (SITES-13550)
  • De bijwerking van de org.json bibliotheek door middel van NPR-41291 heeft geleid tot conversies van gegevensfouten in de DefaultDataTypeConverter van de cfm-impl bundel. Conversie van gegevenstypen moet flexibeler zijn. (SITES-16473)
  • Het pop-upbericht 'Deze versie van het inhoudsfragment kan vanwege incompatibele inhoud niet worden vergeleken met de huidige versie.' Inhoudsfragmenten moeten vergelijkbaar zijn, maar niet. (SITES-16317)
  • De JS-URL van de elementkiezer is gewijzigd van
    https://experience.adobe.com/solutions/CQ-assets-selectors/assets/resources/assets-selectors.js
    tot
    https://experience.adobe.com/solutions/CQ-assets-selectors/static-assets/resources/assets-selectors.js (SITES-16068)
  • Pas het nieuwe API-responsschema voor metagegevens van Polaris aan voor CFM-Polaris-integratie. (SITES-15166)
  • Alle inhoudsfragmenten moeten worden vermeld op de plaats waar naar het geselecteerde inhoudsfragment wordt verwezen. In plaats daarvan bevatten elementverwijzingen in het referentievenster voor inhoudsfragmenten 0 (nul) verwijzingen. (SITES-15036)

Core Backend sites-core-backend-6519

  • Verbeteren StyleImpl. (SITES-15164)
  • Verbeter de versie/650 tak van de pijpleiding WCM om integratietests voor zijn modules in werking te kunnen stellen. (SITES-12938)

Campagne-integratie sites-campaign-integration-6519

  • Op de component signature (/apps/fpl/components/campaign/signature) werkt de koppeling ExternalAlizer niet. Het domein wordt niet toegevoegd aan de afbeeldingsbron als de HTML-opmerking boven de afbeeldingstag is verwijderd. Dit probleem is alleen gevonden met de handtekeningcomponent in de productieomgeving, niet met de testomgeving. (SITES-16120)

Elementaire componenten (verouderd) sites-foundation-components-legacy-6519

  • Adobe Experience Manager (AEM) Sites Search component verbreekt de gebruikersinterface. (SITES-15087)

GraphQL Query Editor sites-graphql-query-editor-6519

  • In de gebruikersinterface van GraphQL Editor kunt u niet door alle voortgezette query's bladeren wanneer er een groot aantal query's is (bijvoorbeeld meer dan 25). (SITES-16008)
  • De GraphQL Editor slaat de publicatiestatus van doorlopende query's niet op. De knop Publiceren ongedaan maken wordt weergegeven in de GraphQL Editor, maar het pictogram dat aangeeft dat de voortgezette query is gepubliceerd, wordt niet weergegeven. Als u de pagina vernieuwt, ziet u dat de voortgezette query niet eens wordt gepubliceerd. (SITES-15858)

Lanceringen sites-launches-6519

  • Wijzigingen in de opslagplaats worden niet opgeslagen vanwege Oak0001 veroorzaakt een conflict wanneer meerdere pagina's worden bewerkt of de inhoud wordt geschreven. Het is normaal dat u in een dergelijke gebeurtenis opnieuw probeert, maar dit gebeurt niet. (SITES-14840)

MSM - Actieve kopieën sites-msm-live-copies-6519

  • MSM-uitrolknop werkt niet in de grafische gebruikersinterface met aanraakbediening. (SITES-16991)
  • De Verwijzing van de verbinding wordt niet bijgewerkt binnen het Fragment van de Ervaring wanneer het creëren van een levende exemplaar of het opstellen van een Fragment van de Ervaring. (SITES-15460)

Pagina-editor sites-pageeditor-6519

  • Als u in Forms > Thema's een thema hebt geopend in de themaeditor en enkele wijzigingen hebt aangebracht en vervolgens op Voorvertoning hebt geklikt, wordt een pictogram voor het laden weergegeven, maar wordt de werkelijke voorvertoning niet geladen. (SITES-17164)
  • De selectie van meerdere documentfiletypen op het filter voor elementtype werkt niet op de paginaconsole. Er worden geen resultaten gevonden, zelfs niet als de resultaten van een bepaald bestandstype beschikbaar zijn. Auteurs kunnen daarom niet meerdere documenten filteren. Zij moeten veelvoudige documenttypes gebruiken en zij moeten het tegelijkertijd filtreren. (SITES-14047)
  • Nadat u een exemplaar van AEM 6.5.17 en AEM 6.5.18 hebt bijgewerkt, vanuit de Pagina-editor, indien u deze optie hebt geselecteerd Publish Page, wordt u omgeleid naar een URL die niet bestaat. De gebruiker moet worden omgeleid naar de wizard Publiceren. (SITES-15856)
  • Overbodige kopie van AEM klembord tijdens plakken vanaf het klembord van het besturingssysteem. (SITES-15704)
  • In elementen selecteren Documents vervolgens onder Filtertype, selecteren Microsoft®® Word of Microsoft®® Excel geeft geen resultaten weer, ook al bestaan er bestanden van beide typen. (SITES-14837)

Assets assets-6519

  • Wanneer u een openbare map maakt of opslaat, worden drie groepen gemaakt in een beheerdashboard. (ACTIVA-26700)
  • Kan geen onderscheid maken tussen publicatiemiddelen en Experience Manager of Brand Portal. (NPR-41320)
  • Wanneer u in het zoekvenster selectievakjes selecteert en een van deze selectievakjes uitschakelt, zijn alle selectievakjes uitgeschakeld. (ACTIVA-26377)

Dynamic Media assets-dm-6519

  • Nadat een element naar AEM is geüpload, update_asset de workflow wordt geactiveerd. De workflow wordt nooit voltooid. Wanneer u de workflowinstanties bekijkt, wordt de workflow voltooid tot de uploadstap voor het product. De volgende stap is het uploaden van Scene7-batches. De gebruiker kan zien dat het middel zich in Scene7 bevindt vanuit de Dynamic Media Classic-app. (ACTIVA-30443)
  • Een aangepast servereindpunt (API-eindpunt) retourneert een onjuiste Dynamic Media-bestandsnaam (Scene7). Dit gebeurt wanneer een element wordt verwijderd en vervangen door een element met dezelfde naam. De aangepaste servlet retourneert de oude Dynamic Media-bestandsnaam (Scene7), terwijl een JCr-API-aanroep de juiste bestandsnaam retourneert. (ACTIVA-29476)
  • Zelfs nadat Sync is uitgeschakeld op mapniveau, wordt in het logbestand de trigger "Scene7 ReplicateOnModifyListener" weergegeven. De ReplicateOnModifyListener/Worker moet verwerking op niet-Dynamic Media-mapelementen en inhoudsfragmenten overslaan. (ACTIVA-26705)
  • Mensen met een laag gezichtsvermogen worden beïnvloed als de focus niet zichtbaar is in vervolgkeuzemenu's (Alleen inhoud, Weergave, Meer opties) in zwart-witmodi met hoog contrast. (ACTIVA-25759)
  • Mensen met een laag gezichtsvermogen worden beïnvloed als de lichtsterktecontrastverhouding voor tekst op een pagina minder dan 4,5:1 is. (ACTIVA-25756)
  • Schermlezers vertellen het weergegeven pop-upbericht niet nadat ze de gegevens hebben verzonden. (ACTIVA-25755)
  • Schermlezers herkennen geen markeringen op de pagina (Dynamic Media; maken van een videocoderingsprofiel) wanneer ze navigeren met een vaste-kommasleutel/regiosneltoets D/R. (ACTIVA-25752)
  • Schermlezers herkennen niet meerdere markeringen op de pagina (Dynamic Media; interactieve video maken) wanneer ze navigeren met behulp van een sneltoets voor liggend/regionaal D/R. (ACTIVA-25750)
  • Schermlezers (NVDA/JAWS/Narrator) herkennen de Landmarkeringen niet in Element bewerken pagina tijdens navigeren met de sneltoetsen D/R. (ACTIVA-25744)
  • De gebruiker krijgt een leeg/vals asynchroon baanbericht maar het aangesloten middel wordt met succes gepubliceerd. (ACTIVA-29342)

Forms forms-6519

Adaptive Forms

  • Wanneer een gebruiker een werkbalk toevoegt aan Adaptief formulier, vertoont het Label van de formuliercontainer een onjuist gedrag omdat dit niet verandert in de voorkeurstaal die de auteur voor Forms heeft geselecteerd. (FORMS-11371)
  • In AEM Forms Workspace selecteert het vervolgkeuzeveld standaard de eerste optie in de gebruikersinterface. (FORMS-11346)
  • De taalconfiguratie in AEM wordt niet beïnvloed als u landinstellingen met vijf karakters gebruikt en het decimale separator niet correct in de brief wordt teruggegeven. (FORMS-11344)
  • Wanneer een gebruiker de XML-uitvoer genereert met behulp van het workbench-proces, mislukt dit voor een aantal bestanden. (FORMS-11314)
  • Wanneer een gebruiker voorvertoning voor Document of Record (DOR) genereert in andere talen dan Engels, werkt dit niet. (FORMS-11106)
  • Wanneer een gebruiker sommige afbeeldingsbestanden met PDFG omzet in een OSGI-instantie op basis van Linux® met JDK11, wordt deze niet omgezet. (FORMS-11105)
  • Wanneer de gebruiker de invoegtoepassing AEM Forms installeert, wordt het deelvenster voor de inhoudsstructuur in AEM Sites verbroken. (FORMS-10912)
  • Wanneer een gebruiker datums kopieert met gebruik van de NVDA-schermlezer van de Date Picker-component, wordt deze niet correct gelezen. (FORMS-10805)
  • In de Forms-regeleditor kan de gebruiker de waarde van het keuzerondje/selectievakje niet instellen wanneer het gegevenstype Boolean is. (FORMS-10713)
  • Wanneer een gebruiker items toevoegt aan een adaptief formulier, wordt deze in omgekeerde volgorde toegevoegd aan een vervolgkeuzelijst. (FORMS-10456)
  • Wanneer een dropdown gebruikend de regelredacteur wordt ontruimd, verschijnt de eerste verstrekte waarde nog alhoewel de waarde is ontruimd. (FORMS-9963)
  • Gebruikers hebben geen toegang tot de functie Formulier Titel met behulp van schermlezers, zoals NVDA. (FORMS-8815)
  • Gebruikers hebben geen toegang tot Sub Title in een formulier met behulp van schermlezers, zoals NVDA. (FORMS-8814)
  • In de paginabron van het HTML-formulier is het kenmerk access key leeg en werkt het niet. (FORMS-5753)
  • In het dialoogvenster Info over werkruimte wordt de tekst "Adobe Experience Manager - Forms" weergegeven als tekst. (FORMS-5748)

Forms Designer forms-designer-6519

  • Wanneer een gebruiker niet-interactieve PDF forms probeert te lezen via schermlezers, worden sommige lijstitems niet gelezen of overgeslagen. (LC-3921645)
  • Wanneer een gebruiker met de Tab-toets door de bewerkbare velden gaat, worden niet alle PDF-formuliervelden consistent doorlopen. (LC-3921631)
  • De volgorde van de labels wordt willekeurig gewijzigd in PDF, zelfs als de labels in Forms Designer zijn ingesteld, is juist. (LC-3921313)
  • Een lijst wordt niet correct weergegeven in de tags in Adobe Acrobat Reader of Adobe Acrobat DC. (LC-3921306)
  • Kop-niveaus die correct zijn toegewezen in Forms Designer, worden willekeurig gewijzigd in een <P> -tag in Adobe Acrobat. (LC-3921305)
  • In een tabel kan de id van een object niet worden gewijzigd nadat deze is toegewezen. (LC-3921134)
  • Als samengevoegde cellen in de tabel staan, is er geen GUI beschikbaar voor het instellen van het bereik (rij en kolom) en het bereik in een complexe tabel in AEM Forms Designer. (LC-3919532)
  • Wanneer een gebruiker PDF-documenten probeert te genereren nadat hij het formulierinvoegpakket op AEM Forms Service Pack 6.5.15.0 heeft geïnstalleerd, mislukt dit periodiek en wordt de fout weergegeven:
    • OutputServiceException AEM_OUT_001_003:Unexpected Exception: 0 Out of Memory Caused by: org.omg.CORBA.COMM_FAILURE: null (LC-3921530)

Stichting foundation-6519

  • Als u een taalkopie maakt op het hoofdniveau van de taal, worden de paden op de pagina niet aangepast. In het geval waarin de taalkopie is gemaakt, is het pad niet correct gewijzigd voor de hoofdtaal, maar voor de pagina's eronder. (NPR-41364)
  • De knopinfo 'Relatieve datumpresentatie' kan alleen worden gesloten door op het toetsenbord op Escape (ESC) te drukken. De knopinfo moet worden gesloten wanneer de gebruiker een gedeelte van de gebruikersinterface selecteert. (NPR-41394)
  • Niet-gelokaliseerde tekenreeks Something went wrong while adding the private key. wanneer u het onjuiste bestand met de persoonlijke sleutel toevoegt in Gebruiker bewerken > Keystore. (NPR-41366)
  • Er zijn pictogrammen nodig voor Microsoft® SharePoint en Microsoft® One Drive in de AEM 6.5-omgeving. (NPR-41354)
  • Niet-gelokaliseerde fout in gebruikersnaam/wachtwoord. tekenreeks in Beveiliging > Gebruiker > Maken in. (NPR-41245)
  • Popover code en de managers van de Gebeurtenis worden tweemaal geladen, die user-created Koral3-Gebaseerde gebruikersinterfaces breken. (NPR-41171)
  • Het uitschakelen werkt niet correct nadat u Alles selecteren hebt gebruikt in de AEM Sites-console. (NPR-41304)

Integrations integrations-6519

  • De verbindingen van SMS in een AEM e-mailcampagne worden niet correct geschreven; zij bevatten een HTML ankerelement. (NPR-41211)
  • Woorden die op het scherm van de rekeningsconfiguratie worden gebruikt zouden geen nieuw credentieel type moeten gebruiken. (NPR-41210)
  • De het rapportinvoerplanner van de Analyse van de beweging van ManagedPollConfig op banen te verliezen. Wanneer twee verschillende analytische kaders met verschillende rapportagesets aan twee verschillende plaatsen werden vastgemaakt, ManagedPollConfig maar één van hen is opiniepeild . (NPR-41209)
  • Wanneer de standaardwaarde wordt hersteld, blijft de eerder geselecteerde tijdframeknop ingeschakeld. In het inzichtelijke dashboard van de inhoud van AEM, door gebrek wordt het tijdkader geplaatst bij de week en toont inzichten van de inhoud als wekelijkse gegevens. Als de gebruiker nu andere tijdframeopties selecteert, zoals uur, dag, maand en jaar, veranderen de gegevens volgens de geselecteerde waarde. Als de waarden echter standaard opnieuw worden ingesteld, is het zichtbare tijdframe week, maar is de eerder geselecteerde tijdframeoptie nog steeds geselecteerd. (NPR-41246)

Eik oak-6519

  • Het nut van de steun aan tariefgrens schrijft aan AEM in het geval dat de async indexering wordt vertraagd. (NPR-40985)

Platform foundation-platform-6519

  • QueryBuilder-query's met vierkante haakjes worden onjuist vertaald naar xpath. (NPR-41298)

Vertaalprojecten foundation-translation-6519

  • Tijdens het maken van de taalkopie van pagina "A", moet deze automatisch de taalkopieën maken van de pagina's waarnaar wordt verwezen, fragmenten, fragmenten voor inhoud en elementen. Bovendien moet de nieuwe taalkopie van pagina "A" op het nieuwe pad de referenties hebben die zijn ingesteld voor de zojuist gemaakte taalkopieën van de pagina's, ervaringsfragmenten, inhoudsfragmenten en elementen. (NPR-41076)

Workflow foundation-workflow-6519

  • Kan een taak in het Postvak IN niet voltooien. Er wordt alleen een "ongedefinieerde" waarde waargenomen in het keuzemenu wanneer wordt geprobeerd de taak te voltooien en een actie te selecteren. Dit betekent dat de gebruikers niet het AEM 6.5.18 de dienstpak kunnen toepassen. (NPR-41402 en NPR-41473)
  • Kan de taken in Postvak IN niet voltooien. De vervolgkeuzelijst bevat geen waarde (alleen "ongedefinieerd") wanneer wordt geprobeerd de taak te voltooien voor ZIP-bestanden, Asset-rapporten, verplaatsen (geslaagd of mislukt) of het vervallen van middelen. (NPR-41305)
  • Wanneer een gebruiker Tools > Workflow > instanties, selecteert u vervolgens de actieve workflow en selecteert u View Payload resulteert dit in een pagina met 500 fouten. (NPR-41325)

Installeren Experience Manager 6.5.19,0 install

  • Experience Manager 6.5.19.0 vereist Experience Manager 6.5. Zie upgradedocumentatie voor gedetailleerde instructies.
  • De download van het de dienstpak is beschikbaar op Adobe Softwaredistributie.
  • Bij een implementatie met MongoDB en meerdere exemplaren, installeert u Experience Manager 6.5.19.0 op één van de instanties van de Auteur die de Manager van het Pakket gebruiken.
IMPORTANT
Adobe raadt u niet aan de Experience Manager 6.5.19.0-pakket. Voordat u het pakket installeert, moet u daarom een back-up maken van het crx-repository voor het geval u het terug moet rollen.

Installeer het de dienstpak op Experience Manager 6,5 install-service-pack

  1. Start de instantie opnieuw vóór de installatie als de updatemodus voor de instantie is geactiveerd (wanneer de instantie is bijgewerkt vanaf een eerdere versie). Adobe raadt aan de toepassing opnieuw te starten als de huidige uptime voor een instantie hoog is.

  2. Maak een momentopname of een nieuwe back-up van uw Experience Manager -instantie.

  3. Download het servicepack van Softwaredistributie.

  4. Pakketbeheer openen en vervolgens selecteren Upload Package om het pakket te uploaden. Zie voor meer informatie Pakketbeheer.

  5. Selecteer het pakket en selecteer Install.

  6. Om de S3 schakelaar bij te werken, stop de instantie na installatie van het Service Pack, vervang de bestaande schakelaar met een nieuw binair dossier dat in de installatiemap wordt verstrekt, en begin de instantie opnieuw. Zie Amazon S3 Data Store.

NOTE
De dialoog over de Manager UI van het Pakket bestaat soms tijdens de installatie van het de dienstpak. De Adobe adviseert dat u op foutenlogboeken wacht om zich te stabiliseren alvorens tot de plaatsing toegang te hebben. Wacht op de specifieke logboeken met betrekking tot het verwijderen van de updaterbundel alvorens wordt verzekerd dat de installatie succesvol is. Dit probleem treedt meestal op in het dialoogvenster Safari browser, maar kan soms voorkomen op om het even welke browser.

Automatische installatie

Er zijn twee verschillende methoden die u automatisch kunt installeren Experience Manager 6.5.19.0.

  • Plaats het pakket in ../crx-quickstart/install als de server online beschikbaar is. Het pakket wordt automatisch geïnstalleerd.
  • Gebruik de HTTP-API van Package Manager. Gebruiken cmd=install&recursive=true zodat de geneste pakketten worden geïnstalleerd.
NOTE
Experience Manager 6.5.19.0 ondersteunt geen installatie van Bootstrappen.

De installatie valideren

Als u wilt weten welke platformen gecertificeerd zijn voor deze release, raadpleegt u de technische voorschriften.

  1. De pagina met productinformatie (/system/console/productinfo) geeft de bijgewerkte versietekenreeks weer Adobe Experience Manager (6.5.19.0) krachtens Installed Products.

  2. Alle OSGi-pakketten zijn ACTIVE of FRAGMENT in de Console OSGi (de Console van het Gebruik: /system/console/bundles).

  3. De OSGi-bundel org.apache.jackrabbit.oak-core is versie 1.22.17 of hoger (webconsole gebruiken: /system/console/bundles).

Service Pack installeren voor Experience Manager Forms install-aem-forms-add-on-package

Voor instructies voor het installeren van het servicepakket op Experience Manager Forms raadpleegt u Installatie-instructies voor Experience Manager Forms Service Pack.

NOTE
De functie Adaptive Forms is beschikbaar in AEM 6.5 QuickStart, is uitsluitend ontworpen voor exploratie en evaluatie. Voor productiegebruik is het van essentieel belang een geldige licentie voor AEM Forms te verkrijgen, aangezien voor de adaptieve Forms-functionaliteit een correcte licentie vereist is.

GraphQL-indexpakket voor Experience Manager-inhoudsfragmenten installeren install-aem-graphql-index-add-on-package

Klanten die GraphQL gebruiken, moeten de Experience Manager-inhoudsfragment met GraphQL Index-pakket 1.1.1.

Zo kunt u de vereiste indexdefinitie toevoegen op basis van de functies die ze daadwerkelijk gebruiken.

Als u dit pakket niet installeert, kan dit leiden tot trage of mislukte GraphQL-query's.

NOTE
Installeer dit pakket slechts eenmaal per instantie; het hoeft niet opnieuw te worden geïnstalleerd met elk Service Pack.

UberJar uber-jar

The UberJar for Experience Manager 6.5.19.0 is beschikbaar in Maven Central-opslagplaats.

Om UberJar in een Geweven project te gebruiken, zie gebruiken van UberJar en neem het volgende gebiedsdeel in uw project POM op:

<dependency>
     <groupId>com.adobe.aem</groupId>
     <artifactId>uber-jar</artifactId>
     <version>6.5.19</version>
     <scope>provided</scope>
</dependency>
NOTE
UberJar en de andere verwante artefacten zijn beschikbaar op Maven Central Repository in plaats van Adobe Public Maven repository (repo.adobe.com). De naam van het hoofdbestand van UberJar wordt gewijzigd in uber-jar-<version>.jar. Er is dus geen classifier, met apis als de waarde voor de dependency -tag.

Verouderde en verwijderde functies removed-deprecated-features

Zie Verouderde en verwijderde functies.

Bekende problemen known-issues

  • Verwant aan eikenhout
    Van Service Pack 13 en hierboven, is het volgende foutenlogboek begonnen te verschijnen dat het persistentiegeheime voorgeheugen beïnvloedt:

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.0.202/5]
    at org.h2.mvstore.DataUtils.newMVStoreException(DataUtils.java:1004)
        at org.h2.mvstore.MVStore.getUnsupportedWriteFormatException(MVStore.java:1059)
        at org.h2.mvstore.MVStore.readStoreHeader(MVStore.java:878)
        at org.h2.mvstore.MVStore.<init>(MVStore.java:455)
        at org.h2.mvstore.MVStore$Builder.open(MVStore.java:4052)
        at org.h2.mvstore.db.Store.<init>(Store.java:129)
    

    of

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.1.214/5].
    

    U kunt deze uitzondering als volgt oplossen:

    1. De volgende twee mappen verwijderen uit crx-quickstart/repository/

      • cache
      • diff-cache
    2. Installeer het Service Pack of start de Experience Manager as a Cloud Service opnieuw.
      Nieuwe mappen van cache en diff-cache automatisch worden gemaakt en er is geen uitzondering meer die betrekking heeft op mvstore in de error.log.

  • Werk uw GraphQL-query's bij die mogelijk een aangepaste API-naam voor uw inhoudsmodel hebben gebruikt om in plaats daarvan de standaardnaam van het inhoudsmodel te gebruiken.

  • Een GraphQL-query kan de opdracht damAssetLucene index in plaats van de fragments index. Deze handeling kan resulteren in GraphQL-query's die mislukken of die lang duren.

    Om het probleem te verhelpen, damAssetLucene moet worden geconfigureerd om de volgende twee eigenschappen op te nemen onder /indexRules/dam:Asset/properties:

    • contentFragment

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/contentFragment"
      • propertyIndex="{Boolean}true"
      • type="Boolean"
    • model

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/data/cq:model"
      • ordered="{Boolean}true"
      • propertyIndex="{Boolean}true"
      • type="String"

    Nadat de indexdefinitie is gewijzigd, is opnieuw indexeren vereist (reindex = true).

    Na deze stappen zouden de vragen van GraphQL sneller moeten presteren.

  • Wanneer u probeert inhoudsfragmenten, sites of pagina's te verplaatsen, te verwijderen of te publiceren, is er een probleem wanneer verwijzingen naar inhoudsfragmenten worden opgehaald, omdat de achtergrondquery mislukt. De functionaliteit werkt dus niet.
    Om correcte verrichting te verzekeren, moet u de volgende eigenschappen aan de knoop van de indexdefinitie toevoegen /oak:index/damAssetLucene (opnieuw indexeren is niet vereist):

    code language-xml
    "tags": [
        "visualSimilaritySearch"
      ]
    "refresh": true
    
  • Wanneer u een GraphQL-query uitvoert met behulp van optionele variabelen, als een specifieke waarde niet voorzien voor de facultatieve variabele, dan zal de waarde voor die variabele als impliciet worden beschouwd null. Dit betekent dat het filter alleen overeenkomt null waarden voor de bijbehorende eigenschap.

    In de query hieronder ziet u bijvoorbeeld waar geen waarde is opgegeven voor de eigenschap lastName:

    code language-graphql
    query getAuthorsFilteredByLastName($authorLastName: String) {
    authorList(filter:
      {
        lastName: {_expressions: {value: $authorLastName}
        }}) {
      items {
        lastName
        }
      }
    }
    

    Alleen auteurs met de lastName eigenschap ingesteld op null wordt geretourneerd:

    code language-graphql
    {
    "data": {
      "authorList": {
        "items": [
          {
            "lastName": null
          }
        ]
      }
    }
    }
    
  • Als u uw Experience Manager -exemplaar van 6.5.0 - 6.5.4 naar het nieuwste servicepakket op Java™ 11, zie RRD4JReporter uitzonderingen in de error.log bestand. Als u de uitzonderingen wilt stoppen, start u de instantie van Experience Manager.

  • Gebruikers kunnen de naam wijzigen van een map in een hiërarchie in Assets en publiceer een geneste map naar Brand Portal. De maptitel wordt echter niet bijgewerkt in Brand Portal totdat de hoofdmap opnieuw wordt gepubliceerd.

  • De volgende fouten en waarschuwingsberichten kunnen tijdens de installatie van Experience Manager 6.5.x.x:

    • "Wanneer de Adobe Target-integratie is geconfigureerd in Experience Manager Als u de standaard-API (IMS-verificatie) van het doel gebruikt, leidt het exporteren van ervaringsfragmenten naar Doel tot onjuiste aanbiedingstypen die worden gemaakt. In plaats van het type "Experience Fragment"/bron "Adobe Experience Manager" maakt Target verschillende aanbiedingen met het type "HTML"/bron "Adobe Target Classic".
    • com.adobe.granite.maintenance.impl.TaskScheduler: Geen onderhoudsvensters gevonden bij graniet/bediening/onderhoud.
    • De validatie aan de adaptieve formulierserver-side mislukt wanneer statistische functies zoals SUM, MAX en MIN worden gebruikt (CQ-4274424).
    • com.adobe.granite.maintenance.impl.TaskScheduler - Geen onderhoudsvensters gevonden bij graniet/bediening/onderhoud.
    • De hotspot in een interactieve Dynamic Media-afbeelding is niet zichtbaar wanneer u een voorvertoning van het element weergeeft via de Shopable Banner-viewer.
    • com.adobe.cq.social.cq-social-jcr-provider bundle com.adobe.cq.social.cq-social-jcr-provider:1.3.5 (395)[com.adobe.cq.social.provider.jcr.impl.SpiSocialJcrResourceProviderImpl(2302)] : Time-out bij wachten op wijziging register is niet-geregistreerd.
  • Vanaf AEM 6.5.15 wordt de Rhino JavaScript Engine geleverd door de org.apache.servicemix.bundles.rhino bundle heeft een nieuw hoistinggedrag. Scripts die de strikte modus gebruiken (use strict;) moeten hun variabelen correct declareren, anders worden ze niet uitgevoerd, maar wordt er een runtimefout gegenereerd.

Bekende problemen voor AEM Forms

Ondersteunde platforms

  • JDK 11.0.20 wordt niet ondersteund voor de installatie van AEM Forms op JEE Installer. Alleen JDK 11.0.19 of eerdere versies worden ondersteund voor de installatie van AEM Forms op JEE Installer. (FORMS-10659)

Installatie

  • Op het JBoss® 7.1.4-platform, wanneer de gebruiker Experience Manager 6.5.16.0 of hoger servicepack installeert, adobe-livecycle-jboss.ear implementatie mislukt. (CQ-4351522, CQDOC-20159)

Installeer het serverfragment (AEM Service Pack 6.5.14.0 of eerder)

  • Als u een upgrade uitvoert naar AEM Service Pack 6.5.15.0 of hoger en uw AEM-instantie werkt op Tomcat 8.5.88, is het verplicht het servletfragment te installeren voor u gaat verder met de installatie van Service Pack 6.5.15.0 of hoger.
  • Het is verplicht het servletfragment te installeren voor alle toepassingsservers behalve voor servers die op JBoss® EAP 7.4.0 worden uitgevoerd.

U installeert als volgt het servletfragment:

  1. Het serverfragment downloaden van Softwaredistributie.
  2. Start de toepassingsserver.
  3. Wacht tot de logbestanden zijn gestabiliseerd en controleer de toestand van de bundel.
  4. Open Web Console-bundels. De standaard-URL is http://[Server]:[Port]/system/console/bundles.
  5. Selecteren Install of Update.
  6. Het gedownloade fragment selecteren
    org.apache.felix.http.servlet-api-1.2.0_fragment_full.jar
  7. Selecteren Install of Update.
  8. Wacht tot de toepassingsserver is gestabiliseerd.
  9. Stop de toepassingsserver.

Adaptieve Forms

  • Wanneer een adaptief formulier wordt gepubliceerd, worden alle afhankelijkheden, inclusief het beleid, opnieuw gepubliceerd, zelfs als er geen wijzigingen in zijn aangebracht. (FORMS-10454)
  • Wanneer een gebruiker een veld voor het eerst in een adaptief formulier configureert, wordt de optie voor het opslaan van een configuratie niet weergegeven in de eigenschappenbrowser. Als u een ander veld van het adaptieve formulier in dezelfde editor selecteert, wordt het probleem opgelost.
  • Wanneer gebruikers de verzendactie uitvoeren, mislukt de verzending met een fout:
    javax.servlet.ServletException: java.lang.NoSuchMethodError
    Om het probleem op te lossen, Compileer de Sling-scripts, zoals JSP, Java™ en Sighy opnieuw. (FORMS-8542)
  • Na het installeren van AEM Service Pack 6.5.14.0 en daarna, kunnen de gebruikers geen doopvont van JEE Admin UI voor de documenten van PDF selecteren wanneer het navigeren aan Home > Services > PDF Generator > Adobe PDF Settings, omdat de lettertypenlijst leeg lijkt. (FORMS-12095)
  • Met Adaptive Forms kunt u aangepaste functies gebruiken met ECMAScript versie 5 of lager. Wanneer een douanefunctie ECMAScript versie 6 of later, zoals "laat", "const", of pijlfuncties gebruikt, zou de regelredacteur niet behoorlijk kunnen openen.

AEM Forms op JEE

  • Er zijn kritieke beveiligingskwetsbaarheden gemeld voor Struts 2 RCE, een populair en open-source webtoepassingsframework voor het ontwikkelen van Java EE-webtoepassingen. Adobe is vrijgegeven AEM 6.5 Service Pack 19.1 (6.5.19.1) om de kwetsbaarheid in AEM Forms op JEE te verhelpen.

Interactieve communicatie

    • De prefill dienst ontbreekt met een ongeldige wijzeruitzondering. (CQDOC-21355)

OSGi-bundels en inhoudspakketten inbegrepen osgi-bundles-and-content-packages-included

In de volgende tekstdocumenten worden de OSGi-bundels en Content Packages weergegeven die zijn opgenomen in Experience Manager 6.5.19.0:

Beperkte websites restricted-sites

Deze websites zijn alleen beschikbaar voor klanten. Als u een klant bent en toegang nodig hebt, neemt u contact op met uw accountmanager van de Adobe.

recommendation-more-help
19ffd973-7af2-44d0-84b5-d547b0dffee2