Pulizia degli indirizzi verticali: indirizzi diversi non consentiti

In questo articolo viene illustrata la soluzione del problema per cui quando l'utente tenta di immettere un indirizzo di fatturazione e spedizione diverso, con la convalida degli indirizzi verticali abilitata, la vetrina non consente all'utente di immetterlo.

Prodotti e versioni interessati

  • Adobe Commerce on-premise e Adobe Commerce sull’infrastruttura cloud 2.3.5-p1

Problema

Passaggi da riprodurre:

  1. Vai a Amministratore > Archivi > Configurazione > Vendite > Pulizia indirizzi.
  2. Seleziona Abilitato dal menu a discesa Usa pulizia indirizzi verticali e Salva configurazione.
  3. Vai al front-end come ospite e aggiungi un prodotto al carrello.
  4. Fai clic sull'icona del carrello e Procedi all'estrazione.
  5. Compila i campi indirizzo.
  6. Seleziona il metodo di spedizione desiderato e fai clic su Avanti.
  7. Fai di nuovo clic sul pulsante Avanti.
  8. Deseleziona Il mio indirizzo di fatturazione e spedizione sono uguali e immetti un nuovo indirizzo di fatturazione (diverso da Indirizzo).
  9. Fare clic sul pulsante Aggiorna, quindi su Aggiorna indirizzo.

Risultati previsti:

L’utente visualizza diversi indirizzi di fatturazione e spedizione.

Risultati effettivi:

Quando l’utente preme il tasto Aggiorna, gli indirizzi di fatturazione e di spedizione diventano gli stessi.

Causa

Verifica indirizzo vertice non riuscita.

Soluzione

Disattiva la verifica degli indirizzi verticali o esegui l’aggiornamento alla versione 2.4.0.

Lettura correlata

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a