Pulizia degli indirizzi verticali: indirizzi diversi non consentiti
In questo articolo viene illustrata la soluzione del problema per cui quando l'utente tenta di immettere un indirizzo di fatturazione e spedizione diverso, con la convalida degli indirizzi verticali abilitata, la vetrina non consente all'utente di immetterlo.
Prodotti e versioni interessati
- Adobe Commerce on-premise e Adobe Commerce sull’infrastruttura cloud 2.3.5-p1
Problema
Passaggi da riprodurre:
- Vai a Amministratore > Archivi > Configurazione > Vendite > Pulizia indirizzi.
- Seleziona Abilitato dal menu a discesa Usa pulizia indirizzi verticali e Salva configurazione.
- Vai al front-end come ospite e aggiungi un prodotto al carrello.
- Fai clic sull'icona del carrello e Procedi all'estrazione.
- Compila i campi indirizzo.
- Seleziona il metodo di spedizione desiderato e fai clic su Avanti.
- Fai di nuovo clic sul pulsante Avanti.
- Deseleziona Il mio indirizzo di fatturazione e spedizione sono uguali e immetti un nuovo indirizzo di fatturazione (diverso da Indirizzo).
- Fare clic sul pulsante Aggiorna, quindi su Aggiorna indirizzo.
Risultati previsti:
L’utente visualizza diversi indirizzi di fatturazione e spedizione.
Risultati effettivi:
Quando l’utente preme il tasto Aggiorna, gli indirizzi di fatturazione e di spedizione diventano gli stessi.
Causa
Verifica indirizzo vertice non riuscita.
Soluzione
Disattiva la verifica degli indirizzi verticali o esegui l’aggiornamento alla versione 2.4.0.
Lettura correlata
- Problema noto di Adobe Commerce 2.4.0: messaggio di errore durante la selezione del metodo di pagamento locale visualizzato per alcuni paesi durante l’acquisto
- Problema noto di Adobe Commerce 2.4.0: errore 404 durante la rimozione dei punti premio in caso di pagamento tramite multi-shipping
- Problema noto di Adobe Commerce 2.4.0: errore di visualizzazione degli ordini
- L’amministratore B2B di Adobe Commerce 2.4.0 non può aggiungere un prodotto configurabile all’offerta
- Problema noto di Adobe Commerce 2.4.0: i metodi di pagamento Braintree non vengono visualizzati nel checkout di più indirizzi
- Problema noto di Adobe Commerce 2.4.0: l’aggiornamento delle attività del cliente non funziona
- Problema noto di Adobe Commerce 2.4.0 - L’aliquota dell’imposta sull’esportazione non funziona
- Problema noto di Adobe Commerce 2.4.0: il pulsante "Aggiungi selezioni al carrello" non funziona
- Problema noto di Adobe Commerce 2.4.0: visualizzazione dei dati dei messaggi non elaborati nella vetrina
- Adobe Commerce 2.4.0 problema noto: etichetta "Refund" mancante in Klarna
- Problema noto di Adobe Commerce 2.4.0: due pulsanti mancanti nella pagina Crea nuovo ordine in Amministratore
- Problema noto di Adobe Commerce 2.4.0: quando la funzione Braintree è abilitata, si verifica un problema di fattura parziale di Venmo
- Problema noto di Adobe Commerce 2.4.0: messaggio di errore durante la selezione del metodo di pagamento locale visualizzato per alcuni paesi durante l’acquisto
- Problema noto di Adobe Commerce 2.4.0: Amazon Pay abilitato, metodi di pagamento mancanti quando viene utilizzato il metodo Return to standard checkout
- Problema noto di Adobe Commerce 2.4.0: l’installazione della versione 2.4.0 non riesce e la cache degli archivi è obsoleta
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a