[AEM Assets]{class="badge positive" title="适用于AEM Assets)。"}

使用资产微服务和处理配置文件 get-started-using-asset-microservices

资产微服务通过​云原生应用程序(也称为​工作程序)提供​可扩展和弹性的资产处理 — 可独立扩展在云中运行的处理单元,以按需处理资产。 由于这些工人可弹性扩展,因此处理容量会在大量摄取期间自动扩展,并在空闲时收缩,这比固定容量处理提高了吞吐量和可靠性。

Adobe直接管理这些服务,确保优化处理各种资源类型和处理选项。 这种管理式方法意味着管理员不需要配置、调整或维护底层处理基础架构,使团队能够专注于资产配置而不是运营开销。

支持的文件类型和格式

资产微服务可处理多种文件类型,与以前版本的​Experience Manager​ 相比,涵盖了 ​多种现成的格式。 这种扩展的本机支持移除了许多常见工作流对外部工具的依赖性。

例如,当前本地支持​PSD (Photoshop文档)和PSB (Photoshop大)格式的缩略图提取。 在以前的版本中,这需要第三方解决方案,例如​ImageMagick。 直接在平台内处理这些格式简化了管道,降低了集成的复杂性,并消除了外部依赖关系的维护负担。

处理配置文件配置

资源处理受​ 处理配置文件 ​中定义的配置控制。 Experience Manager附带基本默认设置,允许管理员添加更具体的资产处理配置以符合其要求。

资产处理的高级视图

管理员负责以下配置任务:

  • 创建​新的后处理工作流配置以满足特定资产处理需求。
  • 维护​现有配置以保持处理行为与组织标准一致。
  • 修改​配置,包括后处理工作流的可选自定义。

开发人员可以通过自定义这些工作流来扩展默认产品。 由于后处理工作流是可配置的,因此开发人员添加超出标准功能的处理步骤,根据专用用例定制管道。

与旧版DAM更新资产工作流的关系

NOTE
此处描述的资产处理过程替换了Experience Manager早期版本中存在的DAM Update Asset工作流模型。 资产微服务处理取代了大多数标准演绎版生成和元数据相关步骤。 后处理工作流配置可以替换剩余步骤(如果有),以便通过新模型处理完整的处理管道。

了解资源处理选项 get-started

Experience Manager (AEM)支持三个渐进级别的资源处理:默认配置、自定义配置​和​自定义配置文件。 这些选项形成了一个分层上报模型 — 从现成的默认设置开始,扩展到管理员定义的自定义设置,最终形成完全可编程、云原生处理的高级要求。 选择正确的级别取决于您的组织对演绎版格式、分辨率和文件类型处理所需的控制程度。

选项
描述
涵盖的用例
默认配置
此配置现成可用,无法修改。 它提供了基本的、即用的演绎版生成,使其适用于没有管理员设置的标准资源工作流。
  • Assets用户界面使用的标准缩略图(48、140​和​ 319 ​像素)
  • 大型预览(Web呈现版本 — 1280像素)
  • 元数据和文本提取。
自定义配置
由管理员通过用户界面配置。 它扩展了默认选项以提供额外的呈现版本生成控件,从而支持超出现成默认值的不同格式和呈现版本。
  • FPO(仅用于置入)​呈现版本。
  • 更改图像的文件格式和分辨率。
  • 有条件地将处理应用于配置的文件类型。
自定义配置文件
管理员通过用户界面配置自定义代码,以通过调用Asset Compute服务(Adobe用于以编程方式处理资源的服务)的自定义应用程序运行自定义代码。 这能够以云原生和可扩展的方法支持更复杂的需求,因为处理在按需扩展的托管云基础架构上运行,而不是在固定的本地资源上运行。
查看允许的用例。

支持的文件格式 supported-file-formats

资产微服务为范围广泛的图像、文档、视频和音频文件格式提供支持。 在这些支持的格式中,资产微服务提供了三种核心功能:

  • 处理文件 — 摄取和转换资源,以便它们能够在数字资产管理工作流中供下游使用。
  • 生成演绎版 — 生成资源的替代版本,如调整大小的缩略图、预览或格式转换的副本。 演绎版可确保按照每个渠道所需的大小、分辨率或格式提供单个源资源。
  • 提取元数据 — 直接从每个文件中读取嵌入的和技术元数据(例如,维度、颜色配置文件或创作详细信息)。 这使得资源可搜索、可发现并始终如一地编录。

可用的特定功能取决于文件类型。 每个受支持的格式都由其​ 多用途Internet邮件扩展名(MIME)类型 ​标识,该类型为标准化标识符,用于告知系统应如何解释文件以及对其应用哪些处理操作。

有关支持的MIME类型和每种类型可用的功能的完整列表,请参阅支持的文件格式。

默认配置 default-config

Experience Manager附带预配置的默认值,这些默认值会立即使平台所需的​ 默认呈现版本 ​可用。 演绎版是Experience Manager从原始上传生成的资源的替代版本,例如预览、缩略图和Web优化派生项。 默认配置还可确保核心操作自动运行,以便:

  • 元数据提取​捕获嵌入到每个上传资源中的描述性信息。
  • 文本提取​从支持的文件类型中提取可读文本内容。
  • 已生成默认演绎版,因此资源可以在Experience Manager中使用。

因此,用户可以立即开始上传或更新资产,并且默认情况下无需任何其他设置即可进行基本处理。

默认处理配置文件

使用默认配置,Experience Manager仅应用最基本的处理配置文件。 处理配置文件​定义了Experience Manager对摄取的资源执行的一组操作,包括格式副本、元数据处理和文本提取。 此默认处理配置文件在用户界面中不可见,您无法对其进行修改。

此默认处理配置文件始终执行以处理上传的资产,从而确保Experience Manager所需的基线处理在每个资产上完成。 由于它无条件运行,因此任何资产在进入系统时都必须接收基本演绎版和提取操作Experience Manager,这些操作取决于搜索、预览和交付。

标准配置 standard-config

Experience Manager提供了根据用户的需要为常用格式生成更具体的呈现版本的功能。 管理员可以创建其他处理配置文件来促进此类演绎版的创建。 然后,用户将一个或多个可用配置文件分配给特定文件夹,以完成其他处理。 例如,额外的处理可以为Web、移动设备和平板电脑生成演绎版,从而确保以针对其目标设备和渠道优化的大小交付每个资产。 观看此视频,了解如何创建和应用处理配置文件以及如何访问创建的演绎版。

  • 演绎版宽度和高度:演绎版宽度和高度规范定义了所生成输出图像的最大大小。 资源微服务会生成最大可能的演绎版,其宽度和高度分别不超过指定的值。 纵横比将保留,以保持与原始格式副本相同,从而确保生成的格式副本不会相对于源资源扭曲或拉伸。 空值意味着资产处理会假定原始资产的像素尺寸。

  • MIME类型包含规则: Multipurpose Internet Mail Extensions (MIME)类型确定是否为给定资源生成演绎版。 在处理具有特定MIME类型的资源时,将首先根据演绎版规范的排除MIME类型值检查MIME类型。 如果与该列表匹配,则不会为资源(阻止列表)生成此特定演绎版。 否则,将针对包含的MIME类型检查MIME类型,如果它与列表匹配,则生成演绎版(允许列表)。

  • 特殊FPO(仅用于置入)演绎版:将来自Experience Manager的大型资产置入Adobe InDesign文档时,创意专业人士会在置入资产后等待相当长的时间。 同时,创意专业人士被阻止使用InDesign。 因此,这会中断创作流并对用户体验产生负面影响。 为解决此问题,Adobe允许首先在InDesign文档中临时放置小型演绎版,从而允许创意专业人士立即恢复工作;稍后可按需用全分辨率资源替换这些占位符。 Experience Manager提供仅用于放置的演绎版。 这些“仅用于放置”(FPO)演绎版的文件大小较小,但保留了与原始演绎版相同的纵横比,因此,当全分辨率资源换入时,针对这些演绎版组成的布局将保持准确。

处理配置文件可以包含FPO(仅用于放置)演绎版。 请参阅Adobe Asset Link 文档以了解是否需要为处理配置文件启用它。 有关详细信息,请参阅Adobe Asset Link完整文档。

创建标准配置文件 create-standard-profile

  1. 管理员可访问​工具 > Assets > 处理配置文件。 单击​创建。

  2. 提供一个描述性名称,帮助管理员在将配置文件应用于文件夹时唯一地标识该配置文件,因为配置文件名称决定了如何在文件夹分配期间选择配置文件。

  3. 要生成FPO(仅用于置入)演绎版(在最终高分辨率资源可用之前用于布局、预览和引用的图像的低分辨率占位符版本),请打开​ 图像 ​选项卡并启用​创建FPO演绎版。 输入1至100之间的​ Quality ​值,其中较高的值会产生较高质量的FPO演绎版。

  4. 要生成其他演绎版(以不同大小、格式或质量级别派生的原始图像的替代版本),请单击“新增”​​并提供以下信息:

    • 每个呈现版本的​文件名,用于标识生成的输出。
    • 从PNG、JPEG、GIF或WebP中选择的每个演绎版的​文件格式。
    • 每个演绎版的​宽度和高度(以像素为单位)。 如果未指定宽度和高度值,则使用原始图像的完整像素大小,这将确保演绎版保持源图像的本机尺寸。
    • 每个JPEG和WebP格式副本的​质量(百分比),用于控制这些格式的压缩级别和结果文件大小。
    • 包含和排除的MIME(多用途Internet邮件扩展)类型,这些类型通过指定格式副本规则应用于哪些资产类型以及忽略哪些资产类型来定义配置文件的适用性。

    processing-profiles-adding

  5. 单击​ 保存 ​以存储配置文件并将其分配给文件夹。

自定义用户档案和用例 custom-config

Asset Compute Service​支持多种用例,包括默认处理和处理Adobe特定的格式,如Photoshop文件。 该服务还支持根据独特要求实施定制或组织特定的处理。 以前需要数字资产管理(DAM)更新资产工作流的自定义现在可自动处理或通过​ 处理配置文件 ​配置进行处理。 如果这些处理选项无法满足特定的业务需求,Adobe建议开发和部署​ Asset Compute Service ​以扩展默认功能。 有关概述,请参阅了解可扩展性和何时使用它。

NOTE
Adobe建议仅在无法使用默认配置或标准配置文件满足业务需求时才使用自定义应用程序。

Asset Compute Service​将图像、视频、文档和其他文件格式转换为多个呈现形式,包括​缩略图、提取的文本和元数据以及存档。 这允许组织自动生成交付、搜索和下游工作流所需的衍生资产。

开发人员可以使用​ Asset Compute Service ​到为支持的用例创建自定义应用程序。 Experience Manager使用管理员配置的​自定义配置文件,直接从用户界面调用这些自定义应用程序。 因此,最终用户无需手动干预即可使用自定义处理。 Asset Compute Service​支持以下调用外部服务的用例:

  • 使用Adobe Photoshop的ImageCutout API删除背景或隔离主题,并将结果保存为演绎版以供重用。
  • 调用第三方系统以进行更改,例如​ 产品信息管理(PIM) ​系统,以便资产处理与外部业务数据保持同步。
  • 使用​ PhotoshopAPI ​根据Photoshop模板生成各种演绎版,确保大规模一致、品牌一致的输出。
  • 使用Adobe Lightroom API优化摄取的资源并将其另存为演绎版,以在摄取期间自动提高视觉质量。
NOTE
无法使用自定义应用程序编辑标准元数据。 您只能修改自定义元数据。

创建自定义配置文件 create-custom-profile

Adobe Experience Manager中的​ 自定义处理配置文件 ​允许管理员将资源路由到​headless App Builder应用程序,该应用程序生成一个或多个自定义​呈现。 请按照以下步骤创建一个:

  1. 管理员可访问​工具 > Assets > 处理配置文件 > 创建。

  2. 在处理配置文件页面上,单击​ 自定义 ​选项卡,然后单击​新增。

  3. 在“名称”文本字段中,键入所需的格式副本文件名,然后提供以下信息。

    • 每个演绎版的文件名和​支持的文件扩展名。
    • App Builder自定义应用程序🔗的​终结点URL (统一资源定位器)。 应用程序必须来自与Experience Manager帐户相同的​组织。
    • 将​ 服务参数 ​添加到将额外信息或参数传递给自定义应用程序。
    • 已包含和排除​MIME (多用途Internet邮件扩展)类型,以将处理限制为几种特定的文件格式。
  4. 在页面的右上角附近,单击​保存。

自定义应用程序是​Headless Project App Builder应用程序 — 这意味着它们在没有用户界面的情况下运行,并在资产处理管道中自动执行。 当应用程序与处理配置文件关联时,自定义应用程序接收提供给它的所有文件。 应用程序必须过滤文件,因为它会处理每个被传递的资源;过滤可确保只转换预期的相关文件格式,并忽略不支持的或不想要的输入。

CAUTION
App Builder应用和Experience Manager帐户​必须属于同一组织。 如果它们属于不同的组织,则集成会失败,并且自定义处理不会运行。 要授权端点连接,需要此组织匹配。

自定义用户档案的示例 custom-profile-example

自定义处理配置文件使用Adobe PhotoshopAPI​将自定义文本应用于营销活动图像,以自动编辑这些图像。 此示例说明了一个常见用例:当资产被摄取到Experience Manager中时,将品牌或营销活动特定的文本叠加添加到资产。

自定义配置文件如何将参数传递到Photoshop API

Asset Compute Service​集成允许Experience Manager通过​ 服务参数 ​字段将这些参数传递到自定义应用程序。 然后,自定义应用程序调用​ PhotoshopAPI ​并将这些值传递到API。 这可确保每次处理资产时成像逻辑都始终如一地运行,而无需手动编辑。

通过​ 服务参数 ​字段,您可以传递以下参数以将自定义文本添加到促销活动图像:

  • 字体名称 — 指定应用于覆盖文本的字体。
  • 文本颜色 — 定义所应用文本的颜色。
  • 文本粗细 — 设置文本的粗细或粗细。
  • 文本大小 — 确定呈现的文本的尺寸。

自定义处理配置文件

图:使用服务参数字段将添加的信息传递到内置到自定义应用程序中的预定义参数。 在此示例中,由于配置文件应用于摄取,因此上传促销活动图像会自动触发更新,并且图像将使用Arial-BoldMT字体中的Jumanji文本进行渲染。

使用处理配置文件处理资产 use-profiles

创建其他自定义处理配置文件并将其应用到特定文件夹。 此工作流允许Experience Manager处理上传到这些文件夹或在这些文件夹中更新的资产。 默认的内置标准处理配置文件始终执行,但在用户界面中不可见。 如果您添加自定义配置文件,则Experience Manager会使用这两个配置文件来处理上传的资源。 这可确保在将自定义呈现添加到顶部时始终应用标准默认处理。

将处理配置文件应用到文件夹的方法

使用以下三种方法之一将处理配置文件应用到文件夹:

  • 管理员可以在​工具 > Assets > 处理配置文件​中选择处理配置文件定义,并使用​ 将配置文件应用到文件夹 ​操作。 该操作将打开一个内容浏览器,允许您导航到特定文件夹并选择它们,然后确认配置文件的应用程序。

  • 用户可以在Assets用户界面中选择文件夹,并使用​ 属性 ​操作打开文件夹属性屏幕。 在​ 资产处理 ​选项卡上,用户可以从处理配置文件列表中选择该文件夹的相应处理配置文件。 要保存更改,请单击​“保存并关闭”。

    从“资产属性”选项卡将处理配置文件应用到文件夹

  • 用户可以在Assets用户界面中选择文件夹或特定资源以应用处理配置文件,然后从顶部可用的选项中选择 资源重新处理图标 重新处理Assets​选项。

TIP
一个文件夹只能应用一个处理配置文件。 要生成更多演绎版,请向现有处理配置文件添加更多演绎版定义。

在处理配置文件应用于文件夹后,该文件夹或其任何子文件夹中上传(或更新)的所有新资产都会使用其他配置的处理配置文件自动进行处理。 因此,文件夹级别的处理会向下传播整个文件夹树。 这种处理是在标准默认配置文件之外进行的。

NOTE
应用于文件夹的处理配置文件适用于整个树,但可以用应用于子文件夹的其他配置文件来覆盖。 将资产上传到文件夹时,Experience Manager会检查包含文件夹的属性以查找处理配置文件。 如果未应用任何配置文件,则会检查层级中的父文件夹以确定要应用的处理配置文件。

要验证是否已处理资源,请在左边栏的呈现版本视图中预览生成的呈现版本。 打开资源预览并打开左边栏以访问​ 呈现版本 ​视图。 处理配置文件中的特定演绎版(其特定资产的类型与MIME类型包含规则匹配)可见且可访问。

其他节目

图:由应用于父文件夹的处理配置文件生成的两个其他呈现形式的示例。

后处理工作流 post-processing-workflows

后处理工作流​在资源微服务执行的可配置处理之上添加完全自定义的资源处理。 当需要对资产进行额外处理,而单独使用处理配置文件无法实现​ ​ ​时,请使用它们。 通过将这些工作流添加到配置,管理员可以将Experience Manager扩展至其标准处理能力之外,以满足专门的要求。

在微服务处理完成后,Experience Manager 自动​运行后处理工作流,或者自动启动工作流(如果已配置)。 由于Experience Manager在完成微服务处理时自动触发这些工作流,因此无需手动添加工作流启动器。 常见示例包括:

  • 自定义工作流步骤​以处理资产。
  • 集成,用于将元数据或属性从外部系统添加到资源,例如产品或流程信息。
  • 外部服务执行的其他处理。

要将后处理工作流配置添加到Experience Manager,请执行以下步骤:

  1. 创建一个或多个工作流模型。 在本文档中,这些自定义模型称为​后处理工作流模型。 它们是常规的Experience Manager工作流模型。
  2. 将所需的工作流步骤添加到这些模型中。 查看默认工作流的步骤,并将所有必需的默认步骤添加到自定义工作流中。 Experience Manager根据工作流模型配置对资产运行这些步骤。 例如,要使智能标记在资产上传时自动发生,请将智能标记步骤添加到自定义后处理工作流模型中。
  3. 在末尾添加DAM更新资产工作流已完成流程步骤。 此步骤至关重要:它在处理结束时发出信号Experience Manager,以便可以将资源标记为已处理 — 即,在资源上显示​New。 如果没有此最终步骤,Experience Manager将无法可靠地确定处理已完成。
  4. 为自定义工作流运行器服务创建配置。 此配置允许管理员通过路径(文件夹位置)或正则表达式定义后处理工作流模型的执行。

有关可在后处理工作流中使用的标准工作流步骤的详细信息,请参阅developer reference中的后处理工作流中的工作流步骤。

在Adobe Experience Manager中创建后处理工作流模型 create-post-processing-workflow-models

后处理工作流模型是用于处理​ 数字资产管理(DAM) ​存储库中的数字资产的标准​ Adobe Experience Manager (AEM) ​工作流模型。 当不同的存储库位置或资产类型需要不同的处理时,请创建单独的模型,因为针对每个场景定制模型可确保根据特定需求处理资产。

构建工作流:​从符合要求的处理步骤中汇编每个后处理工作流。 您可以合并:

  • 随Experience Manager一起提供的​支持的(现成)步骤
  • 自定义实施的工作流步骤​构建用于满足专业处理需求

关键要求 — 最后一个步骤:​每个后处理工作流的最后一步必须是​DAM Update Asset Workflow Completed Process。 此步骤表示Experience Manager已完成。 因此,Experience Manager可以识别资产处理何时完成,并且可以将该资产从正在进行的状态转换出来。 如果忽略此最后一步,则平台将无法检测到处理已完成,这可能会使资产停留在未解析的工作流状态。

配置后处理工作流执行 configure-post-processing-workflow-execution

在资产微服务完成对上传资产的处理之后,您可以定义后处理工作流,以将其他转换、扩充或自定义操作应用于资产。 要使用工作流模型配置后处理,请使用以下方法之一:

将工作流模型应用到文件夹 apply-workflow-model-to-folder

对于典型的后处理用例,将工作流直接应用于文件夹。 这是最简单、最常见的方法。 要在文件夹属性中应用工作流模型,请执行以下步骤:

  1. 创建工作流模型。

  2. 选择一个文件夹,单击工具栏中的​属性,然后单击​ Assets处理 ​选项卡。

  3. 在​ 自动启动工作流 ​下,选择所需的工作流,提供工作流的标题,然后保存更改。

    将后处理工作流应用于其属性中的文件夹

配置自定义工作流运行器服务 configure-custom-workflow-runner-service

为无法通过将工作流应用于文件夹而轻松完成的高级配置配置配置自定义工作流运行器服务。 例如,使用正则表达式选择性地定位特定资产路径的工作流。 此服务非常有用,因为它允许您将不同的工作流模型映射到不同的存储库位置或命名模式,而仅文件夹级别的配置无法实现这些目标。 Adobe CQ数字资产管理(DAM)自定义工作流运行器(com.adobe.cq.dam.processor.nui.impl.workflow.CustomDamWorkflowRunnerImpl)是OSGi(开放服务网关计划)服务。 它提供了以下两个配置选项:

  • 按路径 (postProcWorkflowsByPath)后处理工作流:可以根据不同的存储库路径列出多个工作流模型。 使用冒号分隔路径和模型。 支持简单的存储库路径。 将它们映射到/var路径中的工作流模型。 例如:/content/dam/my-brand:/var/workflow/models/my-workflow。
  • 表达式后处理的工作流 (postProcWorkflowsByExpression):可以根据不同的正则表达式列出多个工作流模型。 使用冒号分隔表达式和模型。 将正则表达式直接指向Asset节点,而不是呈现版本或文件之一。 例如:/content/dam(/.*/)(marketing/seasonal)(/.*):/var/workflow/models/my-workflow。

要了解如何部署OSGi配置,请参阅部署到 Experience Manager。

禁用后处理工作流执行

当不需要后期处理时,通过在​ 自动启动工作流 ​选择中创建并应用“空”工作流模型来禁用执行。 这样可防止在不需要工作流的文件夹上进行不必要的处理。

创建禁用的自动启动工作流模型
  1. 导航到​工具 > 工作流 > 模型。

  2. 在顶部操作栏中单击​创建 > 创建模型。

  3. 提供新工作流模型的标题和名称,例如:

    • Title:禁用自动启动工作流
    • 名称:disable-auto-start-workflow
  4. 单击​ 完成 ​以创建工作流模型。

  5. 选择并编辑创建的工作流模型。

  6. 在工作流模型编辑器中,单击模型定义中的​ 步骤1 ​并删除它。

  7. 从侧面板中,单击​步骤。

  8. 将​ DAM更新资产工作流已完成 ​步骤拖动到模型定义中。

  9. 单击​页面信息(在​ 侧面板 ​切换旁边),然后单击​打开属性。

  10. 在“基本”选项卡下,单击​临时工作流。 临时工作流不会在存储库中保留其执行历史记录,这可以降低开销并提高处理性能。

  11. 在顶部操作栏中,单击​保存并关闭。

  12. 在顶部操作栏中,单击​同步。

  13. 关闭工作流模型编辑器。

应用禁用的自动启动工作流模型

按照中概述的步骤将工作流模型应用到文件夹,并将​ 禁用自动启动工作流 ​设置为不需要资产后处理的文件夹的​自动启动工作流。

最佳实践和限制 best-practices-limitations-tips

最佳实践

  • 在设计工作流时,请考虑您对所有类型的演绎版的需求。 如果您预计将来不需要节目,请从工作流中删除其创建步骤。 之后不能批量删除节目。 由于无法共同删除未使用的演绎版,因此在长时间使用Adobe Experience Manager (AEM)后,不需要的演绎版可能会累积并消耗大量存储空间。 对于单个资源,您可以从用户界面手动删除演绎版。 对于多个资源,您可以自定义Experience Manager以删除特定演绎版,或删除这些资源并重新上传。

当前限制

  • 目前,支持仅限于生成演绎版。 不支持生成新资产。
  • 元数据提取的文件大小限制为​大约15 GB。 上传非常大的资源时,如果文件超过此阈值,元数据提取操作可能会失败。
  • 建议将应用于资产的演绎版数量限制为小于​40,因为超过此限制会导致请求被截断。

另请参阅

recommendation-more-help
experience-manager-cloud-service-help-main-toc