Adobe Commerce セキュリティスキャンツールのトラブルシューティングガイド

Adobe CommerceとMagento Open Sourceのセキュリティスキャンツールに関する様々な問題のトラブルシューティング方法について説明します。

問題:サイトを送信できない

セキュリティ スキャン ツールでは、ドメインをセキュリティ スキャン ツールに追加する前に、サイトの所有権を証明する必要があります。 これを行うには、HTMLコメントまたは <meta> タグ。 HTMLコメントは、内に配置する必要があります。 <body> フッターセクションなどでのタグ。 この <meta> タグはページの内に配置する必要があります。 <head> セクション。

マーチャントが直面する一般的な問題は、セキュリティスキャンツールがマーチャントのサイト所有権を確認できない場合に発生します。

エラーが発生し、スキャンのためにサイトを送信できない場合は、 サイトをセキュリティ スキャンに追加するときに表示されるエラーメッセージ サポートナレッジベースのトラブルシューティング記事。

問題:セキュリティ スキャン ツールで生成されたレポートが空です

セキュリティスキャンツールから空のスキャンレポートを取得するか、次のようなエラーが 1 つだけ含まれるレポートを取得します セキュリティ ツールがベース URL に到達できませんでした または 指定された URL にMagentoのインストールが見つかりません.

解決策

  1. 52.87.98.44、34.196.167.176、および 3.218.25.102 IP が 80 および 443 ポートでブロックされていないことを確認します。
  2. リダイレクト用に送信された URL を確認する(例:) https://mystore.com はにリダイレクトされます https://www.mystore.com またはその逆、またはその他のドメイン名にリダイレクトします)。
  3. WAF/Web サーバーのアクセスログで、却下されたリクエストまたは実行されなかったリクエストを調査します。 HTTP 403 Forbidden および HTTP 500 Internal server error は、空のレポート生成を引き起こす一般的なサーバー応答です。 ユーザーエージェントによる要求をブロックする確認コードの例を次に示します。
if(req.http.user-agent ~ "(Chrome|Firefox)/[1-7][0-9]" && client.ip !~ useragent_allowlist)

{   error 403;   }

以下も参照してください。 セキュリティスキャンツールレポートが空白になる 詳しくは、サポートナレッジベースの記事を参照してください。

問題:セキュリティの問題は解決されましたが、スキャン時に引き続き脆弱と表示されます

セキュリティ上の問題が解決され、新しく解決された問題に対する脆弱性がなくなったことを示すセキュリティスキャンが表示されることを期待しています。 代わりに、セキュリティスキャンによって生成されたレポートが、セキュリティの問題に対する脆弱性を引き続き報告していることがわかります。

原因:

クラウドインスタンスのメタデータは、次の場合にのみ収集されます active および live クラウドプロジェクトとは、リアルタイムプロセスではありません。

統計収集スクリプトは 1 日に 1 回実行されます。その後、セキュリティスキャンツールが新しいデータを取得する必要があります。

期待される同期アップサイクルの待ち時間は最大 1 週間で、少なくとも 24 時間かかります。

チェックから、次のステータスが表示される場合があります。

  1. 合格:セキュリティスキャンツールで更新されたデータがスキャンされ、変更が承認されました。
  2. 不明:セキュリティスキャンツールには、ドメインに関するデータがまだありません。次の同期サイクルが始まるまで待ってください。
  3. 失敗:ステータスに「失敗」と表示された場合は、問題を修正する必要があります(2FA を有効にする、管理者 URL を変更など)。 そして、次の同期アップサイクルを待ちます。

インスタンスに対して変更が行われてから 24 時間が経過し、それらがセキュリティスキャンレポートに反映されていない場合は、次のことができます サポートチケットを送信. チケットの送信時にストア URL を指定します。

BotNet の疑わしいエラー

「BotNet Suspect」エラーに関する通知が届きます。

原因:

  1. ストアドメイン名は 2019 年に「潜在的な BotNet 参加者リスト」になり、管理パネル、ダウンローダー、または RSS 機能が公開され、その URL は CC スキミングフォーラムで言及されました。
  2. このアラートは、ページ上で見つかった JavaScript のような、ストアの侵害やマルウェアの兆候によって引き起こされる可能性があります。
  3. それは必ずしも継続中の問題ではない。 以前にストアが侵害された場合でも、そのホスト名は「犠牲者」の名前としてダークウェブの周りに浮き上がることができます。
  4. Adobe Commerceではなく、(OS レベルでの)システムの妥協が原因である可能性もあります。

解決策

  1. 新しく作成した SSH アカウント、ファイルシステムの変更などを確認します。
  2. セキュリティレビューを実行します。
  3. 特に、まだMagento 1 が稼働している場合は、Adobe Commerceのバージョンとアップグレードを確認してください。このバージョンはサポートされなくなりました。
  4. それでも問題が解決しない場合は、 サポートチケットを送信 およびストア URL を指定します。

問題:挿入時に妥協のエラーが発生する

「妥協注入」エラーに関するエラーが表示されます。

解決策

  1. セキュリティスキャンツールレポートに示されているスクリプトを確認します。
  2. インラインスクリプト挿入のホームページソース本文を確認します。
  3. システム構成の変更のレビュー(特にカスタム)を実行します HTML head および Miscellaneous HTML 。対象: footer セクション値。
  4. コードとデータベースのレビューを実行して、挿入されたマルウェアの未知の変化と兆候を確認します。

上記の手順のいずれも役に立たない場合、 サポートチケットを送信 そして、ストア URL とレポートのエラーメッセージを指定します。

よくある質問

セキュリティスキャンは web サイトのパフォーマンスに影響を与えますか?

いいえ。 セキュリティスキャンでは、すべてのリクエストが 1 人のユーザーのように 1 つずつ行われます。 このため、セキュリティスキャンによって Web サイトのパフォーマンスに影響が出ることはありません。

Adobe Commerceは、セキュリティスキャンレポートをどのくらいの期間保持しますか?

以前の 10 件のレポートを最後から生成できます。 古いレポートが必要な場合は、Adobe Commerce サポートにお問い合わせください。 最大 1 年前のセキュリティスキャンレポートを取得できます。

サポートチケットを送信する際には、どのような情報が必要ですか?

ドメイン名を必ず指定してください。

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