Soluzione

  1. Verificare che 52.87.98.44, 34.196.167.176 e 3.218.25.102 IP non siano bloccati su 80 e 443 porte.
  2. Controllare l'URL inviato per i reindirizzamenti (ad esempio, https://mystore.com reindirizzamenti a https://www.mystore.com o viceversa o reindirizzamenti ad altri nomi di dominio).
  3. Esaminare i registri di accesso a WAF e server Web per le richieste rifiutate o non soddisfatte. HTTP 403 Forbidden e HTTP 500 Internal server error sono le risposte comuni del server che causano la generazione di rapporti vuoti. Di seguito è riportato un esempio di codice di conferma che blocca le richieste da parte degli agenti utente:
if(req.http.user-agent ~ "(Chrome|Firefox)/[1-7][0-9]" && client.ip !~ useragent_allowlist)

{   error 403;   }

È inoltre possibile visualizzare Il report dello strumento di analisi della sicurezza è vuoto articolo nella Knowledge Base di supporto per ulteriori informazioni.

Problema: il problema di sicurezza è stato risolto ma è ancora visualizzato come vulnerabile durante l’analisi

È stato risolto un problema di sicurezza e si prevede che l'analisi della sicurezza mostri che l'utente non è più vulnerabile al problema appena risolto. Al contrario, il rapporto generato dall’analisi della sicurezza segnala ancora l’utente come vulnerabile al problema di sicurezza.

Causa

I metadati dell'istanza cloud vengono raccolti solo per active e live progetti cloud e NON sono un processo in tempo reale.

Lo script di raccolta delle statistiche viene eseguito una volta al giorno, quindi lo strumento Security Scan deve raccogliere i nuovi dati in un secondo momento.

La latenza prevista per il ciclo di sincronizzazione è di una settimana e richiede almeno 24 ore.

Gli stati seguenti possono essere visualizzati dai controlli:

  1. Passaggio: lo strumento Security Scan ha analizzato i dati aggiornati e ha approvato le modifiche.
  2. Sconosciuto: lo strumento Security Scan non contiene ancora dati sul dominio. Attendere il prossimo ciclo di sincronizzazione.
  3. Non riuscito: se lo stato non viene visualizzato, è necessario risolvere il problema (abilitare 2FA, cambiare l'URL di amministrazione, ecc.) e attendere il successivo ciclo di sincronizzazione.

Se sono trascorse 24 ore dalle modifiche apportate all'istanza e non vengono riportate nel rapporto Security Scan, puoi inviare un ticket di supporto. Immetti l’URL dello store durante l’invio del ticket.

Errore sospetto BotNet

Ricevi una notifica relativa al guasto "BotNet Suspect".

Causa

  1. Il nome del dominio dello store è entrato in un "Potential BotNet Participants List" nel 2019, e aveva il pannello di amministrazione, il downloader, o la funzionalità RSS pubblicamente esposto, e/o il suo URL è stato menzionato nei forum CC skimming.
  2. L’avviso potrebbe essere causato dai segni di compromissione dello store e/o da malware, come JavaScript trovato nella pagina.
  3. Non si tratta necessariamente di una questione in corso. Se il negozio è stato compromesso in precedenza, il suo nome host può ancora fluttuare intorno al web oscuro come un nome "vittima".
  4. Potrebbe anche essere causato non da Adobe Commerce, ma da un compromesso di sistema (a livello di sistema operativo).

Soluzione

  1. Controlla se sono stati creati nuovi account SSH, modifiche al file system e così via.
  2. Eseguire un'analisi della protezione.
  3. Controlla la versione e l’aggiornamento di Adobe Commerce, soprattutto se è ancora in esecuzione Magento 1, che non è più supportato.
  4. Se il problema persiste, invia un ticket di supporto e fornisci l'URL dell'archivio.

Problema: errore di inserimento compromissione

Riceve un errore relativo a un errore di "Iniezione compromessa".

Soluzione

  1. Esaminare gli script indicati nel report relativo allo strumento Security Scan.
  2. Controlla il corpo sorgente della pagina iniziale per le iniezioni di script in linea.
  3. Eseguire la revisione delle modifiche alla configurazione del sistema, in particolare HTML head e Miscellaneous HTML personalizzati nei valori di sezione footer.
  4. Eseguire la revisione del codice e del database per individuare eventuali modifiche e segni di malware iniettato.

Se nessuno dei problemi sopra descritti è utile, invia un ticket di supporto e fornisci l'URL dell'archivio e il messaggio di errore dal report.