Reindirizzamento accesso quando si tenta di accedere ad Amministratore Commerce
Questo articolo illustra le possibili soluzioni per il problema di accesso dell’amministratore di Commerce, in cui vieni reindirizzato al modulo di accesso quando tenti di accedere all’amministratore e non viene visualizzato alcun messaggio di errore. Ad esempio, puoi correggere le impostazioni del fuso orario del server e cancellare le impostazioni dei cookie in Adobe Commerce.
Edizioni e versioni interessate:
Tutte le versioni e le edizioni di Adobe Commerce.
Problema
Passaggi da riprodurre:
- Vai alla pagina dell’amministratore di Commerce.
- Immetti le credenziali e fai clic su Accedi.
Risultati previsti:
Hai effettuato l’accesso a Commerce Admin.
Risultati effettivi:
Si viene reindirizzati al modulo di accesso senza messaggi di errore.
Causa
Il problema può essere dovuto a due motivi:
- Fuso orario errato impostato a livello di browser (il che porta a considerare la sessione di amministrazione scaduta anche se la sua durata effettiva non è ancora scaduta).
- Impostazioni dei cookie non corrette. In tal caso, Adobe Commerce non utilizza la sessione stabilita.
Vedere i paragrafi successivi per le soluzioni in ogni caso.
Soluzioni
Problema di durata della sessione di amministrazione
Prova a utilizzare un browser diverso e aumenta la durata della sessione di amministrazione se è inferiore a un’ora.
Per aumentare la durata della sessione di amministrazione, effettua le seguenti operazioni:
-
Creare un backup del database.
-
Utilizza uno strumento di database come phpMyAdmin oppure accedi al database manualmente dalla riga di comando per eseguire la seguente query SQL:
code language-sql UPDATE core_config_data SET value = 7200 WHERE path = 'admin/security/session_lifetime';
-
Pulisci la cache di configurazione eseguendo il comando seguente:
code language-bash php <your_magento_install_dir>/bin/magento cache:clean config
Impostazioni dei cookie non corrette
Per verificare e cancellare i valori delle impostazioni dei cookie, effettua le seguenti operazioni:
-
Creare un backup del database.
-
Utilizza uno strumento di database come phpMyAdmin oppure accedi al database manualmente dalla riga di comando per eseguire la seguente query SQL:
code language-sql SELECT * FROM core_config_data WHERE (path = "web/cookie/cookie_domain" OR path = "web/cookie/cookie_path");
-
Se le risposte dei valori non sono vuote, impostarle su NULL eseguendo il comando seguente:
code language-sql UPDATE core_config_data SET value = NULL WHERE (path = "web/cookie/cookie_domain" OR path = "web/cookie/cookie_path");
-
Pulisci la cache di configurazione eseguendo il comando seguente:
code language-bash php <your_magento_install_dir>/bin/magento cache:clean config
Articoli correlati
- Errore "Il tuo account è temporaneamente disabilitato" nella Knowledge Base di supporto per reindirizzare nuovamente al modulo di accesso dell'amministratore.
- Errore "La sessione corrente è scaduta" nella Knowledge Base di supporto per il reindirizzamento al modulo di accesso dell'amministratore.