Adobe Experience Manager Notas de la versión del paquete de servicio más reciente de 6.5 aem-service-pack-release-notes

Información de la versión release-information

Producto
Adobe Experience Manager 6.5
Versión
6.5.19.0
Tipo
Versión del paquete de servicio
Fecha
Jueves, 7 de diciembre de 2023
Descargar URL
Distribución de software

¿Qué incluye? Experience Manager 6.5.19.0 what-is-included-in-aem-6519

Experience Manager 6.5.19.0 incluye nuevas funciones, mejoras clave solicitadas por el cliente, correcciones de errores y mejoras de rendimiento, estabilidad y seguridad que se han publicado desde la publicación inicial de 6.5 en abril de 2019. Instalar este Service Pack el Experience Manager 6.5.

Funciones principales y mejoras

Algunas de las funciones y mejoras clave de esta versión son las siguientes:

  • Se habilitó al usuario del Editor de páginas de sitios/Componente de imagen para hacer referencia a los recursos desde el Cloud Service de recursos remoto. (SITES-13448, SITES-13433)
  • AEM Ahora admite la ordenación del lado del servidor para una navegación más rápida por el proyecto en la vista de lista. Los nodos de proyecto se ordenan según la columna seleccionada por el usuario antes de aparecer en la interfaz.

Forms

  • Nuevos componentes principales de formulario adaptable: Se agregan pestañas verticales, Términos y condiciones y Casilla de verificación para mejorar la escalabilidad de los formularios.

    • Componente Casilla: el Forms adaptable basado en componentes principales ahora puede incluir un componente de casilla de verificación. Permite a los usuarios realizar elecciones binarias, seleccionando o anulando la selección de una opción en particular. Normalmente aparece como un pequeño cuadro en el que se puede hacer clic o pulsar para alternar entre dos estados: activado y desactivado. La casilla de verificación es un elemento de formulario común que se utiliza para presentar una opción sí/no o verdadero/falso.

    • Componente Términos y condiciones: Forms adaptable basado en componentes principales ahora puede incluir un componente Términos y condiciones. Permite a los autores de Forms introducir una sección específica dentro del formulario en la que se presentan a los usuarios los términos, condiciones o acuerdos legales asociados al uso de un servicio, producto o plataforma. Este componente está diseñado para informar a los usuarios sobre las reglas, regulaciones y obligaciones que aceptan enviando el formulario.

      Pestañas verticales, términos y condiciones y componentes de casilla de verificación

    • Componente de pestañas verticales: Forms adaptable basado en componentes principales ahora puede organizar el contenido del formulario en una lista vertical de pestañas, lo que proporciona un diseño estructurado y navegable. El uso de pestañas verticales en un formulario puede mejorar la experiencia general del usuario al simplificar la navegación y mejorar la organización del contenido del formulario, especialmente en situaciones en que un formulario contiene varias secciones o información compleja.

  • Versión de 64 bits de AEM Forms Designer: la versión de 64 bits de AEM Forms Designer ofrece un rendimiento, una escalabilidad y una administración de memoria mejorados para potenciar su experiencia de creación de formularios. Con la arquitectura de 64 bits, puede abordar proyectos aún más grandes y complejos con facilidad, lo que garantiza flujos de trabajo de diseño sin problemas y eficiencia optimizada. Aumente sus capacidades de diseño de formularios y disfrute del futuro de AEM Forms Designer con esta versión de vanguardia.

  • Conectar un Forms adaptable con Microsoft® SharePoint List: AEM Forms proporciona una integración predeterminada para enviar datos de formulario directamente a SharePoint List, lo que le permite utilizar las funciones de Listas de SharePoint. Puede configurar la lista de Microsoft® SharePoint como fuente de datos para un modelo de datos de formulario y utilizar la acción de envío Enviar mediante el modelo de datos de formulario para conectar un formulario adaptable con una lista de SharePoint.

  • Compatibilidad para configurar las propiedades del documento de registro para los fragmentos de formulario adaptable: Ahora puede personalizar fácilmente los fragmentos del formulario adaptable y sus campos en el editor de formularios adaptables.

  • XMLFM de 64 bits: la iteración de 64 bits de XMLFM introduce un rendimiento, una escalabilidad y una administración de memoria mejorados. Es el primer servicio nativo de 64 bits implementado en el lado del servidor. Al aprovechar su capacidad inherente para acceder a mayores recursos de memoria en comparación con su homólogo de 32 bits, XMLFM de 64 bits permite una gestión perfecta de mayores cargas de trabajo de procesamiento. Este hito no solo representa un salto en el rendimiento, sino que también introduce mejoras clave en el marco de servicio nativo dentro del servidor de AEM Forms. Esta actualización equipa a AEM Forms Server para admitir sin problemas cualquier servicio nativo de 64 bits.

Se han corregido problemas en Service Pack 19 fixed-issues

Sites sites-6519

Accesibilidad sites-accessibility-6519

  • En una página de AEM Sites, cuando amplía un 200 % la página, los vínculos Copia de idioma y Informe CSV en el carril Referencias desaparecen. (SITES-11011)

Interfaz de usuario de administrador sites-adminui-6519

  • Canal de AEM Screens Previsualizar La funcionalidad de no funciona ni se muestra en el panel. (SITES-15730)
  • Durante una operación de movimiento de página, si la interfaz de usuario no puede mostrar las referencias pero indica que se vuelven a publicar automáticamente, se muestran no republicado. (SITES-16435)
  • AEM En la versión 6.5 con Service Pack 16 o 17, cuando en la vista de lista de sitios con la columna "Flujo de trabajo" habilitada, no se puede ordenar la lista en función de los elementos de esa columna. No se realiza ninguna ordenación. (SITES-15385)
  • Para una plantilla de página de redireccionamiento, el campo de redireccionamiento se ha hecho obligatorio. Sin embargo, la validación del campo requerido no se está aplicando ni funciona en estos dos casos: cuando se crea una página sin un valor de redirección obligatorio; no se puede crear una página de redirección. La validación no funciona al navegar mediante métodos abreviados de teclado y cuando el campo se marca como no válido, no continúa. (SITES-15903)
  • Algunos Vínculos entrantes no se incluían en el recuento mostrado en la Referencias panel. Por ejemplo, el panel mostraba lo siguiente Enlaces entrantes (6) pero en realidad había nueve enlaces entrantes. (SITES-14816)

IU clásica sites-classicui-6519

  • Después de instalar la revisión en SITES-15827, los títulos de los cuadros de diálogo que tenían espacios en blanco entre palabras se reemplazaban por " ". También se eliminaban los saltos de línea. (SITES-16089)
  • Los títulos de los cuadros de diálogo codificados ahora dan como resultado una doble codificación del título. (SITES-15841)
  • AEM La actualización de los servidores del servicio de 6.5.16 a 6.5.17 dio como resultado una doble codificación de los títulos de los cuadros de diálogo de la IU clásica. (SITES-15634)

Content Fragments sites-contentfragments-6519

  • Aparecerá un mensaje de error de servidor interno en el Editor de fragmentos de contenido. (SITES-13550)
  • La actualización de la org.json La biblioteca de mediante NPR-41291 ha provocado conversiones de error de datos en la DefaultDataTypeConverter de la cfm-impl paquete. La conversión de tipos de datos debe ser más flexible. (SITES-16473)
  • Aparece el mensaje emergente de error "Esta versión del fragmento de contenido no se puede comparar con la versión actual porque hay contenido incompatible". Los fragmentos de contenido deben ser comparables, pero no lo es. (SITES-16317)
  • Se ha cambiado la URL de JS de selector de recursos de
    https://experience.adobe.com/solutions/CQ-assets-selectors/assets/resources/assets-selectors.js
    hasta
    https://experience.adobe.com/solutions/CQ-assets-selectors/static-assets/resources/assets-selectors.js (SITES-16068)
  • Adapte el nuevo esquema de respuesta de la API de metadatos Polaris para la integración CFM-Polaris. (SITES-15166)
  • Todos los fragmentos de contenido deben enumerarse donde se hace referencia al fragmento de contenido seleccionado. En su lugar, las referencias de recursos en el panel de referencia de fragmentos de contenido muestran referencias 0 (cero). (SITES-15036)

Servidor principal sites-core-backend-6519

  • Mejorar StyleImpl. (SITES-15164)
  • Mejore la rama versión/650 de la canalización WCM para poder ejecutar pruebas de integración para sus módulos. (SITES-12938)

Integración de Campaign sites-campaign-integration-6519

  • En el componente de firma (/apps/fpl/components/campaign/signature), el vínculo Externalizer no funcionaba. El dominio no se añadía al origen de la imagen si se eliminaba el comentario del HTML sobre la etiqueta de imagen. Este problema solo se encontró con el componente de firma en el entorno de producción, no en el entorno de ensayo. (SITES-16120)

Componentes de base (heredados) sites-foundation-components-legacy-6519

  • El componente de búsqueda de sitios de Adobe Experience Manager AEM () rompe la interfaz de usuario. (SITES-15087)

Editor de consultas de GraphQL sites-graphql-query-editor-6519

  • La interfaz de usuario del Editor de GraphQL no permite desplazarse por todas las consultas persistentes cuando hay un número elevado de consultas (por ejemplo, más de 25). (SITES-16008)
  • El editor de GraphQL no guarda el estado de publicación de las consultas persistentes. El botón Cancelar la publicación aparece en el Editor de GraphQL, pero no aparece el icono que indica que se ha publicado la consulta persistente. Al actualizar la página, se muestra que la consulta persistente ni siquiera se ha publicado. (SITES-15858)

Lanzamientos sites-launches-6519

  • Los cambios en el repositorio no se guardan debido a Oak0001 entra en conflicto cuando se editan varias páginas o se crea contenido. Es normal realizar un reintento en un evento de este tipo, pero esto no ocurre. (SITES-14840)

MSM: Live Copies sites-msm-live-copies-6519

  • El botón Despliegue de MSM no funciona en la interfaz gráfica de usuario táctil. (SITES-16991)
  • La referencia de vínculo no se actualiza dentro del fragmento de experiencia al crear una Live Copy o al desplegar un fragmento de experiencia. (SITES-15460)

Editor de página sites-pageeditor-6519

  • En Forms > Temáticas, si abrió una temática en el editor de temáticas, realizó algunos cambios y guardó y, a continuación, hizo clic en Previsualizar, se ve un icono de carga, pero la previsualización real no se carga. (SITES-17164)
  • La selección de varios tipos de archivo de documento en el filtro de tipo de recurso no funciona en la consola de página. No se encuentran resultados aunque estén disponibles los resultados de un tipo de archivo en particular. Como resultado, los autores no pueden filtrar varios documentos. Deben utilizar varios tipos de documento y tienen que filtrarlos de uno en uno. (SITES-14047)
  • AEM AEM Después de actualizar una instancia desde la versión 6.5.17 y la versión 6.5.18, desde el Editor de páginas, si ha seleccionado, haga lo siguiente: Publicar página, se le redirigirá a una dirección URL que no existe. Se debe redirigir al usuario al Asistente para publicación. (SITES-15856)
  • AEM Copia redundante desde el portapapeles durante una operación de pegado desde el portapapeles del sistema operativo. (SITES-15704)
  • En Assets, seleccione Documentos, luego en Filtertype, seleccionando Microsoft®® Word o Microsoft®® Excel no muestra ningún resultado aunque existan archivos de ambos tipos. (SITES-14837)

Assets assets-6519

  • Al crear o guardar una carpeta pública, se crean tres grupos en un panel de administración. (ASSETS-26700)
  • No se pueden diferenciar los recursos de publicación en Experience Manager o Brand Portal. (NPR-41320)
  • En el panel de búsqueda, cuando selecciona casillas de verificación y anula la selección de cualquiera de ellas, se desactivan todas las casillas de verificación. (ASSETS-26377)

Dynamic Media assets-dm-6519

  • AEM Una vez cargado un recurso en la interfaz de usuario de, el elemento de configuración de la interfaz de usuario update_asset flujo de trabajo activado. El flujo de trabajo nunca termina. En las instancias de flujo de trabajo, el flujo de trabajo termina en el paso de carga del producto. El siguiente paso es cargar Scene7 por lotes. El usuario puede ver que el recurso se encuentra en Scene7 desde la aplicación de Dynamic Media Classic. (ASSETS-30443)
  • Un servlet personalizado (extremo de API) devuelve un nombre de archivo de Dynamic Media (Scene7) incorrecto. Se produce cuando se elimina un recurso y se reemplaza por un recurso del mismo nombre. El servlet personalizado devuelve el nombre de archivo antiguo de Dynamic Media (Scene7), mientras que una llamada de API "jcr" devuelve el nombre de archivo correcto. (ASSETS-29476)
  • Incluso después de desactivar la sincronización en el nivel de carpeta, los registros muestran el déclencheur de Scene7 ReplicateOnModifyListener. El ReplicateOnModifyListener/Worker debe omitir el procesamiento en recursos de carpeta que no sean de Dynamic Media y fragmentos de contenido. (ASSETS-26705)
  • Las personas con visión reducida se ven afectadas si el Enfoque no es visible en los elementos desplegables (Solo contenido, Ver, Más opciones) en los modos blanco y negro de alto contraste. (ASSETS-25759)
  • Las personas con visión reducida se ven afectadas si la proporción de contraste de luminosidad del texto de una página es inferior a 4,5:1. (ASSETS-25756)
  • Los lectores de pantalla no narran el mensaje emergente mostrado después de enviar los datos. (ASSETS-25755)
  • Los lectores de pantalla no reconocen los puntos de referencia en la página (Dynamic Media; creación de un perfil de codificación de vídeo) cuando se navega mediante la tecla de método abreviado de referencia o región D/R. (ASSETS-25752)
  • Los lectores de pantalla no reconocen varios puntos de referencia en la página (Dynamic Media; creación de vídeo interactivo) cuando se navega mediante la tecla de método abreviado de referencia o región D/R. (ASSETS-25750)
  • Los lectores de pantalla (NVDA/JAWS/Narrator) no reconocen los puntos de referencia de Editar recurso mientras se navega con las teclas de método abreviado D/R. (ASSETS-25744)
  • El usuario recibe un mensaje de trabajo asincrónico vacío/falso, pero el recurso conectado se ha publicado correctamente. (ASSETS-29342)

Forms forms-6519

Adaptive Forms

  • Cuando un usuario agrega una barra de herramientas al formulario adaptable, la etiqueta del contenedor de formularios muestra un comportamiento errático porque no cambia al idioma preferido que el autor seleccionó para Forms. (FORMS-11371)
  • En AEM Forms Workspace, el campo desplegable selecciona la primera opción de forma predeterminada en la interfaz de usuario. (FORMS-11346)
  • AEM La configuración de idioma en la no se ve afectada si utiliza configuraciones regionales con cinco caracteres y el separador decimal no se representa correctamente en la carta. (FORMS-11344)
  • Cuando un usuario genera la salida XML mediante el proceso de Workbench, se produce un error en algunos de los archivos. (FORMS-11314)
  • Cuando un usuario genera una vista previa del documento de registro (DOR) en idiomas distintos del inglés, no funciona. (FORMS-11106)
  • Cuando un usuario convierte algunos archivos de imagen con PDFG en una instancia OSGI basada en Linux® con JDK11, no realiza la conversión. (FORMS-11105)
  • Cuando el usuario instala el complemento de AEM Forms, se rompe el panel de árbol de contenido en AEM Sites. (FORMS-10912)
  • Cuando un usuario copia fechas utilizando el lector de pantalla NVDA del componente Selector de fechas, no se lee correctamente. (FORMS-10805)
  • En el editor de reglas de Forms, el usuario no puede establecer el valor del botón de opción/casilla de verificación cuando el tipo de valor de datos es booleano. (FORMS-10713)
  • Cuando un usuario agrega elementos agregados en un formulario adaptable, se agrega en orden inverso a una lista desplegable. (FORMS-10456)
  • Cuando se borra una lista desplegable con el editor de reglas, el primer valor proporcionado sigue apareciendo aunque el valor se haya borrado. (FORMS-9963)
  • Los usuarios no pueden acceder al título del formulario con lectores de pantalla como NVDA. (FORMS-8815)
  • Los usuarios no pueden acceder a Sub Title en un formulario con lectores de pantalla como NVDA. (FORMS-8814)
  • En el origen de página del formulario HTML, el atributo de clave de acceso está vacío y no funciona. (FORMS-5753)
  • En el cuadro de diálogo Acerca de Workspace, el texto "Adobe Experience Manager - Forms" se presenta como texto. (FORMS-5748)

Forms Designer forms-designer-6519

  • Cuando un usuario intenta leer PDF forms no interactivos a través de lectores de pantalla, algunos elementos de la lista no se leen ni omiten. (LC-3921645)
  • Cuando un usuario desplaza por los campos editables, no se desplaza a todos los campos de formulario del PDF de forma coherente. (LC-3921631)
  • El orden de las etiquetas se cambia aleatoriamente en el PDF, incluso si el etiquetado en Forms Designer es correcto. (LC-3921313)
  • Una lista no se muestra correctamente en las etiquetas de Adobe Acrobat Reader o Adobe Acrobat DC. (LC-3921306)
  • Los niveles de encabezado asignados correctamente en Forms Designer se cambian aleatoriamente a <P> en Adobe Acrobat. (LC-3921305)
  • En una tabla, el ID de cualquier objeto no se puede modificar una vez asignado. (LC-3921134)
  • Si las celdas combinadas están en la tabla, no hay ninguna interfaz gráfica de usuario disponible para establecer el intervalo (fila y columna) y el ámbito en una tabla compleja en AEM Forms Designer. (LC-3919532)
  • Cuando un usuario intenta generar documentos de PDF después de instalar el paquete de complementos de formularios en AEM Forms Service Pack 6.5.15.0, se produce un error intermitente y se muestra el siguiente error:
    • OutputServiceException AEM_OUT_001_003:Unexpected Exception: 0 Out of Memory Caused by: org.omg.CORBA.COMM_FAILURE: null (LC-3921530)

Foundation foundation-6519

  • La creación de una copia de idioma en el nivel raíz del idioma no ajusta las rutas en la página. En el caso de que se creara la copia de idioma, no para la raíz del idioma, sino para las páginas debajo de ella, la ruta cambió correctamente. (NPR-41364)
  • La información del objeto "Presentación de fecha relativa" solo se puede cerrar pulsando Escape (ESC) en el teclado. La información del objeto debe cerrarse cuando el usuario selecciona cualquier parte de la interfaz de usuario. (NPR-41394)
  • Cadena no localizada Something went wrong while adding the private key. al añadir un archivo de clave privada incorrecto en Editar usuario > Keystore. (NPR-41366)
  • Los iconos son necesarios para Microsoft® SharePoint y MicrosoftAEM ® One Drive en el entorno de la versión 6.5 de. (NPR-41354)
  • "El ID de usuario y la contraseña no coinciden" sin localizar. cadena en Seguridad > Usuario > Crear Cuadro de diálogo. (NPR-41245)
  • El código emergente y los controladores de eventos se cargan dos veces, lo que rompe las interfaces de usuario basadas en Coral3 creadas por el usuario. (NPR-41171)
  • La selección no funciona correctamente después de utilizar "Seleccionar todo" en la consola de AEM Sites. (NPR-41304)

Integraciones integrations-6519

  • AEM Los vínculos SMS de una campaña de correo electrónico de no se escriben correctamente; contienen un elemento de anclaje de HTML. (NPR-41211)
  • El texto utilizado en la pantalla de configuración de la cuenta no debe utilizar un nuevo tipo de credencial. (NPR-41210)
  • Desplazamiento del programador de importación de informes de Analytics desde ManagedPollConfig a trabajos de sling. Cuando se adjuntaban dos marcos de análisis diferentes con grupos de informes diferentes en dos sitios diferentes, ManagedPollConfig encuesta solo a uno de ellos. (NPR-41209)
  • Cuando el valor se restablece al valor predeterminado, el botón de periodo de tiempo seleccionado anteriormente permanece habilitado. AEM En el panel de información de contenido de la página de, de forma predeterminada, el lapso de tiempo se establece en la semana y muestra las perspectivas de contenido como datos semanales. Ahora, si el usuario selecciona otras opciones del lapso de tiempo, como hora, día, mes y año, los datos cambian según el valor seleccionado. Sin embargo, si los valores se restablecen, de forma predeterminada, el lapso de tiempo visible es de una semana, pero aun así la opción de lapso de tiempo seleccionada anteriormente está seleccionada. (NPR-41246)

Oak oak-6519

  • AEM Utilidad de Backport para establecer las escrituras de límite de tasa en caso de que se retrase la indexación asíncrona. (NPR-40985)

Plataforma foundation-platform-6519

  • Las consultas de QueryBuilder con corchetes se traducen erróneamente a xpath (NPR-41298)

Proyectos de traducción foundation-translation-6519

  • Al crear la copia de idioma de la página "A", debe crear automáticamente las copias de idioma de las páginas, fragmentos de experiencias, fragmentos de contenido y recursos a los que se hace referencia. Además, la copia de idioma recién creada de la página "A" en la nueva ruta debe tener sus referencias actualizadas a las respectivas copias de idioma recién creadas de las páginas, los fragmentos de experiencias, los fragmentos de contenido y los recursos. (NPR-41076)

Flujo de trabajo foundation-workflow-6519

  • No se puede completar una tarea en la bandeja de entrada. Solo se observa un valor "indefinido" en el menú desplegable al intentar completar la tarea y seleccionar una acción. AEM Esto significa que los usuarios no pueden aplicar el paquete de servicio 6.5.18 de la versión de. (NPR-41402 y NPR-41473)
  • No se pueden completar las tareas en la bandeja de entrada. No hay ningún valor (solo "indefinido") en la lista desplegable al intentar completar la tarea para archivos zip, informes de recursos, movimiento (éxito o error) o caducidad del recurso. (NPR-41305)
  • Cuando un usuario selecciona Herramientas > Flujo de trabajo > instancias, luego selecciona el flujo de trabajo en ejecución y, a continuación, selecciona Ver carga útil, genera una página de error 500. (NPR-41325)

Instalar Experience Manager 6.5.19.0 install

  • Experience Manager 6.5.19.0 requiere Experience Manager 6.5. Véase documentación de actualización para obtener instrucciones detalladas.
  • La descarga del Service Pack está disponible en el Adobe Distribución de software.
  • En una implementación con MongoDB y varias instancias, instale Experience Manager 6.5.19.0 en una de las instancias de autor mediante el Administrador de paquetes.
IMPORTANT
El Adobe no recomienda quitar ni desinstalar el Experience Manager Paquete 6.5.19.0. Como tal, antes de instalar el paquete, debe crear una copia de seguridad del crx-repository en caso de que deba revertirlo.

Instalación del Service Pack en Experience Manager 6,5 install-service-pack

  1. Reinicie la instancia antes de la instalación si la instancia está en modo de actualización (cuando la instancia se haya actualizado desde una versión anterior). Adobe recomienda reiniciar si el tiempo de actividad actual de una instancia es alto.

  2. Antes de realizar la instalación, tome una instantánea o realice una copia de seguridad nueva de su Experience Manager ejemplo.

  3. Descargue el Service Pack desde Distribución de software.

  4. Abra el Administrador de paquetes y seleccione Cargar paquete para cargar el paquete. Para obtener más información, consulte Administrador de paquetes.

  5. Seleccione el paquete y luego seleccione Instalar.

  6. Para actualizar el conector S3, detenga la instancia después de la instalación del Service Pack, sustituya el conector existente por un nuevo archivo binario proporcionado en la carpeta de instalación y reinicie la instancia. Consulte Almacén de datos de Amazon S3.

NOTE
El cuadro de diálogo en la interfaz de usuario del Administrador de paquetes a veces existe durante la instalación del Service Pack. El Adobe recomienda esperar a que los registros de errores se estabilicen antes de acceder a la implementación. Espere los registros específicos relacionados con la desinstalación del paquete actualizador antes de asegurarse de que la instalación se haya realizado correctamente. Normalmente, este problema se produce en el Safari explorador, pero puede producirse de forma intermitente en cualquier explorador.

Instalación automática

Existen dos métodos diferentes que puede utilizar para instalar automáticamente Experience Manager 6.5.19.0.

  • Coloque el paquete en ../crx-quickstart/install cuando el servidor está disponible en línea. El paquete se instala automáticamente.
  • Utilice el API HTTP del Administrador de paquetes. Uso cmd=install&recursive=true para instalar los paquetes anidados.
NOTE
Experience Manager 6.5.19.0 no admite la instalación de Bootstrap.

Validación de la instalación

Para conocer las plataformas certificadas para trabajar con esta versión, consulte la requisitos técnicos.

  1. La página de información del producto (/system/console/productinfo) muestra la cadena de versión actualizada Adobe Experience Manager (6.5.19.0) bajo Productos instalados.

  2. Todos los paquetes OSGi son ACTIVO o FRAGMENTO en la consola OSGi (utilice la consola web): /system/console/bundles).

  3. El paquete OSGi org.apache.jackrabbit.oak-core es la versión 1.22.17 o posterior de (utilice la consola web: /system/console/bundles).

Instalar Service Pack para Experience Manager Forms install-aem-forms-add-on-package

Para obtener instrucciones para instalar el Service Pack en Experience Manager Forms, consulte Instrucciones de instalación del Service Pack de Experience Manager Forms.

NOTE
La funcionalidad Formularios adaptables, disponible en AEM 6.5 Inicio rápido, está diseñada únicamente para la exploración y la evaluación. Para su uso en producción, es esencial obtener una licencia válida para AEM Forms, ya que la funcionalidad Formularios adaptables requiere una licencia adecuada.

Instalación del paquete de índice de GraphQL para fragmentos de contenido de Experience Manager install-aem-graphql-index-add-on-package

Los clientes que utilicen GraphQL deben instalar Fragmento de contenido de Experience Manager con el paquete de índice 1.1.1 de GraphQL.

Al hacerlo, puede añadir la definición de índice necesaria en función de las funciones que utilizan realmente.

Si no se instala este paquete, las consultas de GraphQL pueden ser lentas o dar error.

NOTE
Instale este paquete solo una vez por instancia; no es necesario reinstalarlo con cada Service Pack.

UberJar uber-jar

UberJar para Experience Manager 6.5.19.0 está disponible en la Repositorio de Maven Central.

Para usar UberJar en un proyecto de Maven, consulte cómo usar UberJar e incluya la siguiente dependencia en el POM de su proyecto:

<dependency>
     <groupId>com.adobe.aem</groupId>
     <artifactId>uber-jar</artifactId>
     <version>6.5.19</version>
     <scope>provided</scope>
</dependency>
NOTE
UberJar y los demás artefactos relacionados están disponibles en el Repositorio de Maven Central en lugar del Repositorio de Maven público de Adobe (repo.adobe.com). El nombre del archivo principal de UberJar cambia a uber-jar-<version>.jar. Así que no hay classifier, con apis como el valor, para el dependency etiqueta.

Funciones en desuso y eliminadas removed-deprecated-features

Consulte Funciones en desuso y eliminadas.

Problemas conocidos known-issues

  • Relacionado con Oak
    En Service Pack 13 y versiones posteriores, ha comenzado a aparecer el siguiente registro de errores que afecta a la caché de persistencia:

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.0.202/5]
    at org.h2.mvstore.DataUtils.newMVStoreException(DataUtils.java:1004)
        at org.h2.mvstore.MVStore.getUnsupportedWriteFormatException(MVStore.java:1059)
        at org.h2.mvstore.MVStore.readStoreHeader(MVStore.java:878)
        at org.h2.mvstore.MVStore.<init>(MVStore.java:455)
        at org.h2.mvstore.MVStore$Builder.open(MVStore.java:4052)
        at org.h2.mvstore.db.Store.<init>(Store.java:129)
    

    O bien

    code language-shell
    org.h2.mvstore.MVStoreException: The write format 1 is smaller than the supported format 2 [2.1.214/5].
    

    Para resolver esta excepción, haga lo siguiente:

    1. Elimine las dos carpetas siguientes de crx-quickstart/repository/

      • cache
      • diff-cache
    2. Instale el Service Pack o reinicie el Experience Manager as a Cloud Service.
      Nuevas carpetas de cache y diff-cache se crean automáticamente y ya no experimenta una excepción relacionada con lo siguiente mvstore en el error.log.

  • Actualice las consultas de GraphQL que puedan haber utilizado un nombre de API personalizado para el modelo de contenido para utilizar el nombre predeterminado del modelo de contenido en su lugar.

  • Una consulta de GraphQL puede utilizar el complemento damAssetLucene índice en lugar de fragments índice. Esta acción puede dar como resultado consultas de GraphQL que fallan o que tardan mucho tiempo en ejecutarse.

    Para corregir el problema, damAssetLucene debe configurarse para incluir las dos propiedades siguientes en /indexRules/dam:Asset/properties:

    • contentFragment

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/contentFragment"
      • propertyIndex="{Boolean}true"
      • type="Boolean"
    • model

      • jcr:primaryType="nt:unstructured"
      • name="jcr:content/data/cq:model"
      • ordered="{Boolean}true"
      • propertyIndex="{Boolean}true"
      • type="String"

    Una vez cambiada la definición del índice, es necesario volver a indexar (reindex = true).

    Después de estos pasos, las consultas de GraphQL deberían funcionar más rápido.

  • Al intentar mover, eliminar o publicar fragmentos de contenido, sitios o páginas, hay un problema cuando se recuperan las referencias de fragmentos de contenido, ya que la consulta en segundo plano falla. Es decir, la funcionalidad no funciona.
    Para garantizar un funcionamiento correcto, debe agregar las siguientes propiedades al nodo de definición del índice /oak:index/damAssetLucene (no se requiere reindexación):

    code language-xml
    "tags": [
        "visualSimilaritySearch"
      ]
    "refresh": true
    
  • Al ejecutar una consulta de GraphQL con variables opcionales, si un valor específico es no siempre que sea para la variable opcional, el valor de esa variable se considerará implícito null. Esto significa que el filtro solo coincidirá con null valores de la propiedad correspondiente.

    Por ejemplo, en la consulta siguiente, donde no se especifica ningún valor para la propiedad lastName:

    code language-graphql
    query getAuthorsFilteredByLastName($authorLastName: String) {
    authorList(filter:
      {
        lastName: {_expressions: {value: $authorLastName}
        }}) {
      items {
        lastName
        }
      }
    }
    

    Solo los autores con lastName se devolverá la propiedad establecida en null:

    code language-graphql
    {
    "data": {
      "authorList": {
        "items": [
          {
            "lastName": null
          }
        ]
      }
    }
    }
    
  • Si actualiza su Experience Manager instancia de 6.5.0 a 6.5.4 al Service Pack más reciente de Java™ 11, verá lo siguiente RRD4JReporter excepciones en la error.log archivo. Para detener las excepciones, reinicie la instancia de Experience Manager.

  • Los usuarios pueden cambiar el nombre de una carpeta en una jerarquía en Assets y publicar una carpeta anidada en Brand Portal. Sin embargo, el título de la carpeta no se actualiza en Brand Portal hasta que se vuelva a publicar la carpeta raíz.

  • Durante la instalación de, se pueden mostrar los siguientes errores y mensajes de advertencia Experience Manager 6.5.x.x:

    • "Cuando la integración de Adobe Target está configurada en Experience Manager Si se utiliza la API de Target Standard (autenticación IMS) y se exportan los fragmentos de experiencias a Target, se crean tipos de ofertas incorrectos. En lugar de "Fragmento de experiencia"/fuente "Adobe Experience Manager", Target crea varias ofertas con el tipo "HTML"/fuente "Adobe Target Classic".
    • com.adobe.granite.maintenance.impl.TaskScheduler: No se han encontrado ventanas de mantenimiento en granite/operations/maintenance.
    • La validación del lado del servidor de formularios adaptables falla cuando se utilizan funciones de agregado como SUM, MAX y MIN (CQ-4274424).
    • com.adobe.granite.maintenance.impl.TaskScheduler - No hay ventanas de mantenimiento en granite/operations/maintenance.
    • El punto interactivo de una imagen interactiva de Dynamic Media no está visible al obtener una vista previa del recurso a través del visor de titulares de ventas.
    • com.adobe.cq.social.cq-social-jcr-provider bundle com.adobe.cq.social.cq-social-jcr-provider:1.3.5 (395)[com.adobe.cq.social.provider.jcr.impl.SpiSocialJcrResourceProviderImpl(2302)] : tiempo de espera hasta que se completó el cambio de registro sin registrar.
  • AEM A partir de la versión 6.5.15, el motor JavaScript de Rhino proporcionado por el org.apache.servicemix.bundles.rhino El paquete tiene un nuevo comportamiento de elevación. Scripts que utilizan el modo estricto (use strict;) deben declarar correctamente sus variables; de lo contrario, no se ejecutan, lo que genera un error de tiempo de ejecución.

Problemas conocidos de AEM Forms

Plataformas compatibles

  • No se admite JDK 11.0.20 para instalar AEM Forms en el instalador JEE. Solo se admite JDK 11.0.19 o versiones anteriores para instalar AEM Forms en el instalador JEE. (FORMS-10659)

Instalación

  • En la plataforma JBoss® 7.1.4, cuando el usuario instala el Service Pack de Experience Manager 6.5.16.0 o posterior, adobe-livecycle-jboss.ear la implementación falla. (CQ-4351522, CQDOC-20159)

AEM Instale el fragmento del servlet (paquete de servicio 6.5.14.0 o anterior de)

  • AEM AEM Si actualiza al paquete de servicio 6.5.15.0 o superior de la versión y la instancia de la versión funciona con Tomcat 8.5.88, es obligatorio que instale el fragmento de servlet. antes continúe con la instalación del paquete de servicio 6.5.15.0 o superior.
  • Es obligatorio instalar el fragmento de servlet para todos los servidores de aplicaciones excepto los que se ejecutan en JBoss® EAP 7.4.0.

Para instalar el fragmento de servlet:

  1. Descargue el fragmento de servlet de Distribución de software.
  2. Inicie el servidor de aplicaciones.
  3. Espere a que se estabilicen los registros y compruebe el estado del paquete.
  4. Abra los paquetes de la consola web. La URL predeterminada es http://[Server]:[Port]/system/console/bundles.
  5. Seleccionar Instalar o Actualizar.
  6. Seleccionar el fragmento descargado
    org.apache.felix.http.servlet-api-1.2.0_fragment_full.jar
  7. Seleccionar Instalar o Actualizar.
  8. Espere a que se estabilice el servidor de aplicaciones.
  9. Detenga el servidor de aplicaciones.

Formularios adaptables

  • Cuando se publica un formulario adaptable, todas sus dependencias, incluidas las directivas, se vuelven a publicar, aunque no se hayan realizado modificaciones en ellas. (FORMS-10454)
  • Cuando un usuario selecciona configurar un campo por primera vez en un formulario adaptable, la opción para guardar una configuración no se muestra en el Explorador de propiedades. El problema se resuelve seleccionando la configuración de otro campo del formulario adaptable en el mismo editor.
  • Cuando los usuarios realizan la acción de envío, el envío falla con un error:
    javax.servlet.ServletException: java.lang.NoSuchMethodError
    Para resolver el problema, Volver a compilar los scripts de Sling como JSP, Java™ y Sightly. (FORMS-8542)
  • AEM Después de instalar el paquete de servicio 6.5.14.0 de y posteriores, los usuarios no pueden seleccionar una fuente de la interfaz de usuario de administración de JEE para los documentos de PDF al navegar a Home > Services > PDF Generator > Adobe PDF Settings, ya que la lista de fuentes aparece vacía. (FORMS-12095)
  • Las Forms adaptables permiten utilizar funciones personalizadas con ECMAScript versión 5 o anteriores. Cuando una función personalizada utiliza la versión 6 o posterior de ECMAScript, como las funciones "let", "const" o "arrow", es posible que el editor de reglas no se abra correctamente.

AEM Forms en JEE

  • Se han notificado vulnerabilidades de seguridad críticas para Struts 2 RCE, un marco de aplicación web popular y de código abierto para el desarrollo de aplicaciones web Java EE. Adobe liberado AEM Paquete de servicio 19.1 de.5 (6.5.19.1) para abordar la vulnerabilidad en AEM Forms en JEE.

Comunicaciones interactivas

    • El servicio de relleno previo falla con una excepción de puntero nulo. (CQDOC-21355)

Paquetes de contenido y paquetes OSGi incluidos osgi-bundles-and-content-packages-included

Los siguientes documentos de texto enumeran los paquetes OSGi y los paquetes de contenido incluidos en Experience Manager 6.5.19.0:

Sitios web restringidos restricted-sites

Estos sitios web solo están disponibles para los clientes de. Si es cliente de y necesita acceso, póngase en contacto con el administrador de cuentas de Adobe de.

recommendation-more-help
19ffd973-7af2-44d0-84b5-d547b0dffee2