Redirecione de volta para o formulário de logon do Administrador do Commerce com o erro "Sua sessão atual expirou"
Este artigo fornece as soluções possíveis para o problema de logon de administrador do Commerce, em que você é redirecionado de volta para o formulário de logon com a seguinte mensagem de erro: "Sua sessão atual expirou". As soluções incluem a verificação de problemas de configuração de tempo do servidor e a alteração das configurações de armazenamento de sessão.
Edições e versões afetadas:
Todas as versões e edições do Adobe Commerce
Problema
Etapas a serem reproduzidas:
- Acesse a página de Administrador do Commerce.
- Insira suas credenciais e clique em Fazer logon.
Resultado esperado:
Você faz logon no Commerce Admin.
Resultado real:
Você será redirecionado de volta ao formulário de logon, com a seguinte mensagem de erro exibida: "Sua sessão atual expirou".
Causa
Pode haver dois motivos possíveis para o problema:
- um problema com as configurações de hora do servidor
- um problema com o armazenamento da sessão
Verifique a seção a seguir para obter soluções.
Solução
Verificar problemas de configurações de tempo do servidor
Verifique o registro de sessão criado no admin_user_session
tabela. Se os valores de created_at
e/ou updated_at
estiverem incorretos, isso pode ser causado pelo problema nas configurações de hora do servidor. Peça ao administrador do sistema do servidor para verificar isso. Observe que o horário em DB é definido como UTC por padrão.
Alterar o armazenamento da sessão
Tente alterar o armazenamento da sessão. Use as informações do Como localizar seus arquivos de sessão artigo em nossa documentação do desenvolvedor para descobrir onde sua sessão está armazenada e alterá-la editando o app/etc/env.php
arquivo.
Por exemplo, para iniciar o armazenamento de uma sessão no sistema de arquivos, altere a variável 'session'
seção como segue:
....
'session' =>
array (
'save' => 'files',
),
....
Execute o bin/magento app:config:import
para importar dados de configuração.
Leitura relacionada
- Importar dados de arquivos de configuração na documentação do desenvolvedor
- Configurar Redis na documentação do desenvolvedor
- Redirecione de volta para o formulário de logon de administrador do Commerce com o erro "Sua conta está temporariamente desativada" em nossa base de conhecimento de suporte
- Redirecionar de volta para o formulário de logon sem erro ao tentar fazer logon no administrador do Commerce em nossa base de conhecimento de suporte