Redirecione de volta para o formulário de logon do Commerce Admin com o erro "Sua sessão atual expirou"
Este artigo fornece as soluções possíveis para o problema de logon do Commerce Admin, para o qual você é redirecionado de volta ao formulário de logon com a seguinte mensagem de erro: "Sua sessão atual expirou". As soluções incluem a verificação de problemas de configuração de tempo do servidor e a alteração das configurações de armazenamento de sessão.
Edições e versões afetadas:
Todas as versões e edições do Adobe Commerce
Problema
Etapas a serem reproduzidas:
- Vá para a página Commerce Admin.
- Insira suas credenciais e clique em Entrar.
Resultado esperado:
Você fez logon no Commerce Admin.
Resultado real:
Você será redirecionado de volta ao formulário de logon, com a seguinte mensagem de erro exibida: "Sua sessão atual expirou".
Causa
Pode haver dois motivos possíveis para o problema:
- um problema com as configurações de hora do servidor
- um problema com o armazenamento da sessão
Verifique a seção a seguir para obter soluções.
Solução
Verificar problemas de configurações de tempo do servidor
Verifique o registro de sessão criado na tabela admin_user_session
. Se os valores de created_at
e/ou updated_at
estiverem incorretos, isso poderá ser causado pelo problema com as configurações de hora do servidor. Peça ao administrador do sistema do servidor para verificar isso. Observe que o horário em DB é definido como UTC por padrão.
Alterar o armazenamento da sessão
Tente alterar o armazenamento da sessão. Use as informações do artigo Como localizar seus arquivos de sessão na documentação do desenvolvedor para descobrir onde sua sessão está armazenada e alterá-lo editando o arquivo app/etc/env.php
.
Por exemplo, para iniciar o armazenamento da sessão no sistema de arquivos, altere a seção 'session'
da seguinte maneira:
....
'session' =>
array (
'save' => 'files',
),
....
Execute o comando bin/magento app:config:import
para importar dados de configuração.
Leitura relacionada
- Importe dados de arquivos de configuração em nossa documentação do desenvolvedor
- Configurar Redis na documentação do desenvolvedor
- Redirecione de volta para o formulário de logon Commerce Admin com o erro "Sua conta está temporariamente desabilitada" em nossa base de dados de conhecimento de suporte
- Redirecionar de volta para o formulário de logon sem erro ao tentar fazer logon no Commerce Admin em nossa base de dados de conhecimento de suporte
- Práticas recomendadas para modificar tabelas de banco de dados no Manual de implementação do Commerce