Vertex Address Cleansing: different addresses not allowed
This article talks about the solution for the issue where when the user tries to enter a different billing and shipping address, with Vertex address validation enabled, the storefront will not let the user enter it.
Affected products and versions
- Adobe Commerce on-premises and Adobe Commerce on cloud infrastructure 2.3.5-p1
Issue
Steps to reproduce:
- Go to Admin > Stores > Configuration > Sales > Address Cleansing.
- Select Enabled from the Use Vertex Address Cleansing drop-down and Save Config.
- Go to the frontend as a guest and add a product to the cart.
- Click on the Cart icon and Proceed to Checkout.
- Fill in the address fields.
- Select desired Shipping Method and click Next.
- Click on the Next button again.
- Uncheck My billing and shipping address are the same, and enter a new billing address (different to Address).
- Click the Update button, then click Update address.
Expected results:
The user sees different billing and shipping addresses.
Actual results:
When the user hits update, the billing and shipping addresses revert to being the same.
Cause
Vertex address verification has failed.
Solution
Disable Vertex Address verification or upgrade to 2.4.0.
Related reading
- Adobe Commerce 2.4.0 known issue: Error message selecting local payment method displayed for some countries during checkout
- Adobe Commerce 2.4.0 known issue: 404 error when removing rewards points on multi-shipping checkout
- Adobe Commerce 2.4.0 known issue: orders display error
- Adobe Commerce 2.4.0 B2B Admin can’t add configurable product to quote
- Adobe Commerce 2.4.0 known issue: Braintree payment methods do not show up in Multiple Addresses checkout
- Adobe Commerce 2.4.0 known issue - refresh on Customer’s Activities does not work
- Adobe Commerce 2.4.0 known issue - Export Tax Rates does not work
- Adobe Commerce 2.4.0 known issue: “Add selections to my cart” button does not work
- Adobe Commerce 2.4.0 known issue: raw message data display on storefront
- Adobe Commerce 2.4.0 known issue: missing “Refund” label in Klarna
- Adobe Commerce 2.4.0 known issue: two buttons missing on Create New Order page in Admin
- Adobe Commerce 2.4.0 known issue: when Braintree is enabled, Venmo partial invoice issue
- Adobe Commerce 2.4.0 known issue: Error message selecting local payment method displayed for some countries during checkout
- Adobe Commerce 2.4.0 known issue: Amazon Pay enabled, payment methods missing when Return to standard checkout used
- Adobe Commerce 2.4.0 known issue: 2.4.0 installation fails with outdated stores cache
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a