오래된 저장소 캐시로 Adobe Commerce 2.4.0 설치에 실패함

이 문서에서는 다음 오류 메시지와 함께 Adobe Commerce 2.4.0 설치에 실패하는 문제에 대한 해결 방법을 제공합니다. 기본 웹 사이트가 정의되지 않았습니다. 웹 사이트를 설정하고 다시 시도하십시오. 콘솔에 표시됩니다.

영향을 받는 제품 및 버전

  • 클라우드 인프라의 Adobe Commerce 2.4.0
  • Adobe Commerce 온-프레미스 2.4.0

문제

사전 요구 사항:
CLI 명령의 스토어 모듈에 대한 API에 종속성이 있는 타사 확장은에 필요한 대로 구성됩니다. composer.json. 이로 인해 Adobe Commerce 2.4.0을 설치하지 못하고 다음과 같은 오류 메시지가 표시됩니다. 기본 웹 사이트가 정의되지 않았습니다. 웹 사이트를 설정하고 다시 시도하십시오. 콘솔에 표시됩니다.

원인

CLI 명령의 저장소에 종속된 타사 확장의 경우 문제가 나타납니다. 하나는 Amazon Sales Channel 입니다.

솔루션

Adobe Commerce 2.4.0을 설치하기 전에 판매자는 다음을 수행해야 합니다.

  1. 에서 이러한 타사 확장 제거 composer.json.
  2. 확장 없이 Adobe Commerce을 설치합니다.
  3. 설치 후 확장을 추가합니다.

이 문제는 2.4.1 릴리스 범위에서 수정됩니다.

지원 기술 자료의 관련 자료:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a