Report Builder でのフィルターの操作

新しいデータブロックを作成するとき、またはコマンドパネルから「データブロックの編集」オプションを選択するとき、フィルターを適用できます。

データブロックへのフィルターの適用

データブロック全体にフィルターを適用するには、フィルターをダブルクリックするか、コンポーネントリストからテーブルの「フィルター」セクションにフィルターをドラッグ&ドロップします。

個々の指標へのフィルターの適用

個々の指標にフィルターを適用するには、フィルターをテーブルの指標にドラッグ&ドロップします。 また、テーブルウィンドウで指標の右側にある「」アイコンをクリックし、「フィルター指標」を選択します。適用したフィルターを表示するには、テーブルウィンドウで指標の上にマウスポインターを置くか、指標を選択します。 フィルターが適用された指標にはフィルターアイコンが表示されます。

指標を表示する「フィルター」タブ

クイック編集フィルター

クイック編集パネルを使用して、既存のデータブロックのフィルターの追加、削除、置換を行うことができます。

スプレッドシートでセルの範囲を選択すると、クイック編集パネルの​ フィルター ​リンクには、その選択範囲内のデータブロックで使用されるフィルターの概要リストが表示されます。

クイック編集パネルを使用してフィルターを編集するには

  1. 1 つまたは複数のデータブロックからセルの範囲を選択します。

    データビュー、日付範囲、フィルターのフィルターオプションを表示するクイック編集フィルターパネル。

  2. 「フィルター」リンクをクリックして、「クイック編集 - フィルター」パネルを起動します。

    「フィルターを追加」フィールドと「適用されたフィルター」リストを表示するフィルターパネル。

フィルターの追加または削除

「追加・削除」オプションを使用して、フィルターを追加または削除できます。

  1. クイック編集フィルターパネルの「追加・削除 」タブを選択します。

    選択したデータブロックに適用されたすべてのフィルターが、クイック編集フィルタ-パネルに一覧表示されます。選択範囲内のすべてのデータブロックに適用されたフィルターは、「選択したすべてのデータブロックに適用」見出しの下に一覧表示されます。すべてのデータブロックではなく一部のデータブロックに適用されたフィルターは、「選択した 1 つ以上のデータブロックに適用」見出しの下に一覧表示されます。

    選択したデータブロックに複数のフィルターが存在する場合、 「フィルターの追加」検索フィールドを使用して、特定のフィルターを検索できます。

    「フィルターを追加」フィールド

  2. フィルターの追加」ドロップダウンメニューからフィルターを選択して追加します。

    検索可能なフィルターのリストには、選択した 1 つ以上のデータブロックに存在するデータビューにアクセス可能なすべてのフィルターと、組織内でグローバルに使用可能なすべてのフィルターが含まれます。

    フィルターを追加すると、選択範囲内のすべてのデータブロックにフィルターが適用されます。

  3. フィルターを削除するには、「適用フィルター」リストのフィルターの右側にある削除アイコン x をクリックします。

  4. 適用」をクリックし、変更を保存してハブパネルに戻ります。

    Report Builder に、適用したフィルターの変更を確認するメッセージが表示されます。

フィルターの置換

既存のフィルターを別のフィルターで置き換えて、データのフィルタリング方法を変更できます。

  1. クイック編集フィルターパネルの「置換」タブを選択します。

    「置換」タブを選択します。

  2. 検索リスト」の検索フィールドを使用して、特定のフィルターを検索します。

  3. 置き換えるフィルターを 1 つ以上選択します。

  4. 「置換文字列」フィールドで 1 つ以上のフィルターを検索します。

    フィルターを選択すると、そのフィルターが「置換文字列」リストに追加されます。

    「置換」タブで「アプリの人物」データブロックが選択され、「置換」リストが更新されて「アプリの人物」が改訂されました。

  5. 適用」をクリックします。

    Report Builder は、置換を反映するようにフィルターのリストを更新します。

セルからのデータブロックフィルターの定義

データブロックは、セルからフィルターを参照できます。 複数のデータブロックでフィルターの同じセルを参照できるので、複数のデータブロックのフィルターを一度に簡単に切り替えることができます。

セルからフィルターを適用するには

  1. データブロック作成または編集プロセスの手順 2 に移動します。 データブロックの作成を参照してください。

  2. フィルター」タブをクリックしてフィルターを定義します。

  3. セルからフィルターを作成 をクリックします。

    セルからフィルターを作成アイコン

  4. データブロックでフィルターを参照するセルを選択します。

  5. フィルターをダブルクリックするか、「含まれるフィルター」セクションにドラッグ&ドロップして、セルに追加するフィルターの選択肢を追加します。

    注意:特定のセルに対して選択できる選択肢は、一度に 1 つだけです。

    含まれるフィルターを表示する「セルからフィルターを追加」ウィンドウ

  6. 適用 をクリックして、参照セルを作成します。

  7. フィルター」タブから、新しく作成した参照セルフィルターをデータブロックに追加します。

    テーブルに追加されたシート 1!J1 (すべてのデータ) フィルターを表示する [ フィルター ] タブ

  8. 完了」をクリックします。

    これで、このセルがフィルター内の他のデータブロックによって参照できるようになります。 参照セルをフィルターとして他のデータブロックに適用するには、「フィルター」タブからフィルターにセル参照を追加します。

参照セルを使用したデータブロックフィルターの変更

  1. スプレッドシートで参照セルを選択します。

  2. クイック編集メニューの セルからのフィルター の下のリンクをクリックします。

    Sheet1!J1 を表示するセル リンクからのフィルタ (すべてのデータ)

  3. ドロップダウンリストからフィルターを選択します。

    フィルタードロップダウンメニュー

  4. 適用」をクリックします。

recommendation-more-help
080e5213-7aa2-40d6-9dba-18945e892f79