Il file .csv dei prodotti esportati non viene visualizzato
Questo articolo corregge il problema relativo al tentativo di esportazione di prodotti in un file .csv in Commerce Admin, ma il file non viene visualizzato.
Prodotti e versioni interessati
- Adobe Commerce sull'infrastruttura cloud, tutte le versioni supportate.
Problema
Passaggi da riprodurre
Prerequisiti: l'opzione Aggiungi chiave segreta agli URL è impostata su Sì. L'opzione è configurata in Amministrazione Commerce in Archivi > Configurazione > Avanzate > Amministrazione > Sicurezza.
-
In Amministrazione, passa a Sistema > Trasferimento dati > Esporta.
-
Seleziona
- Tipo di entità: Prodotti
- Formato file esportazione: CSV
- Enclosure campo: lasciare deselezionata.
-
Fai clic su Continua.
-
Viene visualizzato il seguente messaggio: "Il messaggio è stato aggiunto alla coda, attendi di ottenere il file a breve".
Risultato previsto
Il file .csv con i prodotti esportati viene visualizzato nella griglia in pochi minuti.
Risultato effettivo
Il file .csv con i prodotti esportati non viene visualizzato nella griglia in 10 minuti o più.
Causa
Si è verificato un problema noto con la funzionalità di esportazione nella versione 2.3.2 della parte dell’applicazione Adobe Commerce.
Soluzione
Esistono due possibili soluzioni per il problema:
- Disattiva l’opzione Aggiungi chiave segreta all’URL.
- Eseguire il comando
bin/magento queue:consumers:start exportProcessor
manualmente e configurarlo per l'esecuzione da parte di cron.
I dettagli di entrambe le opzioni sono riportati nei paragrafi seguenti.
Disattiva l’opzione Aggiungi chiave segreta all’URL
- In Amministrazione, passa a Archivi > Configurazione > Avanzate > Amministrazione > Sicurezza.
- Imposta l'opzione Aggiungi chiave segreta agli URL su No.
- Fai clic su Salva configurazione.
- Pulisci cache in Sistema > Strumenti > Gestione cache o eseguendo
bash bin/magento cache:clean
o nell'amministratore.
Esegui il comando di esportazione manualmente e, facoltativamente, aggiungilo come processo cron
Per ottenere il file di esportazione, eseguire il comando bin/magento queue:consumers:start exportProcessor
. Dopo aver eseguito questa operazione, il file deve essere visualizzato nella griglia.
Per aggiungere il processo come processo cron, è necessario aggiungere la variabile CRON_CONSUMERS
al file .magento.env.yaml
.
Aggiungi processo come processo cron (facoltativo)
-
Assicurati che il cron sia configurato e configurato. Per ulteriori informazioni, vedere Configurare i processi cron.
-
Esegui il comando seguente per restituire un elenco di consumer della coda di messaggi:
./bin/magento queue:consumers:list
-
Aggiungere quanto segue al file
.magento.env.yaml
nella directory dell'applicazione radice e includere i consumer che si desidera aggiungere. Ad esempio, ecco il consumatore necessario per l’elaborazione dell’esportazione:code language-yaml stage: deploy: CRON_CONSUMERS_RUNNER: cron_run: true max_messages: 1000 consumers: - exportProcessor
Quindi invia questo file aggiornato e ridistribuisci l’ambiente. Vedi anche Aggiungere processi cron personalizzati al progetto nella documentazione per gli sviluppatori.
.magento.env.yaml
per il tuo ambiente e pensi che sia stato eliminato, devi creare un nuovo .magento.env.yaml
. Inizialmente potrebbe essere vuoto, puoi aggiungere le informazioni in base alle esigenze. Consulta i seguenti articoli: Configurare le variabili di ambiente per la distribuzione e Variabili di ambiente nella documentazione per gli sviluppatori..magento.app.yaml
. Se questa funzionalità non è abilitata, crea un ticket di supporto per aggiungere il processo.