Suppression de l’accès des Blackfire pour Adobe Commerce sur l’infrastructure cloud

À compter du 11 avril 2020, le libre accès à la surveillance des performances des Blackfire ne sera plus inclus avec l’architecture du plan Adobe Commerce sur l’infrastructure cloud Pro ou avec les abonnements à l’architecture du plan de démarrage de l’infrastructure cloud.  Vous ne pourrez plus vous connecter à votre compte de Blackfire. Il est possible de continuer à utiliser Blackfire au-delà du 11 avril en achetant une licence directement via Blackfire.io. Les marchands Adobe Commerce qui n’ont pas acheté de licences directement auprès de Blackfire à cette date verront leurs licences Blackfire gratuites, fournies par Adobe, désactivées. De plus, la fonctionnalité de création de rapports à l’aide de l’outil de profileur sera désactivée. Il est toujours possible pour les clients utilisant l’architecture Pro hébergés sur l’infrastructure cloud de recevoir une surveillance gratuite des performances de l’infrastructure via l’infrastructure New Relic.

Si vous souhaitez continuer à utiliser Blackfire:

  1. Vous devez acheter directement une licence avec Blackfire.
  2. Configurez ensuite le Blackfire à l’aide de ces étapes.
  3. Si vous rencontrez des difficultés lors de l’installation, vous pouvez envoyer un ticket d’assistance pour demander de l’aide. Pour toute question spécifique au Blackfire, contactez l’assistance Blackfire directement à l’adresse support@blackfire.io.

Si vous rencontrez des erreurs lors de l’exécution d’un déploiement :

Si, lors de l’exécution d’un déploiement, vous obtenez des erreurs liées à Blackfire, procédez comme suit :

  1. Supprimez le Blackfire de votre configuration. Modifiez la variable .magento.app.yaml et supprimez le Blackfire de la section runtime :

    code language-yaml
    ...
    # Enable extensions required by Magento 2
    runtime:
      extensions:
      - redis
      - xsl
      - json
      -**blackfire**
       - imap
    ...
    
  2. Effectuez cette opération dans l’environnement de développement local et remontez jusqu’au cloud.

Uniquement envoyer un ticket d’assistance si l’erreur suivante s’affiche après l’exécution d’un déploiement :

Avertissement PHP : Démarrage de PHP : impossible de charger la bibliothèque dynamique 'blackfire.so' (tentative : /usr/lib/php/20180731-zts/blackfire.so (https://experienceleague.adobe.com/usr/lib/php/20180731-zts/blackfire.so%20:%20impossible%20d%E2%80%99ouvrir%20le%20fichier%20d%E2%80%99objet%20partag%C3%A9%20:%20pas%20de%20fichier%20ou%20de%20r%C3%A9pertoire%20de%20ce%20type?lang=fr), /usr/lib/php/20180731-zts/blackfire.so.so (https://experienceleague.adobe.com/usr/lib/php/20180731-zts/blackfire.so.so%20:%20impossible%20d%E2%80%99ouvrir%20le%20fichier%20d%E2%80%99objet%20partag%C3%A9%20:%20pas%20de%20fichier%20ou%20de%20r%C3%A9pertoire%20de%20ce%20type?lang=fr) dans Inconnu sur la ligne 0

Cette erreur signifie que le module Blackfire doit être mis à jour et qu’il ne doit pas être chargé.

Si vous souhaitez utiliser l’infrastructure New Relic:

Pour savoir comment accéder à l’infrastructure New Relic, voir Accès à New Relic dans notre base de connaissances de soutien.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a