デジタルアセットのメタデータの管理

バージョン 記事リンク
AEM as a Cloud Service ここをクリックしてください
AEM 6.5 この記事
AEM 6.4 ここをクリックしてください

Adobe Experience Manager Assets では、あらゆるアセットのメタデータを保持します。したがって、アセットの分類と編成が容易にでき、特定のアセットを検索しやすくなります。メタデータ管理は、Experience Manager Assets にアップロードされるファイルからメタデータを抽出する機能と共に、クリエイティブワークフローに統合されます。アセットの任意のメタデータを保持して管理する機能によって、メタデータに基づいてアセットを自動的に編成および処理できます。

メタデータとその起源

メタデータは、検索可能なアセットに関する追加情報です。アセットおよび Experience Manager に追加され、アセットをアップロードする際に処理されます。 既存のメタデータを編集し、既存のフィールドに新しいメタデータプロパティを追加できます。 各組織では、メタデータの語彙を制御し、信頼性を確保する必要があります。 このため Experience Manager Assets では、新しいメタデータプロパティをオンデマンドで追加できません。 メタデータを保持する新しいプロパティまたはフィールドを追加できるのは、管理者と開発者だけです。 ユーザーは、既存のフィールドにメタデータを入力できます。

デジタルアセットにメタデータを追加するには、次の方法を使用できます。

  • まず、アセットを作成するネイティブアプリケーションがメタデータを追加します。 例えば、Acrobat がいくつかのメタデータを PDF ファイルに追加する場合や、カメラが写真にいくつかの基本的なメタデータを追加する場合があります。アセットを生成する際に、ネイティブアプリケーション自体にメタデータを追加できます。 例えば、Adobe Lightroom で IPTC メタデータを追加することができます。

  • アセットを Experience Manager にアップロードする前に、アセットの作成に使用するネイティブアプリケーションまたは他のメタデータ編集アプリケーションを使用して、メタデータの編集および変更ができます。 アセットを Experience Manager にアップロードすると、メタデータは処理されます。 例えば、 Adobe Bridge でのメタデータの操作を参照し、Adobe Exchange での Adobe Bridge のタグパネルを参照してください。

  • Experience Manager Assets では、プロパティページでアセットのメタデータを手動で追加または編集することができます。

  • Experience Manager Assets のメタデータプロファイル機能を利用して、アセットが DAM にアップロードされた際に、メタデータを自動的に追加します。

Experience Manager Assets でのメタデータの追加または編集

Assets ユーザーインターフェイスでアセットのメタデータを編集するには、次の手順に従います。

  1. 次のいずれかの操作を実行します。

    • Assets インターフェイスで、アセットを選択し、 ツールバーで​プロパティを表示​をクリックします。
    • アセットのサムネールから、「プロパティを表示」クイックアクションを選択します。
    • アセットページで、 「プロパティを表示」のアセット情報アイコンをクリックします。

    アセットページに、すべてのアセットのメタデータが表示されます。メタデータは、アセットが Experience Manager にアップロード(取り込み)される際に抽出されます。

    アセットのプロパティを選択して、そのメタデータを表示する

    図:アセットのメタデータの編集または追加をプロパティページで行います。

  2. 必要に応じて、様々なタブの下でメタデータを編集し終わったら、ツールバーの「保存」をクリックして、変更内容を保存します。「閉じる」をクリックして、Assets web インターフェイスに戻ります。

    メモ

    テキストフィールドが空の場合、現在設定されているメタデータはありません。フィールドに値を入力して保存すると、そのメタデータプロパティを追加できます。

アセットのメタデータへの変更内容は、XMP データの一部として元のバイナリに書き戻されます。メタデータの書き戻しワークフローは、元のバイナリにメタデータを追加します。 既存のプロパティ(dc:title など)への変更は上書きされ、新しいプロパティ(cq:tags などのカスタムプロパティを含む)はスキーマとともに追加されます。

XMP の書き戻しは、技術要件に示されたプラットフォームおよびファイル形式でサポートされ、有効になります。

複数アセットのメタデータプロパティの編集

Adobe Enterprise Manager Assets を使用すると、複数のアセットのメタデータを同時に編集できるので、アセットに対する共通のメタデータの変更を一括ですばやく伝えることができます。複数のコレクションのメタデータを一括して編集することもできます。プロパティページを使用して、複数のアセットまたはコレクションのメタデータを変更できます。

  • メタデータプロパティを共通の値に変更する
  • タグを追加または変更する

メタデータのプロパティページをカスタマイズ(メタデータのプロパティの追加、変更、削除など)するには、スキーマエディターを使用します。

メモ

一括編集メソッドは、フォルダーまたはコレクションで使用可能なアセットに対して機能します。フォルダー全体で使用可能なアセットまたは共通の基準に一致するアセットについては、検索後にメタデータを一括更新することが可能です。

  1. Assets ユーザーインターフェイスで、編集するアセットの場所に移動します。
  2. 共通のプロパティを編集するアセットを選択します。
  3. ツールバーで「プロパティ」をクリックして、選択したアセットのプロパティページを開きます。
  4. 様々なタブで選択したアセットのメタデータプロパティを変更します。
  5. 特定のアセットのメタデータを表示するには、リストの残りのアセットの選択をキャンセルします。プロパティページでいくつかのアセットの選択をキャンセルした場合、それらのアセットのメタデータは更新されません。
  6. アセットに別のメタデータスキーマを選択するには、ツールバーの「設定」をクリックし、スキーマを選択します。「保存して閉じる」をクリックします。
  7. 複数の値が含まれるフィールドで、既存のメタデータに新しいメタデータを追加するには、「追加モード」を選択します。このオプションを選択しないと、フィールド内の既存のメタデータが新しいメタデータに置換されます。「送信」をクリックします。

複数のアセットへのメタデータスキーマの一括適用

注意

1 つの値のみを指定できるフィールドの場合、「追加モード」を選択しても、フィールド内の既存の値に新しいメタデータが追加されません。

メタデータの読み込み

Assets では、CSV ファイルを使用して、アセットのメタデータを一括で読み込むことができます。CSV ファイルを読み込むことで、最近アップロードされたアセットや既存のアセットの一括更新を行うことができます。また、サードパーティシステムから CSV 形式でアセットメタデータを一括で取り込むこともできます。

メタデータの読み込みは非同期であり、システムのパフォーマンスに影響はありません。ワークフロー実行フラグがチェックされている場合、XMP 書き戻しアクティビティが発生するので、複数のアセットのメタデータを同時に更新すると、リソースが集中的に使用されるおそれがあります。このような読み込みは、他のユーザーのパフォーマンスに影響しないように、サーバー使用率が低いときに計画します。

メモ

カスタム名前空間にメタデータを読み込むには、まず、その名前空間を登録します。

  1. Assets ユーザーインターフェイスに移動して、ツールバーの「作成」をクリックします。

  2. メニューから「メタデータ」を選択します。

  3. メタデータの読み込み​ページで、「ファイルを選択」をクリックします。メタデータが入った CSV ファイルを選択します。

  4. 次のようなパラメーターを指定します。サンプル CSV ファイルは、 metadata-import-sample-file.csv を参照してください。

    メタデータ読み込みパラメーター 説明
    バッチサイズ メタデータを読み込むバッチ内のアセット数。デフォルト値は 50 です。最大値は 100 です。
    フィールドセパレーター デフォルト値は ,(コンマ)です。他の文字も指定できます。
    複数の値の区切り文字 メタデータ値のセパレーター。デフォルト値は `
    ワークフローを開始 デフォルトでは False です。true に設定すると、(メタデータをバイナリ XMP データに書き込む)DAM メタデータ書き戻しワークフローでデフォルト設定が有効になります。ワークフローを有効にすると、システムの反応が遅くなります。
    アセットパス列名 アセットが含まれている、CSV ファイルの列名を定義します。
  5. ツールバーから「インポート」をクリックします。メタデータが読み込まれると、通知が通知インボックスに表示されます。

  6. 正しい読み込みを確認するには、アセットのプロパティのページに移動し、フィールドの値を確認します。

メタデータの読み込み時に日付とタイムスタンプを追加するには、日付と時刻の YYYY-MM-DDThh:mm:ss.fff-00:00 形式を使用します。日付と時刻は T で区切られます。hh は 24 時間形式の時間、fff はナノ秒、-00:00 はタイムゾーンオフセットです。例えば、2020-03-26T11:26:00.000-07:00 は、2020 年 3 月 26 日の午前 11:26:00.000 PST 時間です。

注意

日付形式が YYYY-MM-DDThh:mm:ss.fff-00:00 と一致しない場合、日付値は設定されません。書き出されたメタデータ CSV ファイルの日付形式は、YYYY-MM-DDThh:mm:ss-00:00 形式になります。インポートする場合は、fff で示すナノ秒値を追加して、有効な形式に変換します。

メタデータの書き出し

複数のアセットのメタデータを CSV 形式で書き出すことができます。メタデータは非同期的に書き出され、システムのパフォーマンスに影響を及ぼしません。メタデータを書き出すには、Experience Manager がアセットノード jcr:content/metadata とその子ノードのプロパティをトラバースし、メタデータプロパティを CSV ファイルに書き出します。

メタデータの一括書き出しの使用例は次のとおりです。

  • アセットの移行時にサードパーティシステムにメタデータを読み込む。
  • より広範なプロジェクトチームとアセットメタデータを共有する。
  • メタデータをテストまたは監査してコンプライアンスを確保する。
  • メタデータを外部化して、個別にローカライズします。
  1. メタデータを書き出すアセットを含んだアセットフォルダーを選択します。ツールバーの「メタデータを書き出し」を選択します。

  2. メタデータの書き出しダイアログで、CSV ファイルの名前を指定します。サブフォルダー内のアセットのメタデータを書き出すには、「サブフォルダーのアセットを含める」を選択します。

    フォルダー内のすべてのアセットのメタデータを書き出すためのインターフェイスとオプション

  3. 目的のオプションを選択します。ファイル名を指定し、必要に応じて日付を指定します。

  4. 書き出すプロパティ」フィールドで、すべてのプロパティを書き出すか、特定のプロパティを書き出すかを指定します。書き出すプロパティを選択する場合は、目的のプロパティを追加します。

  5. ツールバーの「書き出し」をクリックします。メタデータが書き出されることを確認するメッセージが表示されます。メッセージを閉じます。

  6. 書き出しジョブのインボックス通知を開きます。ジョブを選択し、ツールバーの「開く」をクリックします。メタデータが含まれている CSV ファイルをダウンロードするには、ツールバーの「CSV ダウンロード」をクリックします。「閉じる」をクリックします。

    一括で書き出したメタデータを格納した CSV ファイルをダウンロードするためのダイアログ

    図:一括で書き出したメタデータを格納した CSV ファイルをダウンロードするためのダイアログ。

コレクションのメタデータの編集

詳しくは、コレクションのメタデータの表示と編集および複数のコレクションのメタデータを一括編集を参照してください。

フォルダーへのメタデータプロファイルの適用

フォルダーにメタデータプロファイルを割り当てると、サブフォルダーは自動的に親フォルダーのプロファイルを継承します。つまり、フォルダーに適用できるのは 1 つのメタデータプロファイルのみとなります。そのため、アセットをアップロード、保存、使用およびアーカイブする場所のフォルダー構造については入念に検討してください。

フォルダーに異なるメタデータプロファイルを割り当てた場合、新しいプロファイルが以前のプロファイルよりも優先されます。以前に存在していたフォルダーのアセットは変更されずに維持されます。新しいプロファイルは、その後にフォルダーに追加されるアセットに対して適用されます。

プロファイルが割り当てられているフォルダーは、ユーザーインターフェイスでカード名にプロファイルの名前が表示されます。

カード表示には、フォルダーに適用されたメタデータプロファイルが表示されます

特定のフォルダーまたはすべてのアセットにグローバルにメタデータプロファイルを適用できます。

後で変更した既存のメタデータプロファイルが存在するフォルダー内のアセットを再処理できます。処理プロファイルを編集した後のフォルダー内のアセットの再処理を参照してください。

ツール​メニュー内から、またはフォルダー内にいる場合は「プロパティ」から、メタデータプロファイルをフォルダーに適用できます。この節では、メタデータプロファイルをフォルダーに適用する両方の方法について説明します。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

後で変更した既存のビデオプロファイルが存在するフォルダー内のアセットを再処理できます。処理プロファイルを編集した後のフォルダー内のアセットの再処理を参照してください。

プロファイルユーザーインターフェイスからのフォルダーへメタデータプロファイルを適用

次の手順に従って、メタデータプロファイルを適用します。

  1. Experience Manager のロゴをクリックし、ツールアセットメタデータプロファイル​に移動します。
  2. 1 つまたは複数のフォルダーに適用するメタデータプロファイルを選択します。
  3. メタデータプロファイルをフォルダーに適用」をクリックし、新たにアップロードしたアセットを受け取る 1 つまたは複数のフォルダーを選択して、「完了」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

「プロパティ」からのフォルダーへメタデータプロファイルを適用

  1. 左側のレールで、「アセット」をクリックし、メタデータプロファイルを適用するフォルダーに移動します。

  2. チェックマークをクリックして対象のフォルダーを選択し、「プロパティ」をクリックします。

  3. メタデータプロファイル」タブを選択し、ポップアップメニューからプロファイルを選択して、「保存」をクリックします。

既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

フォルダーからメタデータプロファイルを削除

フォルダーからメタデータプロファイルを削除すると、サブフォルダーは自動的に親フォルダーのプロファイルの削除状態を継承します。ただし、フォルダー内で実行されたファイルの処理はそのまま維持されます。

メタデータプロファイルは、ツール​メニュー内のフォルダーまたはフォルダー内の​プロパティ​から削除できます。

プロファイルユーザーインターフェイスを使用したフォルダーからメタデータプロファイルを削除

  1. Experience Manager のロゴをクリックし、ツールアセットメタデータプロファイル​に移動します。

  2. 1 つまたは複数のフォルダーから削除するメタデータプロファイルを選択します。

  3. フォルダーからメタデータプロファイルを削除」をクリックし、プロファイルを削除する 1 つまたは複数のフォルダーを選択して、「完了」をクリックします。

    名前がフォルダー名の下に表示されなくなっていることで、メタデータプロファイルがフォルダーに適用されていないことを確認できます。

「プロパティ」を使用したフォルダーからメタデータプロファイルを削除

  1. Experience Manager のロゴをクリックして「アセット」に移動し、その後メタデータプロファイルを削除するフォルダーに移動します。
  2. チェックマークをクリックして対象のフォルダーを選択し、「プロパティ」をクリックします。
  3. メタデータプロファイル」タブを選択し、ドロップダウンメニューから「なし」を選択して、「保存」をクリックします。既にプロファイルが割り当てられているフォルダーには、フォルダー名のすぐ下にプロファイルの名前が表示されます。

ヒントと制限事項

  • ユーザーインターフェイスを介したメタデータの更新により、dc 名前空間のメタデータプロパティが変更されます。HTTP API を介して行われた更新により、jcr 名前空間のメタデータプロパティが変更されます。詳しくは、HTTP API を使用してメタデータを更新する方法を参照してください。

  • アセットのメタデータをインポートするための CSV ファイルは、非常に特殊な形式です。労力と時間を節約し、意図しないエラーを避けるために、エクスポートされた CSV ファイルの形式を使用して CSV の作成を開始できます。

  • CSV ファイルを使用してメタデータをインポートする場合、必要な日付形式は YYYY-MM-DDThh:mm:ss.fff-00:00 です。その他の形式を使用する場合、日付値は設定されません。 書き出されたメタデータ CSV ファイルの日付形式は、YYYY-MM-DDThh:mm:ss-00:00 形式になります。インポートする場合は、fff で示すナノ秒値を追加して、有効な形式に変換します。

このページ