Campaign v8 compatibility matrix

Last update: 2024-02-12
  • Created for:
  • Beginner
    Admin

This document lists all systems and components supported for the latest build of Adobe Campaign v8 client console. Unless mentioned otherwise, all minor releases are supported. Products and versions that are not part of this list are not compatible with Adobe Campaign.

As specific versions of these 3rd party systems and tools reach end-of-life (EOL), Adobe Campaign will no longer be compatible with those versions, and they will be removed from this compatibility matrix. Please ensure you are on supported versions of any systems listed in the compatibility matrix to avoid any issues.

NOTE

Adobe Campaign server and Campaign client console must be on the same version. Learn how to check your version.

Client console

The following operating systems and browser are required to use Campaign client console. Learn more.

Operating systems

  • Microsoft Windows Server 2019, 2016
  • Microsoft Windows 11, 10
NOTE

Please note that the 32-bit version of the client console is deprecated since 8.5 release. Starting 8.6, the client console is only available in 64-bits. For more information on how to upgrade your system, refer to this technote.

Web browser

CRM connectors

Customer Relationship Management (CRM) systems compatible with Adobe Campaign are listed below. Learn more.

  • Salesforce connector API version 49
  • Microsoft Dynamics connector, Web API: Dynamics 365 on-premise and online

Federated Data Access (FDA)

External databases compatible with Adobe Campaign Federated Data Access (FDA) module are listed below. Learn more.

  • Amazon Redshift
  • Azure Synapse, starting Campaign v8.5
  • Google Big Query
  • Snowflake
  • Vertica

Mobile SDK

To send push notifications with Campaign, use the Adobe Experience Platform Mobile SDK by configuring the Adobe Campaign Classic extension in the Data Collection UI.

Compatible versions for iOS and Android are detailed in the Adobe Developer documentation

Web access

The following browsers are compatible with Campaign for Web Access.

  • Microsoft Edge, Mozilla Firefox, Google Chrome, Safari (latest versions)

Additional resources

To be informed of new Experience Cloud solution releases, subscribe to the Adobe Priority Product Update.

On this page