Compatibility matrix

This document lists all systems and components supported for the latest build of Adobe Campaign Classic v7. Products and versions that are not part of this list are not compatible with Adobe Campaign.

If you are a Gold Standard user, refer to the Gold Standard Compatibility matrix.

Important notes

Unless mentioned otherwise, all minor releases are supported.

In its latest build, Adobe Campaign Classic is compatible with all the systems and tools listed in this page. As specific versions of these 3rd party systems and tools reach end-of-life (EOL) with their respective creators, Adobe Campaign will no longer be compatible with those versions, and they will be removed from our compatibility matrix in the subsequent product release. Please ensure you are on supported versions of any systems listed in the compatibility matrix to avoid any issues.

To learn more about deprecated items, visit this page.

CAUTION

This matrix is regularly updated with new supported items being added and deprecated items being removed.

Operating Systems

CentOs

8.x (64 bits)
Important: CentOS Linux 8 will reach End Of Life (EOL) on December 31st, 2021. For more information, refer to the Deprecated features page.

7.x (64 bits)

Important: If you are using RHEL, you must be willing to disable SELinux or to have your architects write custom SELinux rules to check that an enabled SELinux is not causing issues with Campaign operations.

Debian

11 (64 bits)

10 (64 bits)

9 (64 bits)

RHEL

8.x (64 bits)

7.x (64 bits)

Important: If you are using RHEL, you must be willing to disable SELinux or to have your architects write custom SELinux rules to check that an enabled SELinux is not causing issues with Campaign operations.

Windows Server

2019 (starting 7.2.1 release)

2016

2012 R2

2012

Web Servers

Microsoft IIS

10.0 on Windows Server 2016 and 2019

8.5 on Windows Server 2012 R2

8.0 on Windows Server 2012 - Windows 8

Apache

2.4 for RHEL7 - CentOS 7, Debian 8/9, Windows (64 bits)

Tools

Java Development Kit (JDK)

11

9

8

The application has been approved for the Java Development Kit (JDK) developed by Oracle as well as for OpenJDK.

Libre Office

7 (and previous versions if embedded in your system)

SpamAssassin

3.4.x

Relation Database Management Systems (RDBMS)

Oracle

19c

18c

12c

11g R2

PostgreSQL

13.x

12.x

11.x

10.x

Note: you can also use Amazon RDS for PostgreSQL with the versions specified above.

SQL Server

2019

2017

2016

2014

2012 - SP1 and SP2

Important: Microsoft SQL Server is not supported as the primary database when the Campaign server is running on Linux. Learn more.

NOTE
  • RDBMS driver must match with RDBMS server version.

  • PostgreSQL is the RDBMS for Hosted environments.

CRM connectors

Customer Relationship Management (CRM) systems compatible with Adobe Campaign are listed below. Learn more about Campaign CRM connectors.

Salesforce connector API

API version 49

Microsoft Dynamics connector

Web API

Federated Data Access (FDA)

External databases compatible with Adobe Campaign Federated Data Access module are listed below. Compatibility depends on your hosting model.

Managed Services (hosted), Hybrid and On-premise environments can connect Campaign with the following external database systems:

Database system Database version Campaign version
Amazon Redshift

 

v7.0 19.1.4 minimumm
Google BigQuery   7.2.1 minimum
PostgreSQL

13.x

12.x

11.x

10.x

v7.0 19.1.4 minimum
Snowflake   7.2.1 minimum
Vertica Analytics   v7.0 19.1.4 minimum

In addition, Hybrid and On-premise environments can also connect Campaign with the following external database systems. These systems are not compatible with Campaign Managed Services (hosted) environments.

Database system Database version Campaign version
Microsoft Azure Synapse Analytics   v7.0 19.1.4 minimum
MySQL

8

5.7

v7.3 minimum

v7.0 minimum

Netezza

7.2

v7.0 minimum
Oracle

19c

18c

12c

11g

v7.0 minimum
SAP HANA

version 1 SPS 12

v7.0 minimum
SQL Server

2019

2017

2016

2014

2012 SP1 and SP2

v7.0 minimum
Sybase

IQ 16

ASE 15.7

v7.0 minimum
Teradata

16.20

16

15.10

15.0

v7.0 minimum
Hadoop via HiveSQL

HortonWorks HDP 2.4.X, 2.5.x, 2.6.x

HDInsight 3.4 (HDP 2.4), 3.5 (HDP 2.5), 3.6 (HDP 2.6)

Cloudera CDH6.x

v7.0 minimum

Client Console

The following operating systems and browser are required to use Campaign Client Console.

Operating systems

Microsoft Windows

11 (starting 7.3 release)

10 (recommended for Japanese instances)

8

Microsoft Windows Server

2019 (starting 7.2.1 release)

2016

2012

Microsoft WebView2 runtime

Microsoft Edge WebView2 runtime

Latest version

Download from Microsoft Developer website

Mobile SDK

You can use Campaign to send push notifications on the operating systems listed below, using the associated mobile SDK.

Android

12 (starting Campaign v7.3), 9.0, 8.x, 7.x

with mobile SDK build 1.1.1

iOS

iOS 9 - 15

with mobile SDK build 1.0.26, compatible with 32 and 64-bit versions. iOS 15 is supported starting Campaign v7.3

Browsers

The following browsers are compatible with Campaign for Web Access.

Microsoft Edge

Latest version

Mozilla Firefox

Latest version

Google Chrome

Latest version

Safari

Latest version

More like this

On this page