如何取得並套用安全性修補程式

NOTE
如果您有內部部署安裝,而且未使用CVS或GitHub等版本控制系統來管理您的程式碼,您的Web主機或許可以協助套用修補程式。 歡迎聯絡他們以尋求支援。

本文提供如何取得及套用已發行的安全性修補程式的指示,但無法取得指示。

受影響的產品和版本

Adobe Commerce內部部署和雲端基礎結構 — 所有支援的版本

原因

大部分安全性修補程式已發行,但未套用任何隔離的修補程式或Hotfix,因此需要升級至安全性修補程式發行版本。

解決方案

案例I:

  • 如果發行說明中提及隔離的修補程式檔案/Hotfix,請從https://account.magento.com的下載區段下載檔案。 共用存取許可權的使用者必須先獲得帳戶擁有者/授權持有者的下載許可權。

警告:

如果您使用舊版Adobe Commerce (2.4.4),系統會自動提供延伸支援。 您的版本必須是下列不支援的版本之一,才能套用最新的安全性修補程式:

2.4.4 - 2.4.4-p11

不支援的版本(2.3.x、2.4.0 - 2.4.3)不符合支援資格,您必須先升級至支援的版本,才能利用最新的安全性修正。

如果您沒有「延伸支援」,您可以要求「支援」與您共用修補程式,但無法解決您在套用修補程式時可能遇到的任何問題/錯誤。

案例II:

隔離的修補程式僅於例外情況下提供,並非實作安全性修正的推薦形式。

如果發行說明中未提及隔離的修補程式檔案/Hotfix:

  • 雲端:
  1. 在適用於Commerce的雲端修補程式底下,某些安全性修補程式可能包含在最新版的Cloud Tools Suite (ECE Tools)中/發行 — 請檢視發行說明,如果發行版本中提到安全性修正,請將套件升級至該版本。
  2. 如果發行說明未提及安全性修正,請繼續閱讀。

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