重定向回Commerce Admin登录表单,其中显示“您的当前会话已过期”错误
本文为Commerce Admin登录问题提供了可能的解决方案,在该问题中,您将被重定向回登录表单,并出现以下错误消息: “您的当前会话已过期”。 解决方案包括检查服务器时间设置问题和更改会话存储设置。
受影响的版本和版本:
所有Adobe Commerce版本和版本
问题
重现步骤:
- 转到 Commerce Admin 页面。
- 输入您的凭据,然后单击 登录。
预期的结果:
您已登录Commerce Admin。
实际结果:
您将被重定向回登录表单,并显示以下错误消息: “您的当前会话已过期”。
原因
这个问题可能有两个原因:
- 服务器时间设置问题
- 会话存储问题
请查看以下部分以了解解决方案。
解决方案
检查服务器时间设置问题
检查admin_user_session
表中创建的会话记录。 如果created_at
和/或updated_at
的值不正确,则可能是由于服务器时间设置问题造成的。 请要求您的服务器系统管理员检查这一点。 请注意,默认情况下,DB中的时间设置为UTC。
更改会话存储
尝试更改会话存储。 使用我们的开发人员文档中的如何找到您的会话文件文章中的信息来查找您的会话存储的位置,并通过编辑app/etc/env.php
文件来更改它。
例如,要在文件系统中开始存储会话,请按以下方式更改'session'
部分:
....
'session' =>
array (
'save' => 'files',
),
....
运行bin/magento app:config:import
命令以导入配置数据。
相关阅读
- 从开发人员文档中的配置文件导入数据
- 在开发人员文档中配置 Redis
- 重定向回Commerce Admin登录表单,并在我们的支持知识库中出现“您的帐户被暂时禁用”错误
- 尝试登录到我们的支持知识库中的Commerce Admin时,重定向回登录表单且没有错误
- 在Commerce实施行动手册中修改数据库表的最佳实践
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a