Erro ao limpar o cache no Commerce Admin

Este artigo explica como identificar a causa de uma mensagem de erro que ocorre ao limpar o cache no Commerce Admin. Ao tentar limpar o cache por meio do Administrador, você recebe a seguinte mensagem:
O arquivo /app/project-id/pub/media/catalog/product/cache/diretory/filename" não pode ser excluído. Aviso!unlink(https://experienceleague.adobe.com/app/project%20id/pub/media/catalog/product/cache/diretory/filename?lang=pt-BR): esse arquivo ou diretório não existe

Produtos e versões afetados

Adobe Commerce (todos os métodos de implantação) 2.3.0-2.3.7, 2.4.0-2.4.2-p1

Problema

Ao tentar limpar o cache por meio do Administrador, você recebe uma mensagem de erro.

Etapas a serem reproduzidas:

  1. No Admin, vá para Sistema > Ferramentas > Gerenciamento de Cache.
  2. Selecione qualquer uma das opções de limpeza de cache.

Resultado esperado:

Você liberou o cache do Adobe Commerce com êxito sem erros.

Resultado real:

Você recebe o erro "O arquivo não pode ser excluído".

Causa

O erro está relacionado a um atraso entre o momento em que a operação de limpeza de cache foi iniciada e o momento em que foi relatada como concluída.

Solução

  1. Confirme se os arquivos mencionados no erro não estão presentes no servidor (verificando se a limpeza do cache foi bem-sucedida):
ls -la pub/media/catalog/product/cache/directory/filename

Se você vir a seguinte saída:

ls: cannot access 'pub/media/catalog/product/cache/directory/filename/': No such file or directory

houve uma tentativa de limpar os arquivos quando a operação já tinha sido concluída. Isso não é um erro; é um problema de simultaneidade de mensagens que deve ocorrer às vezes. Não há problemas a serem solucionados.
No entanto, se a saída mostrar que os arquivos ainda estão no cache, você precisará enviar um tíquete de suporte.

Leitura relacionada

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a