Emails não enviados quando os créditos SendGrid são excedidos no Adobe Commerce

Quando os emails não são enviados quando os créditos do SendGrid são excedidos no Adobe Commerce na infraestrutura em nuvem, no ambiente de Produção, envie um caso de suporte, forneça a mensagem de erro e solicite o aumento dos créditos, sujeito às condições de aprovação listadas abaixo. Se você não vir uma mensagem de erro ou estiver na arquitetura de plano de Início da infraestrutura do Adobe Commerce na Nuvem, também envie um caso de suporte e mencione que o arquivo mail.log não indica que os créditos foram excedidos.

Descrição description

Ambientes

Adobe Commerce na infraestrutura na nuvem versões 2.3.0 - 2.3.7-p1, 2.4.0 - 2.4.3

Problema

Os créditos do SendGrid se referem ao número de emails permitidos que podem ser enviados. Somente 12.000 emails podem ser enviados por mês das ramificações de integração e Armazenamento temporário. Os créditos são renovados no início do mês, portanto, se você ficar sem créditos, terá que aguardar a renovação.

Não há limites rígidos para o número de emails que podem ser enviados em produção, desde que a Reputação do remetente esteja acima de 95%.

A reputação é afetada por:

  • o número de emails rejeitados/rejeitados
  • se os clientes sinalizaram seus emails como spam
  • se os registros de spam baseados em DNS sinalizaram seu domínio como uma possível fonte de spam

Na produção, um total de 12.000 emails são alocados por dia, mas esse número pode ser estendido com base no número médio de emails enviados nos cinco dias anteriores.

Causa

Há limites para o número de emails permitidos que podem ser enviados.

Resolução resolution

Como verificar se seus créditos foram excedidos:

Arquitetura do plano Pro da infraestrutura do Adobe Commerce na nuvem: verifique o /var/log/mail.log - você verá uma mensagem semelhante a esta:

May 28 21:13:00 <i-node> postfix/error[ 21335] : BC7941A2BBF: to=<to@email.com>, relay=none, delay=4642, delays=4642/0.56/0/0.03, dsn=4.0.0, status=deferred (delivery temporarily suspended: SASL authentication failed; server smtp.sendgrid.net[ ip address]  said: 451 Authentication failed: Maximum credits exceeded).

Solução

  • Se você vir esta mensagem no ambiente de Produção, envie um caso de suporte, forneça a mensagem acima e solicite o aumento dos créditos.

  • A aprovação para aumento de créditos está sujeita às seguintes condições:

    • A reputação do remetente é 95 ou superior.
    • Quaisquer falhas que fizeram com que os créditos fossem excedidos devem ter sido resolvidas, por exemplo: talvez seja necessário habilitar o ReCaptcha para criar contas ou enviar pedidos, reduzir o número de spam relatado pelos clientes etc.
  • Se você não vir esta mensagem ou se estiver na arquitetura de plano inicial da infraestrutura do Adobe Commerce na Nuvem, também envie um caso de suporte e mencione que o arquivo mail.log não indica que os créditos foram excedidos.

Leitura relacionada

  • SendGrid no Guia do Commerce on Cloud Infrastructure
  • SMTP Erros e Solução de Problemas
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