O status do índice de Elasticsearch é 'amarelo' ou 'vermelho'
O artigo fornece uma correção para quando o Status do Índice Elasticsearch não é 'green'. 'amarelo' indica normal, e 'vermelho' indica ruim. O status "amarelo" ou "vermelho" pode ocorrer em conjunto com produtos ausentes ou com a exibição de informações antigas do produto.
Versões e produtos afetados
- Adobe Commerce na infraestrutura em nuvem 2.2.x, 2.3.x
- Adobe Commerce no local 2.2.x, 2.3.x
Problema
O índice de pesquisa do catálogo de Elasticsearch está lento, resultando em um status de 'amarelo' ou 'vermelho' em vez de 'verde'. Você também pode experimentar alterações ausentes no front-end.
Causa
Pode haver várias causas em potencial. Uma causa é a instância de Elasticsearch ficar sem espaço em disco. Outra causa são os índices duplicados.
Solução
Crie um novo despejo mysql antes de seguir essas etapas e execute-as fora do horário comercial para evitar afetar potencialmente seus clientes:
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Alternar temporariamente para pesquisa MySQL - habilitar pesquisa MySQL. (Observação: lembre-se de voltar para o Elasticsearch ou você pode ter problemas de desempenho).
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Para identificar índices duplicados, execute o seguinte comando:
code language-none curl --silent -X GET localhost:9200/_cat/indices?v
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Para excluir índices:
code language-none curl -XDELETE localhost:9200/[your_index_name_here]
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Reative o Elasticsearch.
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Executar reindexação completa.
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Verifique o status dos índices executando o seguinte comando:
code language-none curl --silent -X GET localhost:9200/_cat/indices?v
Se essas etapas não funcionarem, envie um tíquete de suporte.
Leitura relacionada
Para saber mais, consulte a API de integridade do cluster Elasticsearch.