Commerce Admin でのキャッシュのパージ中のエラー
この記事では、Commerce管理者でキャッシュをパージする際に発生するエラーメッセージの原因を特定する方法について説明します。 管理者を使用してキャッシュをパージしようとすると、次のメッセージが表示されます。
/app/project-id/pub/media/catalog/product/cache/directory/filename」ファイルは削除できません。 警告!unlink (/app/project id/pub/media/catalog/product/cache/directory/filename):そのようなファイルやディレクトリはありません
影響を受ける製品とバージョン
Adobe Commerce(すべてのデプロイメント方法) 2.3.0 ~ 2.3.7、2.4.0 ~ 2.4.2-p1
問題
管理者を使用してキャッシュをパージしようとすると、エラーメッセージが表示されます。
再現手順:
- 管理者で、システム/ツール/キャッシュ管理 に移動します。
- 任意のクリア キャッシュ オプションを選択します。
期待される結果:
Adobe Commerceのキャッシュは正常にフラッシュされました(エラーなし)。
実際の結果:
「ファイルを削除できません」というエラーが発生します。
原因:
エラーは、キャッシュクリーニング操作が開始されてから完了とレポートされるまでの遅延に関連しています。
解決策
- エラーで示されているファイルがサーバーに存在しないことを確認します(キャッシュパージが成功したことを確認します)。
ls -la pub/media/catalog/product/cache/directory/filename
次の出力が表示される場合:
ls: cannot access 'pub/media/catalog/product/cache/directory/filename/': No such file or directory
操作が既に完了しているときに、ファイルをクリアしようとしました。 これはバグではありません。メッセージの同時実行性に関する問題で、時々発生すると予想されています。 トラブルシューティングする問題はない。
ただし、ファイルがまだキャッシュに残っていることが出力で示される場合は、 サポートチケットを送信する必要があります。
関連資料
- 開発者向けドキュメントの キャッシュ管理。
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a