Ripristino di Elasticsearch7 quando il motore di ricerca è impostato su Opensearch
Questo articolo fornisce una soluzione al problema quando si verifica un errore Fallback aElasticsearch7 quando il motore di ricerca è impostato su OpenSearch in Adobe Commerce.
Versioni interessate
Adobe Commerce sull’infrastruttura cloud 2.4.4 - 2.4.5
Problema
Hai impostato il motore di ricerca su OpenSearch, ma vedi questo tipo di errore nel file var/log/support_report.log
:
[2024-04-04T00:27:41.212916+00:00] report.ERROR: opensearch search engine doesn't exist. Falling back to elasticsearch7 [] []
Passaggi da riprodurre:
- Verificare che OpenSearch sia installato eseguendo questo comando:
curl 127.0.0.1:9200
Se indica 1.2.4, OpenSearch è già installato. - Vai a Stores > Configuration > Catalog > Catalog Search.
- Controlla il motore di ricerca. Verrà visualizzato Elasticsearch7.
Causa
Anche se la versione in uso supporta OpenSearch, l'applicazione riconoscerà/accetterà solo Elasticsearch7 come motore di ricerca.
A partire dalla versione 2.4.6 di Adobe Commerce, l'applicazione è stata aggiornata per consentire la selezione di OpenSearch come motore di ricerca.
Se scegli Stores > Configuration > Catalog > Catalog Search in un ambiente non cloud, potrai modificare questa opzione come mostrato nella Soluzione seguente.
(Nota: in un ambiente cloud, questo campo non può essere modificato perché il motore di ricerca è bloccato nel file app/etc/env.php
).
Soluzione
Aggiornare la variabile SEARCH_CONFIGURATION
nel file .magento.env.yaml
e verificare che il motore di ricerca sia impostato su elasticsearch7.
Lettura correlata
Configura il servizio OpenSearch nella guida Commerce su infrastruttura cloud.