DocumentazioneCommerceKnowledge base di Commerce

Solo PaaS

Errori di distribuzione in cui non sono state trovate patch

Ultimo aggiornamento: 2 dicembre 2024

Questo articolo fornisce una soluzione al problema che si verifica quando si aggiorna l'istanza la distribuzione non riesce e viene visualizzato un errore nei registri di distribuzione: Impossibile trovare le patch successive: MDVA-XXXXX, ACSD-XXXXX. Verificare la disponibilità del comando "status" di queste patch per la versione di Magento corrente.

Prodotti e versioni interessati

  • Adobe Commerce su infrastruttura cloud, tutte le versioni supportate.

Problema

Si è verificato un errore durante l'aggiornamento di Adobe Commerce: Impossibile trovare le patch successive.

Causa

Le patch applicate in precedenza per le versioni precedenti non sono applicabili o non sono più disponibili per la nuova versione.

Soluzione

  1. Controlla il file .magento.env.yaml nella sezione QUALITY_PATCH, ad esempio

    QUALITY_PATCHES:
     - MDVA-XXXXX
     - ACSD-XXXXX
    
  2. Cerca gli ID patch nelle Note sulla versione delle patch di qualità per verificare se è possibile applicarli alla nuova versione di Adobe Commerce a cui stai eseguendo l'aggiornamento.

  3. Se la patch non è applicabile alla nuova versione di Adobe Commerce in cui si desidera eseguire l'aggiornamento, rimuovere l'ID patch dal file .magento.env.yaml.

  4. Dopo aver rivisto tutti gli ID patch indicati dall’errore, invia le modifiche e ridistribuiscili.

Lettura correlata

  • Applicare le patch nella Guida all'infrastruttura di Commerce su Cloud.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a