Le fichier .csv des produits exportés n’apparaît pas
Cet article fournit une solution au problème d’affichage du fichier lors de l’exportation du type d’entité souhaité vers un fichier .csv dans Commerce Admin.
Produits et versions concernés
- Adobe Commerce sur l’infrastructure cloud, toutes les versions prises en charge.
Problème
Étapes à reproduire
Conditions préalables : l’option Ajouter une clé secrète aux URL est définie sur Oui. L’option est configurée dans l’administrateur Commerce sous Magasins > Configuration > Avancé > Admin > Sécurité.
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Dans l’administrateur, accédez à Système > Transfert de données > Exporter.
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Sélectionner
- Type d’entité : l’entité que vous souhaitez exporter
- Format du fichier d’exportation : CSV
- Field Enclose : laissez la case décochée.
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Cliquez sur Continuer.
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Le message suivant s'affiche : "Message ajouté à la file d'attente, attendez d'obtenir votre fichier bientôt".
Résultat attendu
Le fichier .csv contenant le type d’entité souhaité exporté s’affiche dans la grille en quelques minutes.
Résultat réel
Le fichier .csv contenant le type d’entité souhaité exporté ne s’affiche pas dans la grille dans 10 minutes ou plus.
Cause
Problème connu avec la fonctionnalité d’exportation dans la partie application Adobe Commerce version 2.3.2.
Solution
Il existe deux solutions possibles :
- Désactivez l’option Ajouter une clé secrète à l’URL .
- Exécutez la commande
bin/magento queue:consumers:start exportProcessor
manuellement et éventuellement configurez-la pour qu’elle soit exécutée par cron.
Voir les détails des deux options dans les paragraphes suivants.
Désactiver l’option Ajouter une clé secrète à l’URL
- Dans l’administrateur, accédez à Magasins > Configuration > Avancé > Admin > Sécurité.
- Définissez l’option Ajouter la clé secrète aux URL sur Non
- Cliquez sur Enregistrer la configuration.
- Nettoyer le cache sous System > Tools > Cache Management ou en exécutant
bash bin/magento cache:clean
ou dans l’administrateur.
Exécutez la commande d’exportation manuellement et ajoutez-la éventuellement en tant que tâche cron
Pour obtenir le fichier d'export, exécutez la commande bin/magento queue:consumers:start exportProcessor
. Après l’exécution de cette opération, le fichier doit s’afficher dans la grille.
Pour ajouter le processus en tant que tâche cron, vous devez éventuellement ajouter la variable CRON_CONSUMERS
au fichier .magento.env.yaml
.
Ajout d’un processus en tant que tâche cron (facultatif)
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Assurez-vous que votre cron est configuré. Pour plus d’informations, voir Configuration des tâches cron .
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Exécutez la commande suivante pour renvoyer une liste des consommateurs de la file de messages :
./bin/magento queue:consumers:list
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Ajoutez le code suivant à votre fichier
.magento.env.yaml
dans le répertoire racine de l’application et incluez les consommateurs que vous souhaitez ajouter. Par exemple, voici le consommateur requis pour le traitement de l’exportation :code language-yaml stage: deploy: CRON_CONSUMERS_RUNNER: cron_run: true max_messages: 1000 consumers: - exportProcessor
Poussez ensuite ce fichier mis à jour et redéployez votre environnement. Référencez également Ajouter des tâches cron personnalisées à votre projet dans notre documentation destinée aux développeurs.
.magento.env.yaml
pour votre environnement et que vous pensez qu’il a été supprimé, vous devez créer un .magento.env.yaml
. Il peut être initialement vide. Vous pouvez y ajouter des informations selon vos besoins. Référencez les articles suivants : Configuration de variables d’environnement pour le déploiement et Variables d’environnement dans notre documentation destinée aux développeurs..magento.app.yaml
. Si cette fonction n'est pas activée, créez un ticket d'assistance pour que la tâche soit ajoutée pour vous.