Le fichier .csv des produits exportés n’apparaît pas

Cet article fournit un correctif pour le problème qui se produit lorsque vous essayez d’exporter des produits vers un fichier .csv dans l’administrateur Commerce, mais que le fichier n’apparaît pas.

Produits et versions concernés

Problème

Étapes à reproduire

Conditions préalables : l’option Ajouter une clé secrète aux URL est définie sur Oui. L’option est configurée dans l’administrateur Commerce sous Magasins > Configuration > Avancé > Admin > Sécurité.

  1. Dans l’administrateur, accédez à Système > Transfert de données > Exporter.

    magento_export_products_2.3.4.png

  2. Sélectionner

    • Type d’entité : Produits
    • Format du fichier d’exportation : CSV
    • Field Enclose : laissez la case décochée.
  3. Cliquez sur Continuer.

  4. Le message suivant s'affiche : "Message ajouté à la file d'attente, attendez d'obtenir votre fichier bientôt".

Résultat attendu

Le fichier .csv contenant les produits exportés s’affiche dans la grille en quelques minutes.

Résultat réel

Le fichier .csv contenant les produits exportés ne s’affiche pas dans la grille dans 10 minutes ou plus.

Cause

Problème connu avec la fonctionnalité d’exportation dans la partie application Adobe Commerce version 2.3.2.

Solution

Il existe deux solutions possibles :

  • Désactivez l’option Ajouter une clé secrète à l’URL .
  • Exécutez la commande bin/magento queue:consumers:start exportProcessor manuellement et éventuellement configurez-la pour qu’elle soit exécutée par cron.

Voir les détails des deux options dans les paragraphes suivants.

Désactiver l’option Ajouter une clé secrète à l’URL

  1. Dans l’administrateur, accédez à Magasins > Configuration > Avancé > Admin > Sécurité.
  2. Définissez l’option Ajouter la clé secrète aux URL sur Non
  3. Cliquez sur Enregistrer la configuration.
  4. Nettoyer le cache sous System > Tools > Cache Management ou en exécutant bash bin/magento cache:clean ou dans l’administrateur.

Exécutez la commande d’exportation manuellement et ajoutez-la éventuellement en tant que tâche cron

Pour obtenir le fichier d'export, exécutez la commande bin/magento queue:consumers:start exportProcessor. Après l’exécution de cette opération, le fichier doit s’afficher dans la grille.

Pour ajouter le processus en tant que tâche cron, vous devez éventuellement ajouter la variable CRON_CONSUMERS au fichier .magento.env.yaml.

Ajout d’un processus en tant que tâche cron (facultatif)

  1. Assurez-vous que votre cron est configuré. Pour plus d’informations, voir Configuration des tâches cron .

  2. Exécutez la commande suivante pour renvoyer une liste des consommateurs de la file de messages : ./bin/magento queue:consumers:list

  3. Ajoutez le code suivant à votre fichier .magento.env.yaml dans le répertoire racine de l’application et incluez les consommateurs que vous souhaitez ajouter. Par exemple, voici le consommateur requis pour le traitement de l’exportation :

    code language-yaml
    stage:
        deploy:
            CRON_CONSUMERS_RUNNER:
                cron_run: true
                max_messages: 1000
                consumers:
                    - exportProcessor
    

    Poussez ensuite ce fichier mis à jour et redéployez votre environnement. Référencez également Ajouter des tâches cron personnalisées à votre projet dans notre documentation destinée aux développeurs.

NOTE
Si vous ne trouvez pas le fichier .magento.env.yaml pour votre environnement et que vous pensez qu’il a été supprimé, vous devez créer un .magento.env.yaml. Il peut être initialement vide. Vous pouvez y ajouter des informations selon vos besoins. Référencez les articles suivants : Configuration de variables d’environnement pour le déploiement et Variables d’environnement dans notre documentation destinée aux développeurs.
TIP
Les fichiers YAML sont sensibles à la casse et n’autorisent pas les onglets. Veillez à utiliser une mise en retrait cohérente dans l’ensemble du fichier .magento.env.yaml , sinon votre configuration risque de ne pas fonctionner comme prévu. Les exemples de la documentation et du fichier d’exemple utilisent une mise en retrait à deux espaces. Utilisez la commande de validation de l’outil ece pour vérifier votre configuration.
NOTE
Sur Adobe Commerce sur les projets d’infrastructure cloud Pro, la fonction auto-crons doit être activée sur votre infrastructure cloud Adobe Commerce avant de pouvoir ajouter des tâches cron personnalisées aux environnements d’évaluation et de production à l’aide de .magento.app.yaml. Si cette fonction n'est pas activée, créez un ticket d'assistance pour que la tâche soit ajoutée pour vous.
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a