Le fichier .csv des produits exportés n’apparaît pas
Cet article fournit une solution au problème où l’exportation du type d’entité souhaité dans un fichier .csv dans Commerce Admin entraîne l’absence du fichier.
Produits et versions concernés
- Adobe Commerce sur les infrastructures cloud, toutes les versions prises en charge.
Problème
Procédure à suivre
Conditions préalables : l’option Ajouter une clé secrète aux URL est définie sur Oui. L’option est configurée dans l’Administration Commerce sous Magasins > Configuration > Avancé > Admin > Sécurité.
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Dans Admin, accédez à Système > Transfert de données > Exporter.
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Sélectionner
- Type d’entité : l’entité à exporter
- Format du fichier d’exportation : CSV
- Enceinte de champ : ne pas cocher.
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Cliquez sur Continuer.
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Le message suivant s’affiche : « Message ajouté à la file d’attente, attendez d’obtenir votre fichier ».
Résultat attendu
Le fichier .csv contenant le type d’entité souhaité exporté s’affiche dans la grille en quelques minutes.
Résultat réel
Le fichier .csv contenant le type d’entité souhaité exporté n’est pas affiché dans la grille pendant 10 minutes ou plus.
Cause
Un problème connu avec la fonctionnalité d’exportation dans la version 2.3.2 de la partie application Adobe Commerce.
Solution
Il existe deux solutions possibles à ce problème :
- Désactivez l’option Ajouter la clé secrète à l’URL .
- Exécutez la commande
bin/magento queue:consumers:start exportProcessormanuellement et, éventuellement, configurez-la pour qu’elle soit exécutée par cron.
Voir les détails des deux options dans les paragraphes suivants.
Désactivez l’option Ajouter la clé secrète à l’URL .
- Dans Admin, accédez à Magasins > Configuration > Avancé > Admin > Sécurité.
- Définissez l’option Ajouter la clé secrète aux URL sur Non.
- Cliquez sur Enregistrer la configuration.
- Nettoyez le cache sous Système > Outils > Gestion du cache ou en exécutant
bash bin/magento cache:cleanou dans Admin.
Exécutez manuellement la commande d’exportation et ajoutez-la éventuellement en tant que tâche cron
Pour obtenir le fichier d’exportation, exécutez la commande bin/magento queue:consumers:start exportProcessor . Après avoir exécuté cette opération, le fichier doit s’afficher dans la grille.
Pour ajouter éventuellement le processus en tant que tâche cron, vous devez ajouter la variable CRON_CONSUMERS au fichier .magento.env.yaml.
Ajouter un processus en tant que tâche cron (facultatif)
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Assurez-vous que le cron est configuré. Pour plus d’informations, consultez Configuration de tâches cron.
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Exécutez la commande suivante pour renvoyer une liste de consommateurs de file d’attente de messages :
./bin/magento queue:consumers:list -
Ajoutez les éléments suivants à votre fichier
.magento.env.yamldans le répertoire racine de l’application et incluez les consommateurs que vous souhaitez ajouter. Par exemple, voici le client requis pour le traitement des exportations :code language-yaml stage: deploy: CRON_CONSUMERS_RUNNER: cron_run: true max_messages: 1000 consumers: - exportProcessorEnvoyez ensuite ce fichier mis à jour et redéployez votre environnement. Consultez également la section Ajouter des tâches cron personnalisées à votre projet dans notre documentation destinée aux développeurs.
.magento.env.yaml pour votre environnement et que vous pensez qu’il a été supprimé, vous devez créer un nouveau .magento.env.yaml. Il peut être vide au départ, vous pouvez y ajouter des informations selon vos besoins. Référencez les articles suivants : Configurer des variables d’environnement pour le déploiement et Variables d’environnement dans notre documentation destinée aux développeurs..magento.app.yaml. Si cette fonctionnalité n’est pas activée, créez un ticket d’assistance pour que la tâche soit ajoutée pour vous.