Échec du déploiement avec « Erreur de création du projet : le hook de création a échoué avec le code d’état 1 »
Cet article aborde les causes et les solutions du problème d’infrastructure cloud d’Adobe Commerce, où la phase de création du processus de déploiement échoue et le message d’erreur est résumé avec : « Erreur de création du projet : le hook de création a échoué avec le code d’état 1 ».
Produits et versions concernés
- Adobe Commerce sur les infrastructures cloud, toutes versions confondues
Problème
Procédure à suivre :
Déclenchez le déploiement manuellement ou en exécutant une fusion, une notification push ou une synchronisation de votre environnement.
Résultat attendu :
Le déploiement est terminé.
Résultat réel :
- La phase de création échoue et l’ensemble du processus de déploiement est bloqué.
- Dans le journal des erreurs de déploiement, le message d’erreur se termine par : « Erreur lors de la création du projet : Le hook de build a échoué avec le code d’état 1. Abandon du build ».
Cause
Plusieurs raisons expliquent l’échec de la création d’environnements. En règle générale, dans le journal de déploiement, un long message d’erreur s’affiche, où la première partie est plus spécifique en ce qui concerne la raison, et la conclusion est « Erreur lors de la création du projet : le hook de build a échoué avec le code d’état 1. Abandon du build ».
Examiner de plus près la première partie spécifique au problème vous aidera à identifier le problème. Voici les plus courantes et la section suivante fournit des solutions pour elles :
- Il n’y a pas d’espace de stockage disponible.
- Configuration CEE-Outils incorrecte.
- Le correctif que vous essayez d’appliquer est incompatible avec votre version d’Adobe Commerce ou est en conflit avec d’autres correctifs appliqués ou avec vos personnalisations.
- Des problèmes liés au code des modules personnalisés empêchent la création réussie.
Solution
- Vérifiez que l’espace de stockage est suffisant. Pour plus d’informations sur la vérification de l’espace disponible, consultez l’article Vérification de l’espace disque dans un environnement cloud à l’aide de l’interface de ligne de commande. Vous pouvez envisager de nettoyer les répertoires de journaux et/ou d’augmenter l’espace disque.
- S'assurer que les outils ECE sont correctement configurés.
- Vérifiez si c’est le correctif qui cause le problème. Résolvez le conflit ou contactez l’assistance Adobe Commerce. Voir ci-dessous pour plus de détails.
- Vérifiez si c’est l’extension personnalisée qui cause le problème. Résolvez le conflit ou contactez les développeurs d’extensions pour obtenir la solution.
Les paragraphes suivants apportent des détails supplémentaires.
Nettoyage des journaux et/ou augmentation de l’espace
Répertoires à prendre en compte pour le nettoyage :
var/log
var/report
var/debug/
var
Pour plus d’informations sur la manière d’augmenter l’espace disque si vous vous trouvez dans l’architecture du plan de démarrage d’Adobe Commerce sur l’infrastructure cloud, consultez le Augmentation de l’espace disque pour l’environnement d’intégration sur le cloud. Les mêmes instructions peuvent être utilisées pour augmenter l’espace d’Adobe Commerce sur l’infrastructure cloud dans l’environnement d’intégration d’architecture Pro. Pour la production/l'évaluation Pro, vous devez déposer un ticket auprès de l'assistance Adobe Commerce et demander un espace disque plus important. Mais il est surveillé par Platform. Mais en règle générale, vous n’aurez pas à gérer cela dans l’architecture d’évaluation/de production de Pro, car Adobe Commerce surveille ces paramètres pour vous et vous avertit et/ou prend des mesures conformément au contrat.
S'assurer que les outils CEE sont correctement configurés
-
Assurez-vous que les hooks de build sont correctement définis dans le fichier
magento.app.yaml
. Si vous utilisez Adobe Commerce 2.2.X, les hooks de création doivent être définis comme suit :code language-yaml # We run build hooks before your application has been packaged. build: | php ./vendor/bin/ece-tools build # We run deploy hook after your application has been deployed and started. deploy: | php ./vendor/bin/ece-tools deploy
Utilisez l’article Mise à niveau vers ece-tools pour référence.
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Assurez-vous que le package ECE-tools est présent dans le fichier
composer.lock
en exécutant la commande suivante :code language-bash grep '"name": "magento/ece-tools"' composer.lock
S’ils sont spécifiés, la réponse ressemble à l’exemple suivant :
code language-bash "name": "magento/ece-tools", "version": "2002.0.20",
Consultez l’article Mise à niveau vers ece-tools pour plus de référence.
Le correctif est-il à l’origine du problème ?
Si c’est le correctif appliqué qui empêche la création réussie de l’environnement, un élément similaire à ce qui suit s’affiche dans le journal de déploiement :
%patch_name%.composer.patch
[2019-02-19 18:12:59] CRITICAL:
....
[2019-02-19 18:12:59] CRITICAL: Command git apply --check --reverse /app/m2-hotfixes/%patch_name%.composer.patch returned code 1
...
W:
W: Command git apply --check --reverse /app/m2-hotfixes/%patch_name%.composer.patch returned code 1
W:
W:
W: build
...
E: Error building project: The build hook failed with status code 1. Aborted build.
Ces messages d’erreur signifient que le correctif que vous essayez d’appliquer a été créé pour une autre version d’Adobe Commerce ou est en conflit avec vos personnalisations ou les correctifs précédemment appliqués. Essayez de résoudre le conflit ou contactez l’assistance Adobe Commerce.
L’extension est-elle à l’origine du problème ?
Si c’est l’extension personnalisée qui empêche la création réussie de l’environnement, le ou les noms des modules personnalisés mentionnés dans le journal de déploiement, ainsi que le conflit particulier causé par ce module, s’affichent. Résolvez le conflit ou contactez les développeurs d’extensions pour obtenir la solution.
Vérifiez que les modifications sont appliquées.
Validez et envoyez vos modifications. Cela déclenchera automatiquement le déploiement.