El servicio Redis se bloqueó
El artículo recomienda cómo corregir Redis.
Productos y versiones afectados
- Adobe Commerce en infraestructura en la nube 2.2.x., 2.3.x
- Adobe Commerce local 2.2.x., 2.3x
- Todas las versiones de Redis
Problema
Lentitud o interrupción del sitio web debido a desbordamiento de memoria en Redis.
Causa
El desbordamiento de memoria puede provocar que el servicio Redis se bloquee. Durante la hora pico, el servicio Redis puede requerir más memoria que la asignada actualmente.
Solución
Para comprobar la configuración actual y la memoria utilizada, ejecute el siguiente comando en la CLI. Comprueba la memoria utilizada, la memoria máxima, las claves desalojadas y el tiempo de activación de Redis en días:
redis-cli -p REDIS_PORT -h REDIS_HOST info | egrep --color "(role|used_memory_peak|maxmemory|evicted_keys|uptime_in_days)"
Las variables REDIS_PORT y REDIS_HOST se pueden recuperar de app/etc/env.php
.
Si el resultado de ejecutar la consulta anterior muestra que el porcentaje de memoria libre es inferior al 40%, envíe un ticket al servicio de soporte técnico de Adobe Commerce solicitando un aumento de la configuración de maxmemory
en el servidor Redis. Si el valor de las claves desalojadas no es "0" o el tiempo de activación de Redis en días es igual a 0 (lo que indica que Redis se ha bloqueado hoy), también debe enviar un ticket al servicio de asistencia de Adobe Commerce solicitando una investigación y una corrección para este problema.
Lectura relacionada
Para obtener más información sobre la memoria Redis, consulte Optimización de memoria Redis.