Error al purgar la caché en el administrador de Commerce
En este artículo se explica cómo identificar la causa de un mensaje de error que se produce al purgar la caché en el administrador de Commerce. Cuando intente purgar la caché a través del administrador, recibirá el siguiente mensaje:
El archivo /app/project-id/pub/media/catalog/product/cache/directory/filename" no se puede eliminar. Advertencia:!unlink(https://experienceleague.adobe.com/app/project%20id/pub/media/catalog/product/cache/directory/filename?lang=es): no existe ese archivo o directorio
Productos y versiones afectados
Adobe Commerce (todos los métodos de implementación) 2.3.0-2.3.7, 2.4.0-2.4.2-p1
Problema
Cuando intente purgar la caché a través del administrador, recibirá un mensaje de error.
Pasos a seguir:
- En el Administrador, vaya a Sistema > Herramientas > Administración de caché.
- Seleccione cualquiera de las opciones para borrar el almacenamiento en caché.
Resultado esperado:
Se ha vaciado correctamente la caché de Adobe Commerce sin errores.
Resultado real:
Recibe el error "el archivo no se puede eliminar".
Causa
El error está relacionado con un retraso entre el momento en que se inició la operación de limpieza de la caché y el momento en que se informó como completada.
Solución
- Confirme que los archivos mencionados en el error no están presentes en el servidor (comprobando que la depuración de la caché se haya realizado correctamente):
ls -la pub/media/catalog/product/cache/directory/filename
Si ve el siguiente resultado:
ls: cannot access 'pub/media/catalog/product/cache/directory/filename/': No such file or directory
se intentó borrar los archivos cuando ya se había completado la operación. Esto no es un error; es un problema de concurrencia de mensajería que se espera que ocurra a veces. No hay problema para solucionar.
Sin embargo, si el resultado muestra que los archivos aún están en la caché, debe enviar un vale de soporte.
Lectura relacionada
- Administración de caché en nuestra documentación para desarrolladores.