Habilitar caché para evitar la degradación del rendimiento

Este artículo explica cómo resolver un problema de sitio lento causado por la deshabilitación de ciertos tipos de caché de Adobe Commerce.

Productos y versiones afectados

  • Adobe Commerce en cloud Infrastructure 2.2.x, 2.3.x
  • Adobe Commerce local 2.2.x, 2.3.x

Problema

Observará una degradación del rendimiento. Por ejemplo, la página Cierre de compra se carga lentamente o el valor Apdex disminuye en New Relic.

Causa

Una razón para la degradación del rendimiento puede ser que se deshabiliten ciertos tipos de caché de Adobe Commerce.

Solución

  1. En primer lugar, compruebe el estado de la caché de Adobe Commerce para ver si este es el problema. Para ello, SSH a su entorno y ejecute el siguiente comando:

    code language-bash
    php bin/magento cache:status
    

    Esto mostraría el estado de cada tipo de caché ("0" para deshabilitado, "1" para habilitado). O puede obtener esta información en el archivo app/etc/env.php.

  2. Investigue los tipos de caché deshabilitados. Todos los tipos de caché de Adobe Commerce deben habilitarse, a menos que haya recibido instrucciones alternativas de Adobe. Las extensiones de terceros no deben requerir la desactivación de la caché de Adobe Commerce.

  3. Si la investigación confirma que algunos tipos de caché están deshabilitados por error, actívelos ejecutando el siguiente comando para cada tipo de caché: php bin/magento cache:enable <your_disabled_cache_type>

Si tiene dudas o preguntas sobre si cierto tipo de caché de Adobe Commerce se puede o se debe deshabilitar, póngase en contacto con el servicio de atención al cliente de Adobe Commerce para obtener recomendaciones.

Lectura relacionada

Documentación de la caché de Adobe Commerce en nuestra documentación para desarrolladores:

Otros posibles motivos de los problemas de rendimiento y sus soluciones:

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a