El estado del índice del Elasticsearch es 'amarillo' o 'rojo'
El artículo proporciona una corrección para los casos en los que el estado del índice de Elasticsearch no es 'green'. 'amarillo' indica normal y 'rojo' indica malo. El estado "amarillo" o "rojo" puede ocurrir junto con los productos que faltan o la visualización de información antigua del producto.
Versiones y productos afectados
- Adobe Commerce en cloud Infrastructure 2.2.x, 2.3.x
- Adobe Commerce on-premise 2.2.x, 2.3.x
Problema
El índice de búsqueda del catálogo de Elasticsearch es lento, lo que da como resultado un estado de 'amarillo' o 'rojo' en lugar de 'verde'. También es posible que experimente cambios que faltan en el front-end.
Causa
Puede haber varias causas potenciales. Una causa es que la instancia del Elasticsearch se quede sin espacio en disco. Otra causa son los índices duplicados.
Solución
Cree un nuevo volcado de mysql antes de seguir estos pasos y realizarlos fuera del horario laboral para evitar que afecte potencialmente a sus clientes:
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Cambiar temporalmente a búsqueda MySQL: habilitar búsqueda MySQL. (Nota: Recuerde volver a cambiar a Elasticsearch o puede que experimente problemas de rendimiento).
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Para identificar índices duplicados, ejecute el siguiente comando:
code language-none curl --silent -X GET localhost:9200/_cat/indices?v
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Para eliminar índices:
code language-none curl -XDELETE localhost:9200/[your_index_name_here]
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Vuelva a habilitar el Elasticsearch.
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Ejecute un reindexado completo.
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Compruebe el estado de los índices ejecutando el siguiente comando:
code language-none curl --silent -X GET localhost:9200/_cat/indices?v
Si estos pasos no funcionan, envíe un vale de soporte técnico.
Lectura relacionada
Para obtener más información, consulte la API de estado de clúster de Elasticsearch.