order.txt ファイルを使用したメニューのカスタマイズ

メニューに関連付けられた order.txt ファイルを編集して、メニューの外観をカスタマイズできます。

この節の手順は、あらゆる種類のメニューで利用できます。

order.txt ファイルを編集してメニューをカスタマイズするには

  1. Profile Managerの​プロファイル名​列で、order.txtファイルのチェックマークを右クリックし、Make Local​をクリックします。

  2. User列のorder.txtファイルのチェックマークを右クリックし、Open/in Notepad​をクリックします。 order.txtファイルが表示されます。

    ステップ情報

  3. (オプション)必要に応じて、ファイルの上部にある「[包括的]」または「[排他的]」設定を追加変更します。 この設定は、order.txtファイルに指定されていないがProfile Managerに存在する項目をメニューに表示するかどうかを制御します。 次のオプションがあります。

    • [Inclusive]: これはデフォルト設定です。この設定では、order.txt ファイルに指定されていないメニュー項目が、メニューの下部にアルファベット順に表示されます。例えば、Profile Managerに上記のorder.txtに示したプロファイル項目の他に項目が含まれている場合、プロファイルは[データ]の下に表示されます。

    • [Exclusive]: この設定を使用すると、 order.txt ファイルで指定されていないメニュー項目がメニューから除外されます。例えば、Profile Managerに、上記order.txtに示したプロファイル項目の他に項目が含まれている場合、プロファイルはメニュー上のどこにも表示されません。

    • 空白: ファイルの上部に「含める」と「 [] 除外する」のいずれも表示されない場合、Data Workbenchには、設定が「含む」であるかのようにメニュー項目が表示され [] []ます。

  4. 次の手順を実行します。

    実行する作業... 手順...

    メニュー項目の並べ替え

    Data Workbenchに表示する順序で項目名を入力します。

    例えば、各メニュー項目名が対応するファイルまたはフォルダーの名前と一致すれば、次のように指定すると「テーブル」が最初に、「ビジュアライゼーション」、「凡例」、「注意」が最後に表示されます。

    テーブル

    ビジュアライゼーション

    凡例

    注意

    メニュー項目の名前の変更

    対応するファイルまたはフォルダーの名前をプロファイルマネージャーで変更して、order.txt ファイルで項目名を変更します。

    例えば、「注意」を「新規注意」に変更するには、プロファイルマネージャーで「注意」フォルダーの名前を「新規注意」に変更して、order.txt ファイルで「注意」項目の名前を「新規注意」に変更します。

    メニュー項目の非表示

    メニュー項目を削除せずに非表示にするには、名前の先頭にマイナス記号(-)を入力します。

    例えば、次のように指定すると、メニューに「注意」が表示されなくなります。

    凡例

    -注意

    非表示のメニュー項目を再度表示するには、マイナス記号(-)を削除するか、 Insight.cfgファイルのUnhide Allパラメーターを使用します。 Insight設定パラメーターを参照してください。

    次の方法でメニュー項目を非表示にすることもできます。

    • .filter.metric または .dim ファイルの Show パラメーターを使用すると、フィルター、派生指標と派生ディメンションおよび拡張ディメンションを各メニューから非表示にできます。このオプションを使用すると、項目はメニューに表示されませんが、プロファイルには存在するので、引き続き使用できます。

      このパラメーターを使用して、フィルター、派生指標および派生ディメンションを非表示にするには、.metric.dim または .filter ファイルの末尾に次の行を追加します。

      show = bool: false

      このパラメーターを使用して拡張ディメンションを非表示にするには、『データセット設定ガイド』の第 10 章で手順を参照してください。

      Insight.cfg ファイルで Unhide All パラメーターを設定して、この方法で非表示にした項目を一時的に表示できます。このパラメーターについて詳しくは、 Insight設定パラメーターを参照してください。

    • Transformation.cfg ファイルまたはいずれかのデータセットインクルードファイルの Hidden パラメーターを使用すると、ディメンションメニューから拡張ディメンションを非表示にできます。このオプションを使用すると、項目はメニューに表示されませんが、プロファイルには存在するので、引き続き使用できます。

      注意:この方法を使用して拡張ディメンションを非表示にする場合は、非表示にするディメンションのデータセットを再変換する必要があります。

      Insight.cfg ファイルで Unhide All パラメーターを設定して、この方法で非表示にした項目を一時的に表示できます。このパラメーターについて詳しくは、 Insight設定パラメーターを参照してください。

    • 0 バイトのファイルを使用すると、任意のメニューの任意の種類の項目を非表示にできます。このオプションを使用すると、空の(0 バイトの)ファイルによって、データを含む同じ名前のファイルが非表示になります。Data Workbenchは、0バイトのファイルを存在しないものとして扱います。 詳しくは、空の(0バイト)ファイルを使用してファイルを隠すを参照してください。

    メニュー項目の削除

    このファイルが [Exclusive] オプションを使用するように設定されている場合は、このファイルからメニュー項目を削除します。項目自体は引き続きプロファイルに存在しますが、メニューには表示されなくなります。

    このファイルが [Inclusive] オプションを使用するように設定されている場合にメニューから項目を削除するには、このファイルからメニュー項目名を削除したうえで、対応するファイルを削除するか、または 0 バイトにする必要があります。

    ファイルの削除の詳細については、「作業プロファイルからのファイルの削除」を参照してください。0バイトファイルについて詳しくは、空の(0バイト)ファイルを使用してファイルを非表示にするを参照してください。

    グループヘッダーの追加

    表示する見出しのテキストの前と後に、3 つハイフンを入力します。

    例えば、次のように指定すると、一連の関連するメニュー項目に「管理」グループヘッダーを追加できます。

    ---管理---

    プロファイル

    データセット

    メニューのセクションを分離するラインの追加

    ラインを表示する場所に 3 つのハイフンを入力します。

    例えば、次のように指定すると、「注意」と「カスタム」を分離するラインが表示されます。

    注意

    カスタム

  5. ファイルを保存して閉じます。

  6. (オプション)作業プロファイルのすべてのユーザーが変更を利用できるようにするには、User列のorder.txtファイルの白いチェックマークを右クリックし、Save to/* working profile name​をクリックします。

このページ

Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now
Adobe Maker Awards Banner

Time to shine!

Apply now for the 2021 Adobe Experience Maker Awards.

Apply now