Gehen Sie zurück zum Anmeldeformular für die Commerce Admin mit dem Fehler "Ihre aktuelle Sitzung ist abgelaufen".
In diesem Artikel finden Sie die möglichen Lösungen für das Commerce Admin-Anmeldeproblem, bei dem Sie zum Anmeldeformular mit der folgenden Fehlermeldung zurückgeleitet werden: "Ihre aktuelle Sitzung ist abgelaufen". Zu den Lösungen gehören die Überprüfung auf Probleme bei der Serverzeiteinstellung und die Änderung der Einstellungen für die Sitzungsspeicherung.
Betroffene Versionen:
Alle Adobe Commerce-Versionen und -Editionen
Problem
Zu reproduzierende Schritte:
- Rufen Sie die Commerce-Admin-Seite auf.
- Geben Sie Ihre Anmeldedaten ein und klicken Sie auf Anmelden.
Erwartetes Ergebnis:
Sie werden beim Commerce-Administrator angemeldet.
Tatsächliches Ergebnis:
Sie werden zum Anmeldeformular zurückgeleitet, wobei die folgende Fehlermeldung angezeigt wird: "Ihre aktuelle Sitzung ist abgelaufen".
Ursache
Es kann zwei mögliche Gründe für das Problem geben:
- Problem mit Serverzeiteinstellungen
- Problem mit Sitzungsspeicherung
Im folgenden Abschnitt finden Sie Lösungen.
Lösung
Probleme mit den Serverzeiteinstellungen prüfen
Überprüfen Sie den Sitzungsdatensatz, der in der Tabelle admin_user_session
erstellt wurde. Wenn die Werte von created_at
und/oder updated_at
falsch sind, kann dies durch das Problem mit Serverzeiteinstellungen verursacht werden. Bitten Sie Ihren Serversystemadministrator, dies zu überprüfen. Beachten Sie, dass die Uhrzeit in DB standardmäßig auf UTC festgelegt ist.
Sitzungsspeicher ändern
Versuchen Sie, den Sitzungsspeicher zu ändern. Verwenden Sie die Informationen aus dem Artikel Wie Sie Ihre Sitzungsdateien finden in unserer Entwicklerdokumentation, um herauszufinden, wo Ihre Sitzung gespeichert ist, und ändern Sie sie durch Bearbeiten der Datei app/etc/env.php
.
Um beispielsweise mit dem Speichern der Sitzung im Dateisystem zu beginnen, ändern Sie den Abschnitt 'session'
wie folgt:
....
'session' =>
array (
'save' => 'files',
),
....
Führen Sie den Befehl bin/magento app:config:import
aus, um Konfigurationsdaten zu importieren.
Verwandtes Lesen
- Importieren von Daten aus Konfigurationsdateien in unserer Entwicklerdokumentation
- Konfigurieren von Redis in unserer Entwicklerdokumentation
- Kehren Sie zurück zum Anmeldeformular für Commerce Admin mit dem Fehler "Ihr Konto ist vorübergehend deaktiviert" in unserer Support-Wissensdatenbank.
- Kehren Sie ohne Fehler zum Anmeldeformular zurück, wenn Sie versuchen, sich bei Commerce Admin in unserer Support-Wissensdatenbank anzumelden.