Leiten Sie mit dem Fehler „Ihre aktuelle Sitzung ist abgelaufen“ zurück zum Commerce Admin Anmeldeformular
In diesem Artikel finden Sie die möglichen Lösungen für das Commerce Admin Anmeldeproblem, bei dem Sie mit der folgenden Fehlermeldung zurück zum Anmeldeformular geleitet werden: „Ihre aktuelle Sitzung ist abgelaufen“. Zu den Lösungen gehören das Überprüfen auf Probleme bei der Server-Zeiteinstellung und das Ändern der Sitzungsspeichereinstellungen.
Betroffene Editionen und Versionen:
Alle Adobe Commerce-Versionen und -Editionen
Problem
Schritte zur Reproduktion:
- Navigieren Sie zur Seite Commerce Admin .
- Geben Sie Ihre Anmeldedaten ein und klicken Sie auf Anmelden.
Erwartetes Ergebnis:
Sie werden beim Commerce Admin angemeldet.
Tatsächliches :
Sie werden zurück zum Anmeldeformular weitergeleitet, wobei die folgende Fehlermeldung angezeigt wird: „Ihre aktuelle Sitzung ist abgelaufen“.
Ursache
Es könnte zwei mögliche Gründe für das Problem geben:
- Ein Problem mit den Server-Zeiteinstellungen
- Ein Problem mit dem Sitzungsspeicher
Suchen Sie im folgenden Abschnitt nach Lösungen.
Lösung
Überprüfen auf Probleme mit den Server-Zeiteinstellungen
Überprüfen Sie den in der admin_user_session
erstellten Sitzungsdatensatz. Wenn die Werte von created_at
und/oder updated_at
falsch sind, kann dies durch ein Problem mit den Server-Zeiteinstellungen verursacht werden. Bitten Sie Ihren Server-Systemadministrator, dies zu überprüfen. Beachten Sie, dass die Zeit in DB standardmäßig auf UTC eingestellt ist.
Ändern des Sitzungsspeichers
Versuchen Sie, den Sitzungsspeicher zu ändern. Verwenden Sie die Informationen aus dem Artikel So finden Sie Ihre Sitzungsdateien in unserer Entwicklerdokumentation, um herauszufinden, wo Ihre Sitzung gespeichert ist, und ändern Sie sie, indem Sie die app/etc/env.php
-Datei bearbeiten.
Um beispielsweise mit dem Speichern einer Sitzung im Dateisystem zu beginnen, ändern Sie den Abschnitt 'session'
wie folgt:
....
'session' =>
array (
'save' => 'files',
),
....
Führen Sie den bin/magento app:config:import
Befehl aus, um Konfigurationsdaten zu importieren.
Verwandtes Lesen
- Daten aus Konfigurationsdateien importieren in unserer Entwicklerdokumentation
- Konfigurieren Redis in unserer Entwicklerdokumentation
- Umleiten zurück zum Commerce Admin-Anmeldeformular mit dem Fehler „Ihr Konto ist vorübergehend deaktiviert“unserer Support-Wissensdatenbank
- Führen Sie ohne Fehler zurück zum Anmeldeformular, wenn Sie versuchen, sich bei der Commerce Admin in unserer Support-Wissensdatenbank anzumelden
- Best Practices zum Ändern von Datenbanktabellen im Commerce-Implementierungs-Playbook