重新導向回Commerce Admin登入表單,並顯示「您目前的工作階段已過期」錯誤

本文提供Commerce Admin登入問題的可能解決方案,其中您被重新導向回登入表單,並顯示下列錯誤訊息: 「您目前的工作階段已過期」。 解決方案包括檢查伺服器時間設定問題,以及變更工作階段儲存設定。

受影響的版本和版本:

所有Adobe Commerce版本和版本

問題

要再現的步驟

  1. 前往​ Commerce Admin ​頁面。
  2. 輸入您的認證,然後按一下​ 登入

預期結果

您已登入Commerce Admin。

實際結果

系統會將您重新導向回登入表單,並顯示下列錯誤訊息: 「您目前的工作階段已過期」

原因

此問題可能有兩個原因:

  • 伺服器時間設定發生問題
  • 工作階段存放區的問題

請檢視下節以取得解決方案。

解決方案

檢查伺服器時間設定問題

檢查admin_user_session資料表中建立的工作階段記錄。 如果created_at和/或updated_at的值不正確,可能是伺服器時間設定問題所造成。 請要求您的伺服器系統管理員進行檢查。 請注意,DB中的時間預設會設為UTC。

變更工作階段存放區

請嘗試變更工作階段存放區。 使用開發人員檔案中如何尋找您的工作階段檔案文章中的資訊,找出您的工作階段儲存位置,並編輯app/etc/env.php檔案加以變更。

例如,若要開始將工作階段儲存在檔案系統中,請變更'session'區段,如下所示:

....
'session' =>
    array (
      'save' => 'files',
),
....

執行bin/magento app:config:import命令以匯入組態資料。

相關閱讀

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a