與帳戶許可權和存取金鑰相關的部署問題

本文提供因存取金鑰所有權衝突而在雲端基礎結構上部署Adobe Commerce所發生問題的解決方案。

受影響的產品和版本

  • 雲端基礎結構上的Adobe Commerce,所有支援的版本

問題

必要條件

雲端授權與連絡人A相關聯(電子郵件地址: first@e.mail)

要再現的步驟

  1. 聯絡A在其帳戶中建立的Adobe Commerce存取金鑰(金鑰X)並將其安裝在雲端。
  2. 連絡人B (電子郵件地址: second@e.mail)使用其帳戶購買擴充功能,並建立安裝擴充功能的存取金鑰(金鑰Y)。
  3. 連絡人A離開了公司,授權(所有權)也轉移到了連絡人B。
  4. 系統整合商嘗試使用索引鍵X在雲端環境中安裝擴充功能。

預期結果

已成功安裝擴充功能。

實際結果

未安裝擴充功能,因為部署失敗。

原因

兩個鍵都會指定給連絡人角色,這會導致衝突。

解決方案

如果對帳戶上的主要連絡人進行變更後部署失敗(原始帳戶和新帳戶各自都有自己的存取金鑰),且金鑰已從原始帳戶轉移到新帳戶,則需要停用原始帳戶的金鑰。 根據上述範例,應該停用索引鍵X。

如何停用存取金鑰

如果您沒有與舊金鑰相關聯的Commerce Marketplace帳戶的存取權,請聯絡Adobe Commerce支援以停用金鑰。

如果您擁有與舊金鑰相關聯的Marketplace帳戶的存取權,請採取以下步驟來停用金鑰:

  1. 使用舊帳號的認證登入Commerce Marketplace

  2. 按一下頁面右上角的帳戶名稱,然後選取​ 我的設定檔

  3. 在Marketplace索引標籤中按一下​ 存取金鑰

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  4. 按一下存取金鑰旁的​ 停用

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