[AEM Assets]{class="badge positive" title="适用于AEM Assets)。"}

管理图像预设 managing-image-presets

图像预设​是预定义、可重复使用的大小调整和格式命令集合,这些命令使​ Adobe Experience Manager (AEM) Assets ​能够动态交付图像。 每个图像预设可控制不同大小、不同格式以及动态生成的图像属性(如颜色空间、压缩质量和分辨率)的图像交付。 这意味着,可以在许多优化变体中交付单个主资产,而无需维护单独的源文件。

图像预设包含的内容

创建图像预设时,您可以定义用于控制如何生成和交付图像的参数。 每个预设都指定:

  • 投放大小 — 在提供图像供查看时使用的尺寸。
  • 格式化命令 — 优化显示图像外观的设置。

这些格式命令可确保每当交付图像以进行查看时,图像的外观都会得到优化,因此每个演绎版在出现它的上下文中看起来都是一致的,并且随时可以显示。

使用预设导出Assets

管理员可以创建专门用于导出资产的预设。 然后,用户在导出图像时选择预设,该预设会按照管理员定义的规范重新设置图像的格式。 因此,导出的资产符合一致、集中管理的标准,无需每个用户手动配置格式。

响应式图像预设和颜色空间

您还可以创建​ 响应式 ​图像预设。 将响应式图像预设应用于资产时,资产会根据查看它们的设备或屏幕大小进行调整。 这种响应式行为有助于将适当大小的图像交付到台式机、平板电脑和移动设备,从而提高各种查看环境的加载性能和视觉质量。

图像预设支持多个颜色空间。 除了​ RGB ​或​ 灰色 ​之外,您还可以将图像预设配置为在色彩空间中使用​CMYK(青色、洋红色、黄色、金钥/黑色),它支持打印导向和色彩管理的交付工作流。

本节介绍如何创建、修改和一般管理图像预设。 无论您何时预览图像,都可以将图像预设应用于图像。 请参阅应用图像预设。

NOTE
智能成像可与您现有的图像预设配合使用,并在交付的最后毫秒内使用智能功能,以根据浏览器或网络连接速度进一步减小图像文件大小。 有关详细信息,请参阅智能成像。

了解图像预设 understanding-image-presets

图像预设​是预定义、可重复使用的大小调整和格式命令集合,这些命令保存在名称下,其功能与宏非常相似。 每个预设都存储了交付图像所需的确切尺寸、格式和压缩设置,从而允许​ Experience Manager ​按需生成源图像的正确优化版本,而不是要求每个大小和设备都使用单独的文件。

图像预设的工作方式

考虑一个常见方案:网站要求每个产品图像以不同的大小、格式和压缩率显示,以实现桌面交付和移动设备交付。 由于现代网站可以将图像提供给多种屏幕大小和设备类型,因此这种多格式投放是响应式Web体验的常规要求。

为此,管理员需创建两个图像预设:

  • Enlarge — 以​ 500 x 500像素 ​显示图像,适合桌面交付。
  • Thumbnail — 以​ 150 x 150像素 ​显示图像,适合移动设备交付。

当对大小为Enlarge或Thumbnail的图像发出请求时,Experience Manager​将查找匹配的​ 图像预设 ​定义。 然后,它动态生成符合该预设中定义的大小和格式规范的图像。 因此,单个源图像能够以多个优化表单交付,而无需维护重复资产。

保持任意大小的图像质量

在动态投放期间减小图像大小会导致其失去锐利度和细节。 为了应对此问题,每个图像预设都包含格式化控件,当以特定大小交付图像时,这些控件会优化图像。 这可确保投放的输出保持锐利和清晰,因为预设会为目标维度应用适当的锐化和格式,而不是简单地缩放源。 这些控制功能可使您的图像在访问您的网站或应用程序时清晰易读。

创建图像预设

管理员可以创建图像预设。 管理员可以从头开始构建预设,或者复制现有预设,然后以新名称保存该预设,从而重用已建立的设置作为起点。

管理图像预设 managing-image-presets-1

您可以从“工具”控制台的​Assets > 图像预设​区域管理Experience Manager中的图像预设。 要到达此位置,请执行以下步骤:

  1. 选择​ Experience Manager徽标 ​以打开全局导航控制台。
  2. 选择​ 工具 ​图标。
  3. 导航到​Assets > 图像预设。

65tools-assets-imagepresets

在此图像预设区域,您可以创建、编辑和组织用于控制如何渲染和交付资产的预设。

NOTE
在预览或交付资产时,您创建的任何图像预设也可用作​动态演绎版。 这意味着定义一次的预设可以在预览和交付期间直接重用,而无需每次重新定义演绎版设置。
您不​ 需要 ​手动发布图像预设,因为图像预设是​自动发布的。 因此,新创建的预设将可供交付,而无需单独的发布操作。
请参阅发布图像预设。
NOTE
当您在资产的详细信息视图中选择​ 呈现版本 ​时,系统会显示各种呈现版本。 您可以增加或减少显示的图像预设数,从而允许您定制详细信息视图以仅显示所需的演绎版。 请参阅增加显示的图像预设数。

图像预设与演绎版的关系 how-image-presets-relate-to-renditions

图像预设​定义Dynamic Media如何在请求时交付图像,从而控制最终用户收到的视觉输出。 每个预设都指定一组显示参数,包括:

  • 调整大小 — 投放图像的目标宽度、高度或分辨率
  • 正在格式化 — 用于传递的输出文件格式
  • 压缩 — 应用于图像的质量和文件大小权衡
  • 其他显示参数 — 控制最终图像显示方式的其他设置

演绎版​是资源的已处理版本,在Dynamic Media摄取和处理该资源时生成。 演绎版是投放所依赖的基础图像数据。

图像预设本身不会生成演绎版。 这种区分非常重要:预设是一组投放指令,而不是图像数据的来源。 相反,预设依赖于Dynamic Media在处理资产时创建的演绎版。 因此,预设会在现有演绎版之上应用其大小、格式和压缩规则来生成投放的图像。

由于演绎版是在资产处理期间而不是由预设创建的,因此存在合适的演绎版是预设交付预期输出的先决条件。 在实践中,这意味着资产处理首先建立可用的图像数据,然后图像预设确定在交付时如何呈现该数据。

AEM as a Cloud Service中的演绎版生成 rendition-generation-in-aemaacs

在Adobe Experience Manager (AEM) as a Cloud Service中,AEM使用​ Asset微服务 生成演绎版,这是一种云原生、可扩展的处理功能。 数字资源管理(DAM)更新资源工作流无法在Cloud Service中进行自定义,因为演绎版处理是由受管理的微服务层处理,而不是由可编辑的工作流模型处理。

重要注意事项包括:

  • 将在​ 上载时间 ​生成演绎版,这意味着在每个资源进入系统时自动进行处理。
  • 对​ 处理配置文件 ​的更改仅适用于新上传的资产。 因此,如果需要新演绎版,则必须重新处理现有资源,因为配置文件更改不会为存储库中已存在的内容追溯重新生成演绎版。
  • AEM as a Cloud Service不支持自定义工作流程模型以生成节目;相反,节目控制完全通过处理用户档案实现。

图像预设​在交付时引用可用的演绎版,以提供动态、按需图像变化。 因此,在配置或使用图像预设之前,请确保存在所需的演绎版,因为图像预设无法投放尚未生成的演绎版。

若要控制生成哪些演绎版:

  1. 创建或编辑​处理配置文件。
  2. 配置所需的格式副本定义,指定每个格式副本必须生成的格式、维度和输出设置。
  3. 将处理配置文件应用到相应的文件夹,以便该位置的所有资产继承定义的演绎版设置。

将资源上传到应用了处理配置文件的文件夹时,资源微服务自动生成定义的演绎版。 这种自动化可确保在文件夹中生成一致的演绎版而无需手动干预,这意味着,在AEM as a Cloud Service中控制演绎版生成的主要机制是将资源组织到具有正确处理配置文件的文件夹中。

增加或减少显示的图像预设数 increasing-or-decreasing-the-number-of-image-presets-that-display

预览资产时,您创建的图像预设可用作​动态演绎版。 动态演绎版是资源的动态变体,由预设设置(如大小、格式或压缩)生成,而不是单独存储的文件。 当您从​ 详细信息视图>呈现版本 ​查看资源时,Experience Manager会显示这些动态呈现版本。 您可以增加或减少显示的演绎版限制,这在您维护大量预设库并希望一次看到更多预设或希望更短、更聚焦的列表时很有用。

默认情况下,Experience Manager最多显示​15个图像预设。 调整​ limit ​属性会提高或降低此最大值,以使演绎版列表匹配您的工作流所需的预设数。

增加或减少显示的图像预设数:

  1. 导航到CRXDE Lite (https://localhost:4502/crx/de)。

  2. 导航到/libs/dam/gui/coral/content/commons/sidepanels/imagepresetsdetail/imgagepresetslist上的图像预设列表节点

    increasedecreasethenumberofimagepresetsthatdisplay

  3. 在​ limit ​属性中,将默认设置为​ 15 ​的​ 值 ​更改为所需的数字。

  4. 导航到/libs/dam/gui/coral/content/commons/sidepanels/imagepresetsdetail/imgagepresetslist/datasource处的图像预设数据源

    chlimage1-495

  5. 在limit属性中,将数字更改为所需的数字 — 例如,{empty requestPathInfo.selectors[1] ? "20" : requestPathInfo.selectors[1]}。 此表达式设置当请求路径中未提供显式选择器值时应用的回退限制(在本例中为​20)。

  6. 选择​ 全部保存 ​以应用并保留更新的限制。

创建图像预设 creating-image-presets

图像预设​是一组保存的、可重复使用的图像设置,当您预览或发布​ 时,这些设置会应用于 ​跨图像应用一致的设置。 创建​ 图像预设 ​可确保通过预设处理的每个资产共享相同的维度、格式和渲染选项,从而简化大规模图像投放并减少手动配置。

NOTE
如果使用Internet Explorer 9 (IE9),则新创建的预设在保存后不会立即显示在预设列表中。 要解决此问题,请禁用IE9的缓存。

如果您打算支持摄取​ Adobe Illustrator (AI)、PDF和PostScript (EPS) ​文件,以便生成这些文件格式的动态演绎版,请在创建图像预设之前查看以下信息。

请参阅Adobe Illustrator (AI)、PostScript® (EPS)和PDF文件格式。

如果您打算支持​ INDD ​文件的摄取,以便生成此文件格式的动态演绎版,请在创建图像预设之前查看以下信息。

请参阅InDesign (INDD)文件格式。

创建图像预设:

  1. 在Experience Manager中,选择Experience Manager徽标以访问全局导航控制台,然后转到​工具 > Assets > 图像预设。

  2. 选择​创建。

    chlimage1-496

    note
    NOTE
    若要使此图像预设具有响应性,请擦除​ 宽度 ​和​ 高度 ​字段中的值,并将其留空。 空白维度字段允许演绎版缩放到请求上下文,而不是固定为单一大小。
  3. 在​ 编辑图像预设 ​窗口中,根据需要在​ 基本 ​和​ 高级 ​选项卡中输入值,包括名称。 图像预设选项中概 述了这些选项。 预设显示在左窗格中,可以动态应用于其他资产。

    65imagepreset-edit

  4. 选择​保存。

创建响应式图像预设 creating-a-responsive-image-preset

Adobe Experience Manager中的​ 响应式图像预设 ​是一种图像预设,它提供没有固定像素尺寸的图像,允许渲染的图像自动适应请求设备或视区的大小。 若要创建图像预设,请执行创建图像预设中的步骤。

定义步骤是​将高度和宽度字段留空。 在​ 编辑图像预设 ​窗口中,擦除高度和宽度字段中的任何现有值,以使两者都为空。

将​ 高度和宽度字段留空 ​表示此图像预设为​响应式,从而向Experience Manager发送信号。 因此,预设不会将资产锁定到固定尺寸,而是会提供缩放以适合目标显示上下文的图像。 您可以根据需要调整所有其他图像预设值。

NOTE
要在将图像预设应用于资产时查看​ URL ​和​ RESS ​按钮,必须发布资产。
chlimage_1-79
图像预设和图像资产会自动发布。

图像预设选项 image-preset-options

创建或编辑图像预设时,您具有本节中介绍的选项。 此外,Adobe建议从以下“最佳实践”选项开始:

  • 格式 (基本​选项卡) — 选择​JPEG (联合照相专家组)或其他符合您要求的格式。 所有Web浏览器都支持JPEG图像格式,使其成为Web交付中兼容程度最高的选择,并且在小文件大小和图像质量之间提供了良好的平衡。 但是,JPEG图像使用​有损压缩方案,这意味着会丢弃某些图像数据以减小文件大小。 如果压缩设置过低,则此舍弃流程会引入不需要的可视伪像,例如阻止或分段。 因此,Adobe建议将压缩质量设置为​75,该值可在视觉保真度和小文件大小之间实现最佳平衡。

  • 启用简单锐化 — 不要选择​启用简单锐化。 此锐化滤镜提供的控制精度低于“钝化蒙版”设置,因此将其禁用将保留更精细、可配置性更强的锐化选项。

  • 锐化:重新取样模式 — 选择​锐化2,Adobe建议采用重新取样模式以获得高质量的输出。

基本选项卡选项 basic-tab-options

字段
描述
名称
请输入一个描述性名称,且不含任何空格。 为帮助用户识别此图像预设,请在名称中包含图像大小规范。
宽度和高度
输入交付图像的像素大小。 宽度和高度必须大于0像素。 如果任一值为0,则不会创建预设。 如果两个值都为空,则创建响应式图像预设,允许图像将其投放大小调整为符合请求上下文。
格式
从菜单中选择一种格式。
选择​JPEG (联合图片专家组)可提供以下其他选项:
· 质量 - JPEG质量刻度范围从​1到100。 拖动滑块时比例可见。
·启用JPG色度缩减像素采样 — 人类视觉系统对高频颜色信息的敏感性低于对高频亮度的敏感性。 因此,JPEG图像将图像信息划分为亮度和颜色分量。 当JPEG图像被压缩时,亮度分量以全分辨率保留,而颜色分量通过平均像素组而被缩减采样。 由于颜色分量是平均的,因此缩减取样会将数据量减少到一半或三分之一,并且对感知质量的影响最小。 缩减像素取样不适用于灰度图像。 此技术可减少适用于高对比度(例如,具有覆盖文本的图像)的压缩量。

选择​GIF (图形交换格式)或带有alpha 的 GIF可提供以下额外的​ GIF颜色量化 ​选项:
· 类型 — 选择​自适应 (默认值)、Web​或​Macintosh。 如果选择​ 带有Alpha ​的GIF,则Macintosh选项不可用。
· Dither — 选择​ 扩散 ​或​禁用。
· 颜色数 — 输入从​ 2到256 ​的数字。
· 颜色列表 — 输入逗号分隔的列表。 例如,对于白色、灰色和黑色,请输入000000,888888,ffffff。

选择​PDF (可移植文档格式)、TIFF (标记图像文件格式)或​ 带有Alpha的TIFF ​可提供以下附加选项:
· 压缩 — 选择压缩算法。 PDF的算法选项为​None、Zip​和​Jpeg;TIFF的算法选项为​None、LZW (Lempel-Ziv-Welch)、Jpeg​和​Zip;带有Alpha的TIFF的算法选项为​None、LZW​和​Zip。

选择​PNG(可移植网络图形)、PNG (Alpha为)或​EPS(封装的PostScript)不提供其他选项。
锐化
选择​ 启用简单锐化 ​可在执行所有缩放操作后将基本锐化滤镜应用于图像。 锐化可补偿在图像以与原始图像不同的大小显示时可能产生的模糊。

高级选项卡选项 advanced-tab-options

高级选项卡​将其他配置控件分组,这些配置控件与标准、日常设置分开。 这些选项让经验丰富的用户可以精细地控制大多数用户永远不需要更改的行为,这就是为什么他们被放置在专用选项卡中,而不是主设置视图中。 将高级控件保留在其自己的选项卡中可减少典型用户的混乱,同时仍会向需要它的用户展示强大的配置。

何时使用高级选项卡

高级选项适用于默认行为之外的场景。 在以下情况下,您通常应使用高级选项卡:

  • 默认设置不符合特定的技术或工作流要求。
  • 您需要覆盖用于故障诊断或诊断的标准行为。
  • 需要自定义集成、兼容性或性能调整。
  • 管理员或高级用户正在为专用用例配置环境。

由于此处所做的更改可能会以标准设置所没有的方式影响稳定性或行为,因此最佳实践是在修改每个选项之前对其进行查看。

常用高级选项卡选项

虽然确切的控件因应用程序而异,但“高级”选项卡通常会整合以下设置:

  • 性能和资源控制 — 用于调整应用程序如何使用内存、处理或缓存的选项。
  • 兼容性设置 — 切换以适应旧系统、备用格式或特定环境的行为。
  • 日志记录和诊断 — 启用详细日志或调试输出以帮助识别问题的控件。
  • 安全和访问控制 — 管理权限、加密或身份验证行为的设置。
  • 自定义和实验性功能 — 默认情况下不启用可选功能。
  • 重置和还原控件 — 将高级设置返回到默认状态的选项。

为何分隔高级选项

高级设置与主界面隔离,因为它们具有更改核心行为的更高可能性。 这种分离确保日常用户体验更简单,而高级用户保留对详细配置的完全访问权限。 因此,高级选项卡可用作受控空间,在该空间中,您可以刻意进行更深入的调整,而不是意外进行。

对于大多数用户,默认配置就足够了,无需修改“高级”选项卡。 但是,如果需要进行自定义,这些选项可以灵活地根据给定工作流、环境或要求定制应用程序。

锐化:定义和概述

锐化​是一种图像处理技术,它通过增强​边缘对比度(沿相邻区域边界亮度或色调的差异)来提高图像的外观细节和清晰度。 用技术术语来说,锐化会提高图像的​锐度,这是对边缘处突然色调过渡程度的度量。 因此,边缘看起来更清晰,细微的细节对于观看者来说变得更加清晰,即使锐化不会添加真正的新信息,而这些信息尚未被捕获。

锐化的工作方式

锐化的操作方式是在边缘处放大局部对比度,而不是均匀地在整个图像中放大。 当在较亮和较暗区域之间检测到边界时,该过程使所述过渡的较亮侧变亮,并使所述过渡的较暗侧变暗。 由于人类视觉系统将高边缘对比度解释为锐化,因此这种选择性调整使图像读取更加聚焦和详细。

大多数锐化方法的常见核心步骤包括:

  1. Edge检测 — 识别发生显着色调过渡的位置。
  2. 对比度放大 — 增加每个检测到的边缘的浅边和深边之间的差异。
  3. 强度和半径的控制 — 确定效果有多强,以及它围绕每个边缘延伸多远。

常用锐化方法

  • 钝化蒙版(USM):​尽管名为​钝化蒙版(USM),但该技术会锐化图像。 它的工作原理是从原始图像中减去模糊(不锐化)的图像副本来隔离边缘,然后沿着这些边缘提高对比度。 超声马达由于能精确控制超声振动的强度和传播而得到广泛应用。
  • 高通滤波:​此方法可隔离图像的高频部分(这些高频部分对应于细微的细节和边缘),并增强高频部分,从而提高感知的锐度。
  • 基于反褶积的锐化:​更高级的方法尝试反转特定形式的模糊,恢复捕获期间丢失的详细信息。

实际应用

锐化应用于摄影、数字成像、打印和显示技术。 在工作流的两个阶段尤为有用:

  • 捕获锐化​补偿相机传感器和镜头引入的微弱柔化。
  • 输出锐化​为最终介质准备图像,因为打印和缩减缩放可以减少表面细节。

如果应用得当,锐化可以恢复专业图像应有的清晰感。 但是,如果应用过度,它会在边缘产生明亮或暗的​ 光晕 ​和放大噪声,因此限制和适当的设置对于自然结果至关重要。

字段
描述
颜色空间
为色彩空间选择 RGB、CMYK、 或灰度。
颜色配置文件
如果资产与工作配置文件不同,请选择您希望将资产转换为的输出色彩空间配置文件。
渲染方法

可以覆盖默认的渲染方法。 渲染意图决定了在目标颜色配置文件(超出色域)中无法重现的颜色会发生什么情况。 如果渲染意图与ICC配置文件不兼容,则会将其忽略。

  • 选择 可感知 可在原始图像中的一种或多种颜色超出目标颜色空间的色域时,将总色域从一个颜色空间压缩到另一个颜色空间。
  • 当当前颜色空间中的颜色超出目标颜色空间中的色域时,选择相对色度。 并且您希望将其映射到最接近的目标色域,而不更改其他颜色。
  • 如果要在转换为目标色彩空间时重现原始图像色彩饱和度,请选择饱和度。
  • 选择 绝对色度 以完全匹配颜色,而不调整会改变图像亮度的白点或黑点。
黑场补偿
如果输出配置文件支持此功能,请选择此选项。 如果黑场补偿与指定的ICC配置文件不兼容,则忽略黑场补偿。
仿色
选择此选项可避免或减少可能出现的颜色分段伪像。
锐化类型

选择无、锐化或钝化蒙版。

  • 如果要禁用锐化,请选择无。
  • 选择 锐化 可在执行所有缩放操作后对图像应用基本锐化滤镜。 锐化有助于弥补在以不同大小显示图像时可能产生的模糊。
  • 如果要对最终取样缩小的图像微调锐化滤镜效果,请选择钝化蒙版。 您可以控制效果的强度、效果的半径(以像素为单位)以及被忽略的对比度阈值。 此效果使用与Photoshop的“钝化蒙版”滤镜相同的选项。

在 USM锐化 中,您可以选择以下选项:

  • 数量 — 控制应用于边缘像素的对比度。 缺省实数值为1.0。 对于高分辨率图像,最高可将其增加到5.0。 将“量”视为滤镜强度的度量。
  • 半径 — 确定边缘像素周围影响锐化的像素数。 对于高分辨率图像,请输入1到2之间的实数。 低值仅锐化边缘像素;高值锐化较宽范围的像素。 正确的值取决于图像的大小。
  • 阈值 — 确定在应用钝化蒙版滤镜时要忽略的对比度范围。 换言之,此选项定义锐化的像素与周围区域必须存在多大差异,才能被视为边缘像素并进行锐化。 为避免引入噪声,请尝试使用2到20之间的整数值。
  • 应用于 — 确定取消锐化是应用于每种颜色还是亮度。

中介绍了锐化 在Experience Manager Dynamic Media中使用图像锐化视频、锐化图像联机帮助主题以及在Dynamic Media Classic中锐化图像的最佳实践可下载的PDF。

重新取样模式

选择 重新取样模式 选项。 在缩减图像取样时,以下选项会锐化图像:

  • 双线性 — 最快速的重新取样方法。 会出现一些锯齿伪像。
  • 两次立方 — 增加CPU的使用,但生成较锐利的图像,出现的锯齿伪像较少。
  • 锐化2 — 可以生成比两次立方更锐利的结果,但成本更高CPU。
  • 两次锐化 — 为减小图像大小选择Photoshop默认重新取样器,在Adobe Photoshop中将其称为两次锐化。
  • 每种颜色和亮度 — 每种方法都可以基于颜色或亮度。 默认情况下,每个颜色都处于选中状态。
打印分辨率
选择用于打印此图像的分辨率;默认值为72像素。
图像修饰符

除了UI中可用的常见图像设置之外,Dynamic Media还支持您可以在 图像修饰符 字段中指定的大量高级图像修改。 这些参数在图像服务器协议命令引用中定义。

重要信息:不支持API中列出的以下功能:

  • 基本模板化和文本渲染命令: text= textAngle= textAttr= textFlowPath= textFlowXPath= textPath=和 textPs=
  • 本地化命令: locale=和 req=xlate
  • req=set 不可用于一般用途。
  • req=mbrset
  • req=saveToFile
  • req=targets
  • template=
  • 非核心Dynamic Media服务:SVG、图像渲染和Web到打印

使用图像修饰符定义图像预设选项 defining-image-preset-options-with-image-modifiers

图像修饰符扩展了“基本”和“高级”选项卡中可用的选项,让您在定义图像预设时获得更多控制权。 图像渲染依赖于Dynamic Media图像渲染API,并在HTTP协议引用中详细定义。 每个修饰符都是一个图像提供命令(由运算符命令的​ op_前缀 ​标识),用于转换渲染图像的显示方式。

以下是一些使用图像修饰符可以执行操作的基本示例。

NOTE
某些图像修饰符不能在Experience Manager中使用。
  • op_invert — 反转每个颜色组件以获得负图像效果。 将该值设置为​ 1 ​将启用反转,从而生成照相负片。

    code language-xml
    
    &op_invert=1
    

    65imagepreset-edit-invert

  • op_blur — 将模糊滤镜应用于图像。 值越大,软化效果越强;下面的示例应用了​ 7 ​的模糊强度。

    code language-xml
    
    &op_blur=7
    

    65imagepreset-edit-blur

  • 组合命令 — 您可以在单个请求中链接多个图像修饰符,以便同时应用这两种效果。 以下内容将​ op_invert ​和​ op_blur ​组合在一起,反转颜色并在一个渲染输出中应用7的模糊。

    code language-xml
    
    &op_invert=1&op_blur=7
    

    chlimage1-80

  • op_brightness — 降低或增加图像的亮度。 提供的值用于调整亮度,因此提高亮度可以使图像变亮,降低亮度可以使图像变暗。 此示例应用亮度值​58。

    code language-xml
    
    &op_brightness=58
    

    65imagepreset-edit-brightness

  • opac — 调整图像不透明度,从而减少前景不透明度,使图像变得更加透明。 该示例将不透明度值设置为​29。

    code language-xml
    
    opac=29
    

    65imagepreset-edit-opacity

编辑图像预设 modifying-image-presets

Experience Manager中的图像预设是可重复使用的、已保存的配置,用于定义如何动态调整图像大小、设置图像格式以及优化图像交付。 编辑现有图像预设可让您更新这些设置,以便从该预设生成的每个图像演绎版都反映新的配置。

要编辑现有的图像预设,请执行以下步骤:

  1. 在Experience Manager中,选择Experience Manager徽标以访问全局导航控制台,然后转到​工具 > Assets > 图像预设。

    65imagepreset-editpreset

  2. 选择预设,然后选择​编辑。 将打开​ 编辑图像预设 ​窗口。

  3. 对预设设置进行更改,然后选择​ 保存 ​以应用并保存更新的配置,或选择​ 取消 ​以放弃更改。 选择​ 保存 ​可确保从预设生成的每个图像演绎版立即采用更新的设置。

发布图像预设 publishing-image-presets

图像预设​是​自动为您发布的。 图像预设​是一种可重用的配置,它定义如何处理并交付图像,包括大小调整、裁切、格式和质量等设置,以便能够在多个资产中一致地应用相同的处理方式。

由于发布是自动进行的,因此无需单独的手动发布步骤。 因此,您创建或更新的每个图像预设都可供使用,无需您执行其他操作。 这可以确保预设保持同步并立即可用,从而减少取消发布或配置过时的风险。

自动发布的工作原理

  • 创建或修改图像预设时,系统​会自动为您发布该预设。
  • 然后,发布的预设将可用于根据其定义的设置交付图像。
  • 无需手动发布工作流即可激活预设。

自动发布的优势

  • 没有手动步骤:​预设不需要单独发布,简化了工作流程。
  • 一致性:​自动发布使预设保持当前状态并均匀应用于各个图像。
  • 可靠性:​它减少了使用过时或未发布的预设的可能性,从而确保图像按配置交付。

删除图像预设 deleting-image-presets

删除图像预设会将其从Dynamic Media中永久删除,以便在对资产应用基于预设的渲染时不再可用。 由于删除是永久性的,因此Dynamic Media要求先确认再完成操作。

  1. 在Experience Manager中,选择Experience Manager徽标以访问全局导航控制台,然后选择​ 工具 ​图标。
  2. 导航到​Assets > 图像预设。
  3. 选择要删除的预设,然后选择​删除。 Dynamic Media会显示确认提示,以验证是否要删除选定的预设。 存在此确认步骤以防止意外删除。 选择​ 删除 ​以永久删除预设,或选择​ 取消 ​以返回​ 图像预设 ​而不进行更改。
recommendation-more-help
experience-manager-cloud-service-help-main-toc