如何检查禁用cron的原因
本文为云基础架构产品上的Adobe Commerce中的cron问题提供了故障排除解决方案。
受影响的产品和版本
- 云基础架构上的Adobe Commerce,所有版本
问题
以下是cron问题的症状:
您注意到您的cron未运行。
例如:您在app/etc/env.php
文件中看到以下行:
array (
'enabled' => 0
),
空数组表示cron已启用 :
array (
),
原因
cron当前处于非活动状态的原因有多种:
- 由于缺少OpCache设置,cron已禁用。
- 基础架构团队禁用了您的cron,因为它导致您的站点性能不佳/不可用。
- 未重新启用cron,因为您的部署失败。
请参阅以下部分之一,了解您的问题的解决方案。
解决方案
针对缺少OpCache设置的解决方案 solution-missed-opcache-settings
查看Commerce知识库中由于配置错误或缺少 OpCache 设置🔗而停止的Cron 。
基础架构团队禁用的解决方案 solution-disabled-by-infrastructure-team
- 检查您以前的支持工单,其中您的站点已关闭或未响应。
- 然后,检查基础架构团队是否表明他们已禁用该功能。
- 确认您已解决基础架构团队提出的问题/顾虑。
- 如果您需要进一步的帮助来请求重新启用cron,请提交支持请求,并解释您如何解决了基础架构团队指出的问题。
部署解决方案失败 solution-deployment-failed
检查部署日志:
- 在我们的Commerce on Cloud Infrastructure指南中查看和管理日志。
- 正在检查部署日志,如果Cloud UI在Commerce知识库中存在
log snipped
错误。
-
如果部署在
setup:upgrade
步骤中失败,则不会重新启用cron。
例如:您会在部署日志中看到以下行:The command "/bin/bash -c "set -o pipefail; php ./bin/magento setup:upgrade --keep-generated --ansi --no-interaction | tee -a /app/$<project_id>/var/log/install_upgrade.log"" failed. Cache types config flushed successfully
-
否则,部署可能在其他某个阶段失败。 检查部署日志,并确保这两行都显示(如下示例)。 如果您在日志中未看到与此类似的两行,则表示cron未重新启用:
[2024-03-06T10:55:39.345564+00:00] INFO: Disable cron
…[2024-02-07T10:50:09.579005+00:00] INFO: Enable cron
如果需要进一步的帮助,提交支持请求。
recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a