Dåliga prestanda i integreringsmiljöer
Den här artikeln innehåller en lösning på problemet med att Pro-integreringsmiljöerna och Starter-testmiljöer fungerar dåligt.
Berörda produkter och versioner:
- Adobe Commerce om molninfrastruktur (alla versioner)
Problem
Din Pro-integreringsmiljö eller Starter-staging fungerar dåligt.
Orsak
Beroende på storleken på katalogen/data eller kraven för integreringar/anpassningar från tredje part kan de tillgängliga resurserna i integreringsmiljöerna ha överskridits.
Lösning
För att åtgärda prestandaproblem måste du se till att du följer de bästa metoderna för bästa prestanda i integreringsmiljön. Du kan också behöva begära en uppgradering av miljöerna för att förbättra integreringen.
Kontrollera först om miljön finns på konfigurationen för förbättrad integrering.
Kontrollera distributionsloggen på något av följande sätt.
Metod 1:
Kör följande kommando med CLI i molnet:
magento-cloud activity:log -e <branch name>
Metod 2:
Kontrollera den senaste distributionsloggen för den miljön i molnkonsolen.
Om du ser något liknande i slutet av distributionsloggen, den första raden som visar storleken=XL, och de återstående raderna visar storleken=L, innebär det att du använder konfigurationen Förbättrad integrering.
Environment configuration
mymagento (type: php:8.2, size: XL, disk: 5120)
mysql (type: mysql:10.6, size: L, disk: 5120)
redis (type: redis:7.2, size: L)
opensearch (type: opensearch:2, size: L, disk: 1024)
rabbitmq (type: rabbitmq:3.12, size: L, disk: 1024)
Om du inte har den förbättrade integreringskonfigurationen kan du begära en förbättring/uppgradering.
Om du redan använder konfigurationen Förbättrad integrering eller fortfarande stöter på prestandaproblem efter uppgraderingen bör du följa de bästa metoderna för optimala prestanda i integreringsmiljön:
Om du har uppfyllt ovanstående rekommendationer skickar du en supportförfrågan för ytterligare hjälp.