Det går inte att ändra sökmotorn med Commerce Admin (sökmotormenyn är inte tillgänglig)
Varning: MySQL-katalogsökmotorn tas bort i Adobe Commerce 2.4.0. Du måste ha konfigurerat Elasticsearch-värddatorn innan du installerar version 2.4.0.
Se:
Installera och konfigurera Elasticsearch
Installera och konfigurera OpenSearch
Installera och konfigurera Live Search
Den här artikeln innehåller en lösning för att ändra Adobe Commerce Search Engine med Commerce Admin om fältet Sökmotor inte visas eller om kryssrutan Använd systemvärde är nedtonad och inte tillgänglig.
Beskrivning description
Miljö
-
Lokal Adobe Commerce: 2.4.X
-
Adobe Commerce om molninfrastruktur:
- Version: 2.4.X
- Arkitektur för Starter och Pro
-
MySQL, Elasticsearch, Opensearch, Live Search: alla versioner som stöds
Ändra sökmotor med hjälp av administratören (steg)
-
Logga in på Admin som administratör.
-
Klicka på Store till vänster om sidofältet Admin.
-
Välj Konfiguration under Inställningar.
-
Navigera till panelen till vänster under Katalog och välj Katalog.
-
Expandera avsnittet Katalogsökning.
-
Gå till fältet Sökmotor och ta bort markeringen från kryssrutan Använd systemvärde.
-
Klicka på menyn Sökmotor och välj ett av de tillgängliga alternativen som visas nedan.
-
Klicka på Spara konfiguration i det övre högra hörnet på sidan.
Problem med Adobe Commerce lokalt
Problem 1: Fältet Sökmotor visas inte
När du öppnar avsnittet Katalogsökning visas inte menyn Sökmotor alls.
Orsak: Butiksvyn är inte en standardkonfiguration
Butiksvyn för administratören har angetts till ett annat värde än Standardkonfiguration.
Sökmotorn är en global konfigurationsuppsättning på programnivå, inte på Store-scopet. Lager i ett Adobe Commerce-program kan inte använda olika sökmotorer.
Problem 2: Det går inte att avmarkera Använd systemvärde
När du öppnar avsnittet Katalogsökning i Admin är kryssrutan Använd systemvärde nedtonad, så du kan inte ta bort markeringen från kryssrutan för att senare ändra sökmotorn.
Orsak
Standardsökmotorn har konfigurerats på programkonfigurationsnivån i filerna app/etc/env.php
eller app/etc/config.php
och kan därför inte ändras med Admin.
Exempel på avsnittet med standardkonfiguration för sökmotor:
'system'=>
array (
'default'=>
array (
'catalog'=>
array (
'search'=>
array (
'engine'=>'mysql',
),
),
),
),
Upplösning resolution
Problem 1: Fältet Sökmotor visas inte
Lösning: Ange standardkonfiguration för butiksvyn
-
Logga in på Admin som administratör.
-
Klicka på Store till vänster om sidofältet Admin.
-
Navigera till Inställningar och välj Konfiguration.
-
Klicka på väljaren Store-vy i det övre vänstra hörnet och välj Standardkonfiguration.
-
Klicka på OK i bekräftelsedialogrutan för att godkänna ändringarna i butiksvyn.
Relaterad dokumentation: Ändrar omfång i vår användarhandbok.
Problem 2: Det går inte att avmarkera Använd systemvärde
Lösning
Ta bort avsnittet med standardsökmotorkonfigurationen från app/etc/env.php
- eller app/etc/config.php
-konfigurationsfilerna.
Relaterade artiklar i vår utvecklardokumentation
Adobe Commerce konfigurationsfiler i Adobe Commerce Configuration Guide
Adobe Commerce i molninfrastruktur
Det går inte att växla sökmotorer med hjälp av Admin i Adobe Commerce i molninfrastruktur på grund av hur molninfrastrukturen har organiserats.
Under distributionsprocessen kontrollerar Adobe Commerce-skript för molninfrastruktur om Elasticsearch har deklarerats i variabeln MAGENTO_CLOUD_RELATIONSHIPS
. Om detta deklareras väljs Elasticsearch som aktiv sökmotor och konfigureras automatiskt. MySQL-sökmotorn blir inte tillgänglig i Admin. Om Elasticsearch-relationen inte har deklarerats är MySQL aktiverat och Elasticsearch blir inte tillgängligt.
Vi rekommenderar inte att du redigerar app/etc/env.php
- eller app/etc/config.php
-konfigurationsfilerna direkt i molnmiljön. Därför bör du inte ändra de här filerna så att Elasticsearch-motorn visas i Admin (den lösning vi rekommenderar i föregående avsnitt) i ditt molnprojekt.
Ändra sökmotor i miljöer för förproduktion och produktion
Innan du byter sökmotor från MySQL till Elasticsearch i dina miljö för förproduktion och produktion bör du kontrollera att du tidigare har skickat in en supportanmälan som begär att Elasticsearch ska aktiveras i miljön och att biljetten har lösts.
Om du vill ändra sökmotorn som används i dina miljö för förproduktion och produktion ändrar du miljövariabeln SEARCH_CONFIGURATION
i din .magento.env.yaml
-fil på den lokala miljön och sedan ändrar du miljöerna för integrering och förproduktion/produktion så att ändringarna börjar gälla.
Om du byter till Elasticsearch 7 kan variabeln SEARCH_CONFIGURATION
i den resulterande .magento.env.yaml
-filen se ut så här:
stage:
deploy:
SEARCH_CONFIGURATION:
engine: elasticsearch7
elasticsearch_server_hostname: hostname
elasticsearch_server_port: '12345'
elasticsearch_index_prefix: magento
elasticsearch_server_timeout: '15'
Om du byter till OpenSearch (i 2.4.6 och senare) kan variabeln SEARCH_CONFIGURATION
i den resulterande .magento.env.yaml
-filen se ut så här:
stage:
deploy:
SEARCH_CONFIGURATION:
engine: opensearch
elasticsearch_server_hostname: hostname
elasticsearch_server_port: '12345'
elasticsearch_index_prefix: magento
elasticsearch_server_timeout: '15'
Om du byter till Live Search kan variabeln SEARCH_CONFIGURATION
i den resulterande .magento.env.yaml
-filen se ut så här:
stage:
deploy:
SEARCH_CONFIGURATION:
engine: livesearch
Relaterad dokumentation
Kunskapsbas för support
Dokumentation för utvecklare
- Konfigurera Elasticsearch-tjänsten
- Skapa och distribuera (dokumentation om konfigurationsfilen
.magento.env.yaml
) - Distribuera variabler (SEARCH_CONFIGURATION-avsnittet)
- Tjänster (dokumentation om konfigurationsfilen
.magento/services.yaml
) - Live Search