Det går inte att ändra sökmotorn med Commerce Admin (sökmotormenyn är inte tillgänglig)

Den här artikeln innehåller en lösning för att ändra Adobe Commerce Search Engine med Commerce Admin om fältet Sökmotor inte visas eller om kryssrutan Använd systemvärde är nedtonad och inte tillgänglig.

I den här artikeln:

Berörda versioner

  • Lokal Adobe Commerce: 2.4.X

  • Adobe Commerce om molninfrastruktur:

    • Version: 2.4.X
    • Arkitektur för Starter och Pro
  • MySQL, Elasticsearch, Opensearch, Live Search: alla versioner som stöds

Ändra sökmotor med hjälp av administratören (steg)

  1. Logga in på Admin som administratör.
  2. Klicka på Stores till vänster om sidofältet Admin.
  3. Välj Configuration under Settings.
  4. Navigera till panelen till vänster under Catalog, och välj Catalog.
  5. Expandera avsnittet Catalog Search. catalog_menu.png
  6. Gå till fältet Search Engine och ta bort markeringen från kryssrutan Use system value.
  7. Klicka på menyn Search Engine och välj ett av de tillgängliga alternativen som visas nedan. search_engine_menu.png
  8. Klicka på Save Config längst upp till höger på sidan.

Problem med Adobe Commerce lokalt

Problem 1: Fältet Sökmotor visas inte

När du öppnar avsnittet Katalogsökning visas inte menyn Sökmotor alls.

search_engine_not_displayed.png

Orsak: Butiksvyn är inte en standardkonfiguration

Butiksvyn för administratören har angetts till ett annat värde än Standardkonfiguration.

Sökmotorn är en global konfigurationsuppsättning på programnivå, inte på Store-scopet. Lager i ett Adobe Commerce-program kan inte använda olika sökmotorer.

Lösning: Ange standardkonfiguration för butiksvyn

  1. Logga in på Admin som administratör.
  2. Klicka på Stores till vänster om sidofältet Admin.
  3. Navigera till Settings och välj Configuration.
  4. Klicka på väljaren Store View i det övre vänstra hörnet och välj ***Standardkonfiguration ***.
  5. Klicka på OK i bekräftelsedialogrutan för att godkänna ändringarna i butiksvyn.

change_store_view.png

Relaterad dokumentation: Ändra omfång i vår användarhandbok.

Problem 2: Det går inte att avmarkera Använd systemvärde

När du öppnar avsnittet Katalogsökning i Admin är kryssrutan Använd systemvärde nedtonad så att du inte kan ta bort markeringen från kryssrutan för att senare ändra sökmotorn.

Orsak

Standardsökmotorn har konfigurerats på programkonfigurationsnivån i filerna app/etc/env.php eller app/etc/config.php och kan därför inte ändras med Admin.

Exempel på avsnittet med standardkonfiguration för sökmotor:

'system'=>
array (
'default'=>
array (
'catalog'=>
array (
'search'=>
array (
'engine'=>'mysql',
),
),
),
),

Lösning

Ta bort avsnittet med standardsökmotorkonfigurationen från app/etc/env.php- eller app/etc/config.php-konfigurationsfilerna.

Relaterade artiklar i vår utvecklardokumentation

Adobe Commerce konfigurationsfiler i Adobe Commerce Configuration Guide

Adobe Commerce i molninfrastruktur

Det går inte att växla sökmotorer med Admin i Adobe Commerce i molninfrastruktur på grund av hur molninfrastrukturen har organiserats.

Under distributionsprocessen kontrollerar Adobe Commerce-skript för molninfrastruktur om Elasticsearch har deklarerats i variabeln MAGENTO_CLOUD_RELATIONSHIPS. Om den deklareras väljs Elasticsearch som aktiv sökmotor och konfigureras automatiskt. MySQL-sökmotorn blir inte tillgänglig i Admin. Om relationen Elasticsearch inte har deklarerats anges MySQL till active och Elasticsearch blir otillgänglig.

Du bör inte redigera app/etc/env.php- eller app/etc/config.php-konfigurationsfilerna direkt i din molnmiljö. Det är därför som ändringar av de här filerna så att Elasticsearch-motorn visas i Admin (den lösning vi rekommenderar i föregående avsnitt) inte gäller för ditt molnprojekt.

Ändra sökmotor i miljöer för förproduktion och produktion

Innan du byter sökmotor från MySQL till Elasticsearch i dina miljö för förproduktion och produktion bör du kontrollera att du tidigare har skickat in en supportanmälan med en begäran om att aktivera Elasticsearch i miljön och att biljetten har lösts.

Om du vill ändra sökmotorn som används i dina miljö för förproduktion och produktion ändrar du miljövariabeln SEARCH_CONFIGURATION i din .magento.env.yaml-fil på den lokala miljön och sedan ändrar du miljöerna för integrering och förproduktion/produktion så att ändringarna börjar gälla.

Om du byter till Elasticsearch 7 kan SEARCH_CONFIGURATION-variabeln i den resulterande .magento.env.yaml-filen se ut så här:

stage:
  deploy:
   SEARCH_CONFIGURATION:
     engine: elasticsearch7
     elasticsearch_server_hostname: hostname
     elasticsearch_server_port: '12345'
     elasticsearch_index_prefix: magento
     elasticsearch_server_timeout: '15'

Om du byter till Opensearch (i 2.4.6 och senare) kan SEARCH_CONFIGURATION-variabeln i den resulterande .magento.env.yaml-filen se ut så här:

stage:
  deploy:
   SEARCH_CONFIGURATION:
     engine: opensearch
     elasticsearch_server_hostname: hostname
     elasticsearch_server_port: '12345'
     elasticsearch_index_prefix: magento
     elasticsearch_server_timeout: '15'

Om du byter till Live Search kan SEARCH_CONFIGURATION-variabeln i den resulterande .magento.env.yaml-filen se ut så här:

stage:
  deploy:
   SEARCH_CONFIGURATION:
     engine: livesearch

Relaterad dokumentation

Support Knowledge Base

Dokumentation för utvecklare

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a