Kontrollera att Elasticsearch är korrekt installerat

I den här artikeln beskrivs lösningar på problem som orsakas av felaktig installation och konfiguration av Elasticsearch (ES).

WARNING
Observera att uppgraderingar av tjänster inte kan implementeras i produktionsmiljön utan att vårt infrastrukturteam får 48 arbetstimmar varsel om detta på Adobe Commerce molninfrastruktur. Detta är nödvändigt eftersom vi måste se till att det finns en infrastruktursupporttekniker tillgänglig som kan uppdatera din konfiguration inom en önskad tidsram med minimala driftavbrott i din produktionsmiljö. Så 48 timmar före när dina ändringar behöver vara i produktion skickar en supportanmälan med information om den serviceuppgradering du behöver och när du vill att uppgraderingsprocessen ska börja.

Versionskompatibilitet för Elasticsearch med Adobe Commerce

  • Adobe Commerce lokalt och Adobe Commerce i molninfrastruktur:

  • Magento Open Source v2.3.0+ stöder ES 5.x och 6.x (men 6.x rekommenderas).

Problem

Följande symtom tyder på att Elasticsearch inte är korrekt konfigurerat:

  • Error: No alive nodes in your cluster - det här felet kan visas i Adobe Commerce-loggar:

    • var/log/system.log
    • var/log/support_report.log
    • var/log/cron.log
    • var/log/exception.log
    • eller i uppmaningen (när du till exempel kör en omindexering)
  • Fel som anger att Elasticsearch inte är kompatibel med din nuvarande version av Adobe Commerce (detta är ett Adobe Commerce-fel som gäller för molninfrastruktur):

    code language-none
    [YYYY-MM-DD HH:MM:SS] CRITICAL: Fix configuration with given suggestions:    - Elasticsearch version #<version> is not compatible with current version of magento    Upgrade elasticsearch version to ~5.0
    

Där version är Elasticsearch-tjänsten som körs i molnmiljön.

Orsak

Elasticsearch är inte korrekt installerat. Detta kan bero på:

  • Ett stavfel i konfigurationsfilen.
  • En version i konfigurationsfilen som inte matchar någon version av Elasticsearch som är installerad för miljön.
  • En version som är korrekt installerad i miljön, korrekt konfigurerad i konfigurationsfilen, men som inte stöds för den installerade versionen av Adobe Commerce.

Lösning

Så här konfigurerar du Elasticsearch:

När du har konfigurerat Elasticsearch kontrollerar du att det är korrekt konfigurerat:

  1. Logga in på servern.

  2. Kontrollera versionsnumret för Elasticsearch (2.x, 5.x eller 6.x) i utdata om att kommandot körs: curl -XGET <Elasticsearch hostname>:<Elasticsearch server port> I Adobe Commerce om molninfrastruktur: curl -XGET localhost:9200

  3. Kontrollera vad som har konfigurerats i Adobe Commerce för konfiguration av molninfrastruktur genom att köra kommandot: php bin/magento config:show catalog/search

  4. Kontrollera catalog/search/engine och se till att den matchar versionsnumret för Elasticsearch. I Adobe Commerce om molninfrastruktur:

    • Elasticsearch 5.X - elasticsearch5
    • Elasticsearch 6.X - elasticsearch6
    • Elasticsearch 2.X - elasticsearch
  5. Kontrollera index_prefix. Om du har flera miljöer måste du se till att du har olika index_prefix-värden för dem.

recommendation-more-help
8bd06ef0-b3d5-4137-b74e-d7b00485808a