Não é possível salvar contato como a chave da URL
Este artigo fornece uma solução alternativa para o problema quando você não pode salvar contato como uma chave de URL (por exemplo, "/contact") para produtos ou páginas do CMS.
Produtos e versões afetados
Adobe Commerce (todos os métodos de implantação) 2.4.x
Problema
Não é possível salvar um produto ou uma página do CMS usando o termo contato como chave de URL. Ao tentar salvar a chave do URL, você recebe um erro que indica que a chave do URL é um URL duplicado.
Etapas a serem reproduzidas:
Crie uma página do CMS com contato como a chave da URL.
Resultado esperado:
A página é salva com contato como a chave da URL.
Resultado real:
Não é possível salvar a página. Você recebe o erro: O valor especificado no campo Chave de URL geraria uma URL que já existe.
Causa
Contato é uma palavra reservada definida em vendor/magento/module-contact/view/frontend/layout/contact_index_index.xml
.
<router id="standard">
<route id="contact" frontName="contact">
<module name="Magento_Contact" />
</route>
</router>
Solução
Você não pode usar o termo contato como sua chave de URL, mas pode usar o termo contato combinado com outra letra ou número (por exemplo, contato1 e contato2). Embora o termo não precise ser contact+<outro número ou letra>, o termo pode ser qualquer cadeia de caracteres, desde que o comprimento não exceda 255 caracteres.
Execute as seguintes etapas:
-
Faça logon no Commerce Admin.
-
Vá para Marketing > SEO & Search > URL Rewrites.
-
Clique em Add URL Rewrite.
-
Selecione Custom no menu suspenso Create URL Rewrite.
- Em Request Path, digite "contato". Observe que o Request Path é o que um usuário insere no navegador e o Target Path é para onde ele deve ser redirecionado.
- Em Target Path, digite a nova chave de URL (por exemplo, "contact1").
- Selecione No no menu suspenso Redirect.
Leitura relacionada
- Substituições de URL em nosso guia do usuário.
- Práticas recomendadas da SEO em nosso guia do usuário.