Conta de sandbox do PayPal não verificada
Este artigo explica por que a conta de sandbox do PayPal para Serviços de pagamento pode não ser verificada, impedindo que você conclua a integração da sandbox.
Produtos e versões afetados
- Os Serviços de Pagamento agora são compatíveis com as versões 2.4.0 a 2.4.4 do Adobe Commerce.
Problema
Nossa documentação de integração instrui você a se inscrever em uma conta do PayPal, fazer logon na conta de desenvolvedores do PayPal e criar uma conta de sandbox. Se você optar por criar uma nova conta durante a integração na janela pop-up de integração do PayPal, o PayPal não poderá verificar sua conta de sandbox e você não poderá concluir a integração.
Etapas a serem reproduzidas:
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Você instala Serviços de Pagamento e configura os Serviços da Commerce.
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Você navega até Serviços de pagamento no Administrador e inicia a integração da sandbox.
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Na janela pop-up de integração do PayPal exibida, você cria uma nova Conta comercial (em vez de fazer logon com uma conta de sandbox do PayPal criada anteriormente) durante a integração.
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Você concluiu com êxito a integração do PayPal.
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Você verá uma notificação no Administrador de que seus pagamentos de sandbox estão pendentes e que você deve confirmar seu endereço de email no PayPal para concluir a integração.
Você não recebeu um email de confirmação porque o PayPal não pôde verificar seu endereço de email.
Causa
O PayPal não poderá verificar sua conta de sandbox e você não poderá concluir a integração da sandbox (o que significa que não é possível aceitar pagamentos ou testar seu modo de sandbox) se criar sua conta de sandbox antes da conta do PayPal.
Solução
- Usando uma conta de sandbox criada no Portal PayPal Developer.
- Clique em redefinir sandbox e reinicie a integração da sandbox.
- Contate o suporte se não conseguir resolver seus problemas de conta para que você possa retomar a integração e aceitar pagamentos.